Glitchy graphics / no GPU acceleration? 6770M

Discussion in 'macOS Sierra (10.12)' started by mixel, Jun 23, 2016.

  1. mixel macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #1
    Hi! Im running the beta on a Mid 2011 iMac (2.7Ghz i5 / 16GB RAM - AMD Radeon JD 6770M) - everything is slooow and dragging things around is jerky, i can see the window refresh swoop down (like what used to happen when kernel panics kick in). There's no transparency, and windows flicker like crazy..

    Is this a known driver issue with the 6770M? Does anyone have a fix? I made a time machine backup, so I can just revert back, but it'd be nicer to fix it if possible, especially as its running so well for some people. :)
     
  2. mixel thread starter macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #2
    Ok, so with a fresh install it seems to work.. using the transfer wizard to copy my stuff over from Time Machine..

    It does it again when I copy stuff back in this way, so I'm guessing it's a .kext.

    ...

    It was my Wacom Cintiq drivers! Now the graphics work as expected again after a driver update. :D
     
  3. redpandadev macrumors member

    Joined:
    Jun 3, 2014
    #3
    There is definitely an issue with the 6770M drivers ATM. I have the same graphics and have found that there are frequent glitches. I have also found that the transparency is there, but the quality is awful - as if the blur effect associated with transparency is set to the lowest quality mode.
     
  4. FNH15 macrumors regular

    Joined:
    Apr 19, 2011
    #4
    I've pulled up some UI elements which use translucency. What exactly are you talking about? Perhaps a clean install is in order?
     

    Attached Files:

  5. redpandadev macrumors member

    Joined:
    Jun 3, 2014
    #5
    Zoom in and check out the areas that I circled. In these areas you can see visible artifacting and lack of smoothing in the translucent blur effect. This is not what the same effect looks like on El Cap
     

    Attached Files:

  6. mixel thread starter macrumors 65816

    mixel

    Joined:
    Jan 12, 2006
    Location:
    Leeds, UK
    #6
    I see weird horizontal lines in the transparency on your screenshot but that looks like jpg compression?.. I don't have those on mine? Since I've updated my Wacom drivers everything is normal seeming.
     
  7. redpandadev macrumors member

    Joined:
    Jun 3, 2014
    #7
    Correct - it looks exactly like heavy jpg compression, but in fact it is rendered on the screen that way for me.
     

Share This Page