Gmail and Mac mail

Discussion in 'Mac Apps and Mac App Store' started by RGSMDNR, Jun 12, 2008.

  1. RGSMDNR macrumors member

    Joined:
    Mar 22, 2008
    Location:
    Canada
    #1
    Im using an imap gmail account, and im curious as to why when i reply to an email in gmail, it doesnt show that i replied to that email in Mac mail. Is there a setting im missing? Ive searched here and the net and cant find an answer, please help!

    thanks!

    D
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Are you replying through the Mail interface, or through Gmail's web interface?
     
  3. DarkHeraldMage macrumors 6502a

    DarkHeraldMage

    Joined:
    Oct 5, 2007
    Location:
    Fort Worth, TX
    #3
    I think ggjstudios caught it. If you're replying in mail, it'll show up in the sent folder, but if you reply on the web interface it won't. That's just how IMAP works. The sent item from the web interface can still be accessed through Mail though by opening the IMAP folder structure. I do this to backup all sent items. Especially since replies from my BlackBerry reside in the web sent mail folder, not the Mac sent folder. Make sense?
     
  4. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #4
    No...

    In Mail, right under where it says GMail and then All Mail, Sent, etc, click each and go to mailbox, use this mailbox for, and select the corresponding mailbox.

    You have to tweak similar settings for an iPhone if you have one.

    This is exactly how I have it set up and my gmail account is the same in the web interface, apple mail and my iPhone.
     
  5. Bjohnson33 macrumors 6502

    Joined:
    Mar 4, 2006
    #5
    Same problem

    I've had the same problem, but never looked very hard to figure out how to fix it. I'm not sure the answers supplied so far quite get it. When new mail arrives, it's marked in Mail with a blue dot beside it. If I'm away from my computer and read that mail from Gmail's web interface, it shows that it has been read in Gmail, but once I get back home, Mail still shows those messages as unread. Any suggestions?
     
  6. Satori macrumors 6502a

    Satori

    Joined:
    Jun 22, 2006
    Location:
    London
    #6
    Have you enabled IMAP?
     
  7. DarkHeraldMage macrumors 6502a

    DarkHeraldMage

    Joined:
    Oct 5, 2007
    Location:
    Fort Worth, TX
    #7
    That means you don't have it setup as IMAP, but instead you've set it up as POP. If you want it to show as read in Mail when you read it elsewhere, adjust your account settings.
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    newappleboy is correct. Using POP, Mail and Gmail don't literally "sync" to reflect changes in each other. Rather, Mail simply downloads a copy of new messages, leaving the unread message on Gmail's server. If you want both to reflect "Read", you have to open the same message in both Mail and the web-based Gmail.

    To change Gmail to IMAP, follow these instructions:

    In Gmail, go to Settings > Forwarding and POP/IMAP > IMAP Access: and Enable

    then,

    http://mail.google.com/support/bin/answer.py?answer=81379
     
  9. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #9
    Yep, I am using IMAP.

    Are you taking about the All Mail folder or the inbox?
     
  10. RGSMDNR thread starter macrumors member

    Joined:
    Mar 22, 2008
    Location:
    Canada
    #10

    I am replying within Gmails web interface. I figured the sent mail folder would sync and let me know which emails i have replied to. Unless that folder isnt set to sync at all.
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    If you read the rest of the posts, you'll see that the only way the sent items folder will sync is with IMAP configured correctly. It will not sync with a POP account.
     
  12. RGSMDNR thread starter macrumors member

    Joined:
    Mar 22, 2008
    Location:
    Canada
    #12
    I think i was just getting confused because there are 3 'Sent' folders that show up in Mail. Also, when i reply to a message in Gmail, it wont show that i have replied to a message in my inbox in Mail. (little arrow icon) Is that something else i need to set up?
     
  13. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #13
    Dude, here: http://5thirtyone.com/archives/862

    Third result on google. Make sure you follow all the instructions.
     
  14. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #14
    The tutorial on the Google website instructs us to NOT let Mail.app store sent messages on the server. When you send IMAP mail using the Gmail outgoing server (smtp.gmail.com), Gmail automatically saves the sent message. You don't want to allow Mail.app to do this for some reason that I can't remember.

    I just set up the IMAP/Gmail combo in Mail.app this past week and found this helpful:
    http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=75726
     
  15. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #15
    Hmmm...

    I followed my guide to a T and have had zero sync issues between mail, my iphone and gmail's web interface.
     
  16. RGSMDNR thread starter macrumors member

    Joined:
    Mar 22, 2008
    Location:
    Canada
    #16
    I followed the directions (and for some reason, this website kept freezing firefox) but when i reply to an email in gmail, i dont get the little arrow in mail indicating that i have replied to that message.
     

Share This Page