• Did you order new AirTags? We've opened a dedicated AirTags forum.

JohnDohe

macrumors member
Original poster
Hi,

Ever since the latest update, my iPhone7+ defaults to the wrong "From" email address when
I want to send a photo.

I take the pic, view it, click the share button, click GMail and the "From" is my wife's email address, not mine.

I have her email account in my iPhone.

My iCloud account is correctly set to my email address.

How do I change Camera in my iPhone to use my email address and not my wife's?

Yes, I can tap on her email address and select mine, but thats a pain and is not the way it behaved before the update.

Thanks!
 

revmacian

macrumors 68000
Oct 20, 2018
1,745
1,460
USA
Hi,

Ever since the latest update, my iPhone7+ defaults to the wrong "From" email address when
I want to send a photo.

I take the pic, view it, click the share button, click GMail and the "From" is my wife's email address, not mine.

I have her email account in my iPhone.

My iCloud account is correctly set to my email address.

How do I change Camera in my iPhone to use my email address and not my wife's?

Yes, I can tap on her email address and select mine, but thats a pain and is not the way it behaved before the update.

Thanks!
What is listed under Settings > Contacts > My Info ?
 
Comment

JohnDohe

macrumors member
Original poster
Problem: I do not have Mail in Settings!

Did a search for Mail too: not there!
[automerge]1576375199[/automerge]
@ revmacian

What is listed under Settings > Contacts > My Info ?

What shows is WORK.

When I tap "My Info" I'm taken to all my Contacts.

"Default Account" shows "On My iPhone" and tapping that
brings up 3 choices:

Gmail

xxxxxxx@gmail.com
(not my #1 email address; an alternate)

On My iPhone

Thoughts?
 
Last edited:
Comment

revmacian

macrumors 68000
Oct 20, 2018
1,745
1,460
USA
Problem: I do not have Mail in Settings!

Did a search for Mail too: not there!
[automerge]1576375199[/automerge]
@ revmacian



What shows is WORK.

When I tap "My Info" I'm taken to all my Contacts.

"Default Account" shows "On My iPhone" and tapping that
brings up 3 choices:

Gmail

xxxxxxx@gmail.com
(not my #1 email address; an alternate)

On My iPhone

Thoughts?
I could be wrong, but if you don't have "Mail" in Settings, you've got bigger problems:

IMG_0006.png
 
Comment

StumpyBloke

macrumors 68040
Apr 21, 2012
3,149
2,714
England
As noted above, if mail isn’t in settings you have got bigger problems. You might need to delete the mail app, then re-download it again from the App Store. And as I’ve already said, you need to change the mail default app to the one that you want.
 
Comment

JohnDohe

macrumors member
Original poster
As noted above, if mail isn’t in settings you have got bigger problems. You might need to delete the mail app, then re-download it again from the App Store. And as I’ve already said, you need to change the mail default app to the one that you want.

You must have Mail settings in there, unless you have deleted the native Mail App? Look beneath Accounts and Passwords.

Not there, trust me, it was not there.

So I went to App Store and downloaded it from Cloud.

I must have deleted the Mail app because I wasn't using it?

Now Mail shows in Settings.

But . . .

There's no setting in Mail to select the default "From" email account.

However . . .

When I go to Camera or Photos, select a photo and then choose the "Share"
icon in the lower-left (a box with an upward pointing arrow), I'm presented with
options as to how to share: AirDrop, Messages, Mail, GMail.

When I tap the GMail app icon, it loads and in the "From" field my wife's email appears.
I can tap it and select mine, but this is a pain. If I leave it alone and Send it to myself
its from her email address.

But . . . when I tap the Mail app, it loads but I cannot see the "From" email address.
When I send it to myself its from my email address.

So Mail is defaulting to the correct "From" email account whereas GMail does not.

Mockingly, when I open the GMail app from my iPhone's home screen and send myself
an email, it correctly shows my email address in the From field.

There isn't a "Default address" option either in the Mail app itself nor in Settings > Mail.

Neither is there a "Default address" option in the GMail app itself nor in Settings > GMail.

So the question remains:
How does one set the default "From" email address when sharing a photo from the Camera
app using the GMail app option?

Thanks!
 
Comment

StumpyBloke

macrumors 68040
Apr 21, 2012
3,149
2,714
England
Please detail the exact path you took to reach your screenshot as,
Home screen > Settings > . . .

Because when I do,
My Home screen > Settings > (my iCloud account) > Name, Phone Numbers, Email
I see under "REACHABLE AT" my correct email address. My wife's email address
is not there.

Thanks!

Don’t go to my iCloud account. It’s just under Settings. In there (Mail) you can chose your default account.
 
Comment

StumpyBloke

macrumors 68040
Apr 21, 2012
3,149
2,714
England
If you can’t see Default Account at the bottom of Mail settings, and you haven’t restarted your phone do so. I’m assuming however, you’ve more than one email account added?
 
Comment

JohnDohe

macrumors member
Original poster
If you can’t see Default Account at the bottom of Mail settings, and you haven’t restarted your phone do so. I’m assuming however, you’ve more than one email account added?
038c464fb64b00ec731e485932fdb637.jpg

Hi,

iPhone rebooted - no change - still no "Default Account" shown:

1576433813285.png


". . . more than one email account added . . ."

Where do I go to check for that?

In Settings > Mail ?

In Settings > iCloud ?

Please advise,
Thanks!
 
Comment

JohnDohe

macrumors member
Original poster
Settings -> Passwords & Accounts

If there is only one account in there, you won’t get the default account option

I have more than one acccount in Settings -> Passwords & Accounts .

What I'm talking about is the GMail app. This is what is putting up
my wife's account whenever I use it to share a photo-pic.

Settings -> GMail shows this:

1576434671322.png


There's nothing here that even hints at setting a default email account.

Thoughts?

Thanks!
 
Comment

StumpyBloke

macrumors 68040
Apr 21, 2012
3,149
2,714
England
I have more than one acccount in Settings -> Passwords & Accounts .

What I'm talking about is the GMail app. This is what is putting up
my wife's account whenever I use it to share a photo-pic.

Settings -> GMail shows this:

View attachment 882966

There's nothing here that even hints at setting a default email account.

Thoughts?

Thanks!

Sorry, no idea. I assumed you were using the default mail app.
 
Comment

JohnDohe

macrumors member
Original poster
Sorry, no idea. I assumed you were using the default mail app. However, I would hazard a guess that the accounts used within the Gmail app will actually be set up within the app itself. That’s how the Microsoft Outlook app works anyway.

Thanks, but nothing in the GMail app itself that allow one
to set a default email account.

:-((
 
Comment

JohnDohe

macrumors member
Original poster
Not th solution I was looking for but . . .

In the upper-right of the GMail app is a small, circular, icon with my initial X
displayed as a white letter X on a purple-violet circle background.

Tapping the X icon showed my secondary personal email accounts as well
as my wife's.

From there tapping Manage accounts on this device showed a full list
of the 4 gmail accounts I may have added to my iPhone's GMail app at some
time in thelong distant & forgotten past, though I suspect these appeared
through some kind of Google wizardry so they can track me, everywhere?

One account had its slider turned to the "off" position - to the left - while the
other 3 are each "on" (including my wife's gmail account) with their sliders
to the right.

I turned her's "off" and tested: the GMail app showed my email in the "From" field.

Turning her's back "on" confirmed: now her gmail account was in the "From" field.

Is this because GMail defaults to an alphabetical listing of email accounts?

My wife's email address starts with a "a" and mine with a "b" .

All my other email accounts start with either a number, or letters that come after "b".

If this is the way the GMail app behaves then thats pretty shoddy.

One should have the option to specify a default account.

Checking further . . .

I went to Settings > Passwords & Accounts and added my wife's gmail account.

Then I went to Photos, selected one to share, chose Mail:
Mail defaulted "From" to my email address. Tapping "From" pulled up a scroll section
from which I could choose any email account for the "From" field including my wife's.

The point is: the Mail app remembered the most recent email account used
in the "From" field whereas the GMail app used the email account with the
highest alphabetical sorting of all email accounts in the list.

Or . . . does the Mail app simply default to the iClould account of the device which,
on my iPhone, is me?

The Mail app allows an account to be turned on or off by sliding the Mail slider
of an account to the left in Passwords & Accounts.

However, the Mail app also has a Calendars slider to chose on or off.

When I tried to turn off the Calendar slider a popup warned me that if I continued
ALL GMail calendars would be removed from my iPhone.

I chose to leave C alendar on for Mail at least until I get around to moving away
from Google entirely. This is not so easy to do. There are so many other accounts
that have my gmailaddress linked. It will be several days, perhaps even weeks,
to plow through all the various online accounts I use and change their email addresses.
Quit a job.

From within the GMail app (clicking the account icon in the upper-right of the screen)
the GMail app allows one to put an account to "sleep" by moving its slider to the left.

Seems pretty simple, but I do not like not having the option to specify a primary
email account for the GMail app to default to when sending/replying to emails.

If anyone has anything to add please comment!

Thanks!
 
Comment

StumpyBloke

macrumors 68040
Apr 21, 2012
3,149
2,714
England
To be honest, I didn’t read your post above as it’s too long (for me). But have you thought about using the built-in mail app rather than the Gmail app? At least then you know you can select a default account.
 
Comment

brucemr

macrumors regular
Sep 25, 2019
160
161
If you always want to send mails from your address on the phone w gmail app, just leave the other 3 off in the gmail app settings.

The true google default account is the first one signed in on specific gmail app, and via specific web browser including on pc. Nothing to do with alphabetical order.

To change default, completely sign out of all, then sign in again making sure you sign in one you want as default first.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.