Gmail app not showing notifications

Discussion in 'iOS 8' started by Rook83, Sep 18, 2014.

  1. Rook83 macrumors newbie

    Joined:
    Sep 18, 2014
    #1
    The only bug I've had is that the Gmail app is no longer receiving push notifications...It doesn't even show that I have received an email until I open the program and swipe to refresh...any solutions? I don'y know if ios8 changed my settings, but they look just fine from before...
     
  2. fivedots macrumors 6502a

    Joined:
    Jun 29, 2011
    #2
    Probably not the issue as mine was working before, but a small Gmail update just hit the App Store.
     
  3. jev425 macrumors 6502

    jev425

    Joined:
    Sep 12, 2014
    Location:
    Seattle, Washington
    #3
    I was having that issue with my mailbox app and I just uninstalled the app and downloaded it back on. A little annoying but it worked.
     
  4. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #4
    Dang, I tried the update...then a delete/reinstall...still no notifications for gmail...thanks for the suggestions though...
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Have you tried opening the app to let it load at least once since updating to iOS 8? I didn't have notifications coming through until I actually opened the app once and then the notifications started appearing after that.
     
  6. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #6
    I sure did...I'm literally not getting any notifications at all...neither is my wife...I may have to take a "wait and see" approach...
     
  7. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #7
    damn...still not working

    ----------

    but now it miraculously works...hahaha so weird
     
  8. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #8
    And it no longer works...it worked for about 24 hours...I have disabled notifications for Mail, and enabled for Gmail App...I have background refresh on for Gmail app...I have enabled All New Mail notifications...What other settings could it be?
     
  9. willrun4fun macrumors member

    Joined:
    Nov 4, 2013
    #9
    Hit hamburger icon and then the gear in the gmail app then goto notifications and make sure it is set to "all new mail".

    It may have gotten set to none for some reason.

    I have also had gmail do this from time to time, especially on weekends. It is up to them to send the push and sometimes they just aren't reliable.
     
  10. liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #10
    Just to make sure the uninstall/install is clean, do this:

    (1) Remove your accounts from the gmail app first: under "Manage accounts", slide the switch to off for your account, press "Edit", and click "Remove"

    (2) Uninstall the gmail app

    (3) Do a hard reset: hold down power button and home button.

    (4) Re-install the gmail app.
     
  11. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #11
    Ok, thanks for that, I just followed your directions...and now we wait...funny I get inundated with email from school and other places all the time...but not when I am testing it out!
     
  12. rbf1138 macrumors 6502

    Joined:
    Dec 22, 2007
    #12
    Keep us updated on this please. I'm having a similar issue. I'm attempting to get used to using the Gmail app as I've lost my Exchange/push ability with my new phone, but I feel like push isn't working fast or sometimes even at all with the Gmail app.
     
  13. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #13
    Dang...back to square one...that didn't work. My settings are all matched with what my wife has on hers, and hers is working just fine. I have even completely restored the iphone last night and still nothing...I'm wondering if I should just transfer everything to the Mail app...but then I heard that I can't get push with gmail on the Mail app...this is kind of an annoying problem to have...
     
  14. fins831 macrumors 6502a

    Joined:
    Oct 7, 2011
    #14
    Have you looked to see if notifications, or badge has been turned off. I had this problem recently, and somehow gmail notifications and badge things were turned off. Fixed it and its working now
     
  15. Rook83 thread starter macrumors newbie

    Joined:
    Sep 18, 2014
    #15
    Appreciate it...badge and notifications are both on...there's gotta be a simple fix for this...something that I'm over thinking...
     
  16. fins831 macrumors 6502a

    Joined:
    Oct 7, 2011
    #16
    Try turning the notifications off, then moving gmail into no notifications. Hard reset the phone. Then move them back up into notifications that are allowed to happen, and turn them on, and give it a test.

    Thats what I would try.

    Second I would log into gmail settings on gmail.com and check if they are allowing pop3/imap gmail push there...otherwise I gotta think about other suggestions.
     

Share This Page