Gmail blocked - Supressing "Cannot get Mail" pop-up

Discussion in 'iOS 6' started by Gizmotoy, Nov 15, 2012.

  1. Gizmotoy macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #1
    My workplace, like many, blocks Gmail. Our cellular reception is poor, so we're able to get on the company Wi-Fi on our iPhones (iMessage, Web, etc.). I have 4 Gmail addresses in my phone and 1 company Exchange address. If I open Mail while on Wi-Fi, I usually have to clear 4 or 8 boxes (though sometimes significantly more) with the following:

    Cannot Get Mail
    The mail server "imap.gmail.com" is not responding. Verify that you have entered the correct account info in Mail settings.

    Just now I literally had to hit OK 24 times in a row before I could use Mail. I can get my Exchange mail just fine, which is what I was trying to do anyway. I'm sure this is because Gmail is blocked, but I'd kill for the ability to be able to suppress this message. This has been frustrating me for awhile, and it's gotten to the point where it's worth figuring out if there's a workaround.

    Any ideas?
     
  2. liteshow, Nov 15, 2012
    Last edited: Nov 15, 2012

    liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #2
    Delete your Gmail accounts on your iphone and re-add them using Microsoft Exchange. Looks like you had previously added them as Gmail which uses Imap (TCP port 143). If you add them as Microsoft Exchange, it will use TCP port 80/443, which should not be blocked. Your server would be m.google.com
     
  3. Gizmotoy thread starter macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #3
    Thanks for the suggestion, but at least in my case, the block is in place for regulatory reasons. The government requires all email originating on our network to be stored for at least 7 years or face huge fines. I'm not going to violate that, so a circumvention method isn't much help in this context.
     
  4. liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #4
    May I suggest that you modify your title to something like Gmail Filtered or something. Now that you explained it, your gmail going through the imap port is not "blocked" but filtered.

    I'm a little confused here. Could you please explain why using my suggestion of Microsoft exchange (tcp port 80/443) would violate the requirements? Is there a specific requirement that you must use IMAP and not other means to connect to your external email servers?

    Put it this way, are you allowed in your company to open a browser and connect to gmail (or hotmail, yahoo, etc)? If you are, then you are not violating any rules using a Microsoft exchange connection since you are using the same TCP ports.
     
  5. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #5
    I think the OP's issue isn't that he can't get his GMAIL while at work - he isn't allowed and I work for a similar organization. He understands and "accepts" that - the issue is that he wants to suspend all the messages that he gets when later he isn't at work and using a different network and has gotten tons and tons of messages telling him that he can't connect.

    I'm not the expert but going into mail in settings and changing to manual would mean that he wouldn't try and connect but then he'd have to go into the work exchange account and do the update request from there - not pretty.
    Anyway it isn't not getting email it is suppressing the messages telling him that he can't.
     
  6. Gizmotoy thread starter macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #6
    liteshow, I'm not sure what you're getting at, exactly. Gmail is completely blocked from the company network. No browser access, no IMAP access, nothing. It's the same for any webmail provider, not just Gmail. Gmail is not just filtered, it's completely blocked off from the network. As I mentioned, my company uses Exchange, not Gmail.

    CTHarrryH's got it exactly right.

    Say I'm at work, but not at my desktop. I want to check my work email. I open Mail, and have to clear 1 "Cannot get Gmail" box for every account for every time Mail tried to connect while I was away. Usually this is somewhere between 4 and 16 or so. Then I can finally interact with my company email account in Mail without further issue (unless Mail tries to connect for new messages while I'm reading).

    Even a single "Problems retrieving mail" box would be acceptable. I did go ahead and submit feedback to Apple a few minutes ago when I couldn't find any settings that looked like they would help.
     
  7. Beelzbub macrumors regular

    Joined:
    Feb 6, 2012
    #7
    Perhaps he could just take the accounts off and use the Gmail app and only launch the app when outside of work?
     
  8. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #8
    You can have different settings on different accounts e.g. I have my personal Gmail on push and my work email on manual fetch. I believe the problem is that just going into the mail app is enough to do a manual update.
     
  9. rmhop81 macrumors 68020

    rmhop81

    Joined:
    Apr 4, 2005
    Location:
    Dallas, TX
    #9
    why not turn off mail when u go into work for those gmail accounts? click ON when you leave....
     
  10. macsrcool1234 macrumors 65816

    Joined:
    Oct 7, 2010
    #10
    The only way to suppress the messages is to entirely disable checking. They are there for a reason: to tell you that they can't connect.

    Your only other option is to jailbreak, in which case you CAN disable the popups. However jb options for iOS 6 are rather limited.
     
  11. rmhop81 macrumors 68020

    rmhop81

    Joined:
    Apr 4, 2005
    Location:
    Dallas, TX
    #11
    i'm not talking about disabling the popups. go into settings/mail/turn off gmail. when he leaves building, turn it back on.
     
  12. Gizmotoy thread starter macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #12
    Gmail App only supports 1 account at a time, unfortunately. Might be worth checking out Sparrow if Google hasn't pulled it from the store. I hadn't considered that.

    It is. Tried leaving my work account as push, and then the Gmail accounts as Fetch Manually, but simply opening the app forces a Fetch.

    I had wanted to avoid tedious setting changes on every account before and after work, but this may be the only way around it. My main concern is that I forget to turn them back on and stop receiving my mail. Thanks for the suggestion.

    They're obviously there for a reason, but it's pretty hard to argue that 24 modal pop-ups for a single error is either useful or justified.

    I typically jailbreak as soon as it's available, but from what I've read it sounds like no one's seriously working on the iPhone 5 at this point, so it's going to be awhile. For future reference, what do you use to block these when jailbroken?
     
  13. liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #13
    Oops! My bad! I misunderstood your initial post.

    I think Beelzbub suggestion might be the your best bet; only work email on mail app, gmail accounts on another app like gmail app. Or if you like Gmail on the built-in mail app, then use different exchange supported app for work.
     
  14. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #14
    If the restriction is mainly around email originating on the network, and setting up Gmail accounts as Exchange would get rid of the pop-up errors (and that's still kind of up in the air really), then wouldn't you still comply? Essentially you would potentially just be receiving your Gmail mail, but not really doing anything with it nor actually writing/sending any messages via Gmail (which seems to be the troublesome part).

    Setting Gmail accounts to manual (and not using push or fetch in any way for them) should also be helpful--although you will still get an error connecting to them when you launch the Mail app, at least it would seem that you should only get one of those pop-ups (per account) when you do that, rather then have a bunch of them queued up.

    Aside from that, turning off mail for Gmail accounts before work and turning it back on after work would get around it, as mentioned.

    Using the Gmail app (and not having any Gmail accounts in iOS Mail app) would also work--it's limited to one account now, but there have bene some recent news that a new version is going to be released in the near future that should support multiple accounts.
     
  15. macsrcool1234 macrumors 65816

    Joined:
    Oct 7, 2010
    #15
    I agree that Apple should make the notifications only appear once, they stupidly appear every time it tries to check and stack against each other.

    You can manage these with an app called "pop-up blocker." It can probably disabled with some manual plist edit as well if you don't want to pay, you can ask over in the JB forum about that though as im not sure.
     
  16. Gizmotoy thread starter macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #16
    Just as an FYI, I filed a bug report with Apple over this. As of 6.0.2 it only presents the message once per server. Finally. :D
     
  17. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #17
    Here's another option, by the way: why not get the Gmail app, and move GMail accounts there? That way you only access them when you open the app.

    I understand the simplicity of having all your mail in one place is lost (I don't use the Gmail app for that very reason), but it appears that you've lost that luxury simply by working where you work. This'll be easier than having to mess around with settings all the time or having to endure the pop-up.
     
  18. Gizmotoy thread starter macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #18
    That feature was only introduced a few weeks ago, and this thread was from back in November. It wasn't an option back then.

    That'd work OK now, but there's really no need since they fixed Mail.
     

Share This Page