Gmail, Exchange and Forwarding

Memzee

macrumors member
Original poster
Mar 22, 2008
57
0
Hey guys,

I've got an e-mail address at my personal domain, and I have set it to automatically forward to my Gmail account. I have also set my Gmail account to 'send mail as' my personal domain as default. So now when I reply through Gmail's web interface the 'from' field defaults to my personal domain address and the person receiving receives as if it's come from my personal domain.

I also have this Gmail account set up using Exchange on my iPhone, and Push works perfectly. However, when I try to reply to these e-mails it replies from my GMail address, and not my personal domain.

How can I fix this?

Thanks.
 

TriJetHero

macrumors 601
Oct 13, 2010
4,953
141
World
Setup a second mail account (i use POP for that), which uses your personal domain for login, but for the SMTP use smtp.gmail.com

Make this your default account in Settings/Email,Contacts, scroll down to find the defaut setting.

Your iphone will now use your personal domain email as default, but sent it through gmail, as you have already setup gmail with the 'sent as', gmail will now sent it using that personal domain address.

When composing a new mail the default is your personal domain email, but you can select your gmail email address manually if needed.
 
Comment

Memzee

macrumors member
Original poster
Mar 22, 2008
57
0
Ah right, so I can't use Exchange for push and have it the way I want too?

Have to go through POP?

Sucks.. the main reason I'm forwarding to Gmail is for the Push.
 
Comment

Memzee

macrumors member
Original poster
Mar 22, 2008
57
0
For anyone that might search this in the future, I got around it by using Sparrow for iPhone.

Setup the gmail account, added my personal email domain as the default alias.
Then installed Sparrow+ on Cydia to give push notifications.
Done.

=)

Now I have to figure out how to get my old offline mbox archive from Mail.app into Gmail.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.