Gmail exchange issue?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rstark18, Jan 26, 2011.

  1. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Has anyone had this issue?
    I have gmail setup using exchange on my iPhone 4 and normally it works fine. Starting about a week ago I noticed when I went to check a previous email it told me my password was incorrect and wouldn't let me log in to retrieve mail. I tried everything to get it working but the only thing that worked was deleting the exchange account and recreating it. Now a week later I am gettng the same thing. I can log in to gmail using the web interface but nothing I do will let me in with my exchange account on my phone. The message says "cannot get mail. The username or password is incorrect." One other thing I should add is that I recently configured my gmail account to retrieve a few of my POP accounts from AT&T.
    Anyone else experience this and have a solution?
     
  2. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #2
    Try changing your password and re-entering it on the iPhone.
     
  3. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #3
    Very strange, I had tried everything I could think of without deleting the exchange account this time (hard reset, turn mail off, etc.). So I decided now would be a good time to do a restore. I plugged it in to do a backup and in the mean time thought I'd try @Warbrain suggestion of changing the password but before getting to the point of changing the password the backup had finished. Now it's working! What in the backup/sync process would reset that profile that a hard reset wouldn't do?
     
  4. solius, Jan 27, 2011
    Last edited: Jan 27, 2011

    solius macrumors regular

    Joined:
    Jul 15, 2010
    Location:
    Decatur AL
    #4
    I'm having the exact same issue with my gmail exchange account. havent been able to fix. It works on my home network and only my home network. hmm... Im also getting the IMAP error sigh...
     
  5. rstark18 thread starter macrumors 6502a

    Joined:
    Sep 18, 2009
    #5
    Have you:
    Synced to iTunes?
    Hard reset the iPhone?
    Deleted the local account (account on iPhone)?

    Are you running imap and exchange for the same Google account?
     

Share This Page