GMail, getting every mail i send....

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Cybergypsy, Jul 2, 2007.

  1. Cybergypsy macrumors 68040


    May 16, 2006
    Central Florida!
    Each time i send a email from my gmail account i get a copy sent to me......where can disable this.....
  2. Compile 'em all macrumors 601

    Compile 'em all

    Apr 6, 2005
    You can't disable it. It has something todo with Gmail and their POP3 access. It is the same case when using Thunderbird on OS X.

    Try to set a filter to move them to sent. I don't know if this is possible with an iPhone, I don't have one...Yet.
  3. Baron58 macrumors 6502

    Feb 19, 2004
  4. Compile 'em all macrumors 601

    Compile 'em all

    Apr 6, 2005
    I came across another cool way (on SA Forums) to get around your problem :

    1. Go to and create a filter that says that mail with from your email is to be deleted. Sent mail will go to the trash on the Gmail servers (which stays there for like 30 days).
    2. iPhone Mail will not pull from the Gmail trash, so you will not get copies of the email you sent in your iPhone mailbox.
    3. Copies of mail you send will still be in the phone's "Sent" folder.
  5. Furgster macrumors 6502


    Jun 16, 2007
    no no, there is a simple solution to this

    go into settings >> mail>> (choose your account at the top)>> advanced>> and then turn off recent mode that should fix it
  6. Cadence macrumors member

    Jul 17, 2004
    Los Angeles, CA
    ??? in gmail??

    edit: in iphone, gotchya...I'll try this
  7. iansearle macrumors newbie

    Jul 2, 2007
    Here is what I've been able to figure out:

    1) Gmail is setup differently than other POP servers. Anything that is not in trash or spam gets pulled to clients.
    2) IF you ONLY use POP clients ( and iPhone for example) you can setup a gmail filter rule to delete mail that is from your address. That mail will go into the trash (and be kept around for 30 days) and you won't see sent mail on your iPhone.
    3) If you use the gmail web-interface, you'll get errors trying to send mail with this filter in place.

    So, under limited circumstances, there is a workaround. The real solution is for Apple to make the iPhone's mail application work like OS-X and filter out the sent mail.
  8. opticalserenity macrumors 6502a

    Apr 14, 2007
    hopefully something they'll fix in their first update.
  9. TonySwartz macrumors member

    Jan 11, 2004
    I just set my Gmail account to:

    1) Filter to Skip the Inbox (Archive)
    2) Forward to .Mac

    And then on the iPhone I set up my .Mac settings for incoming mail ( and Gmail settings for outgoing mail (

    This allows me to check my email using the .Mac website or Mail, but still keep a copy on Gmail's server if I need to go back and see. I did this with .Mac because Gmail doesn't have IMAP. I'd rather have everything synced up (i.e., I delete an email on the iPhone and it's also deleted on the webmail/ on my computer).

    All of your sent items are saved on Gmail's website, though. You don't see the sent items reappear as new mail in your Inbox on the iPhone either, since they skip the inbox on Gmail's side.
  10. billchase2 macrumors 68000


    Feb 28, 2006
    Ann Arbor
    could one of the mods make one of the million gmail threads a sticky? everyone seems to be posting about it and not realizing that there are already about 15 threads going about the problem...

Share This Page