Gmail IMAP not consistent across iPhone, Mail & webmail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by vawolf, Aug 7, 2008.

  1. vawolf macrumors member

    Joined:
    Jun 3, 2004
    #1
    Hello,

    I've set up my Gmail account to use IMAP with Mail.app and the iPhone 3G. When I look at my inbox in Gmail's webmail and in Mail.app, I see all the same messages. But when I check my Gmail inbox on the iPhone, some of the messages I see on the other two are missing. I tried rebooting the phone and it didn't work. I would've guessed that the problem had to do with some messages I copied from another account to Gmail, but on the iPhone most of those messages show up, just not some.

    Thanks.
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    When you added G-Mail to the phone, did you pick the "G-Mail" option?

    Crazy, right? Well, Google themselves suggest using "Other" instead of that option!

    Dunno if that's your problem, but I suggest erasing the account from the phone and re-adding it using Google's instructions:

    http://mail.google.com/support/bin/answer.py?answer=77702
     
  3. Whigga Spitta macrumors 6502

    Joined:
    Apr 21, 2004
    Location:
    Can you say Chi-City??
    #3
    I was having similar problems with inconsistencies with my Gmail across my iPhone, Mail.app, and webmail.

    Digging through some settings, I realized that on my webmail I had both POP and IMAP enabled, which was giving me some weird results. Perhaps something to check out.

    I also found this to be a helpful link: http://5thirtyone.com/archives/862
     
  4. vawolf thread starter macrumors member

    Joined:
    Jun 3, 2004
    #4
    I checked my Gmail settings on the web interface and POP is disabled. But thanks...and I'll check out the link. It's only a handful of messages so I should probably let it go, but it's the principle of it.
     
  5. Salvacion macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Inglewood, CA
    #5
    I had the same problem, but after following that link's instructions I'm all synched up, mail goes to correct folders on Mail and mail.app, and no more duplicates. Thanks a bunch.
     

Share This Page