GMail IMAP problems

Discussion in 'Mac Apps and Mac App Store' started by admcptch, Nov 13, 2007.

  1. admcptch macrumors newbie

    Joined:
    Nov 2, 2007
    #1
    Ok, so bear with me, I just got my Macbook today : )

    I'm trying to setup my GMail account with Mail (the new Leopard version) and it will only allow me to use the POP settings, I can't seem to use the IMAP. I have IMAP enabled in my GMail account, and I read how you do it on Googles website, but the dropdown to choose IMAP instead of POP doesn't show up for me when I go into Mails prefs. Any idea why? Could I change the 'incoming mail server' to imap.gmail.com? Or doesn't it work like that? Thanks in advance.
     
  2. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #2
    Are you saying you already have GMail set up for POP access?

    If I remember correctly, you can't change from POP to IMAP in an already configured account.

    If so, and if I were you, I would create a new account for GMail (use a different name for the account) and delete the old POP one once you're sure the new one is working correctly. That's what I did anyway, just to make sure I still had GMail access in case I did something wrong.

    Edit: by the way, I think you need to change your sig now.
     
  3. admcptch thread starter macrumors newbie

    Joined:
    Nov 2, 2007
    #3
    Yeah it already is setup for POP.

    It didn't give me a choice of IMAP of POP.

    Google's help page says you make a new account (like you did) and there should then be a dropdown menu to choose IMAP/POP but when I do that, I get no dropdown or any other form of choices.
     
  4. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #4
    Hmm, odd. I had no problem setting up IMAP in Mail. I can't remember the exact details of what account setup involves though. I know it was different from the Google page since that was written for Tiger's Mail, not Leopard's. If no one gets back to you, I'll take a look again when I get home.
     
  5. skinuca macrumors member

    Joined:
    Jun 15, 2005
    #5
    Try not using the gmail preset on the iPhone. Instead create a new mail account from scratch and use the settings for gmail's imap server. This should work. There is a problem with the gmail portion of the iPhone config screen if you want imap. Both google and apple are aware of it and will address it.
     
  6. admcptch thread starter macrumors newbie

    Joined:
    Nov 2, 2007
    #6
    Thanks, yeah it is a little different. I got the IMAP stuff to show-up, but when I went to connect and take the account online it says that it can't access the server through port 993 (and that is the port that Google said to use), weird.

    Edit: As of right now, it's working. So hopefully it keeps working ;)
     
  7. itsallinurhead macrumors 6502

    itsallinurhead

    Joined:
    Apr 23, 2007
    Location:
    Southern California
    #7
    This is the same problem I am having and it is refusing to download any messages. Anyone have a solution?
     
  8. motownflip macrumors regular

    Joined:
    Oct 24, 2007
    #8
    mine is working without problems. Just make sure you follow the directions. Delete and start over again until you get it right. It took me three times.
     
  9. weinrdog macrumors newbie

    Joined:
    Oct 25, 2007
    Location:
    o-HI-o
    #9
    Took a few tries, but did work for me eventually.

    First time I tried (2 days ago) I had significant problems getting it to verify my login. Yesterday, it worked just fine.
     
  10. itsallinurhead macrumors 6502

    itsallinurhead

    Joined:
    Apr 23, 2007
    Location:
    Southern California
    #10
    I tried several times to no avail each time. POP works perfectly fine. Which is weird, I am actually trying to set-up my girlfriends account [doesn't work], but my newly created account works just fine. Does it have anything to do with the number of emails stored on the server?
     
  11. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #11
    I have maybe 10,000 emails on my GMail account (I was one of the first to get an account ... it's who you know ...)

    Anyway, my account, that works correctly, is set up to use imap.gmail.com as the server, my full gmail address for the username, e.g plinden@gmail.com (not my real address in case you're wondering), and under advanced in the account configuration, I use port 993 with the SSL check box checked, authentication set for password. I also have "Use IDLE ... " checked.

    Remember that with IMAP you're downloading all messages unless you modify the advanced setting "Keep copies of messages for offline viewing". I have that set to "All messages, but omit attachments". If it's set to "All messages and their attachments", Mail will sit there looking like it's doing nothing while it downloads everything from GMail.
     
  12. itsallinurhead macrumors 6502

    itsallinurhead

    Joined:
    Apr 23, 2007
    Location:
    Southern California
    #12
    Everything is set up as it should be. When I look at the activity monitor in mail it seems to hang on "feching new mail-changing flags."

    Like I said, it works fine for me but not for the g/f, any ideas?
     
  13. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #13
    Then it's probably not hanging, rather downloading your gf's mail. Do you see a lot of network activity in Activity Monitor?

    If so, after setting it up, go away for an hour and see how it is when you come back.
     
  14. djejrejk macrumors 6502a

    djejrejk

    Joined:
    Jan 3, 2007
    Location:
    Uhh...
    #14
    To use Gmail Imap in Mail.app, simply go to add account, fill out your full name, email address and password, then uncheck the "automatically set up account" checkbox. From there, its pretty simple.
     
  15. Chillijam macrumors member

    Chillijam

    Joined:
    Oct 26, 2007
    Location:
    UK, but maybe not for much longer
    #15
    Is your account set to UK, by any chance? It appears that Google are rolling out the IMAP updates quite slowly. If you don't get the option, you can force it as follows...

    1. Go to Settings
    2. Set your language preference to US English (or equivalent)*
    3. Set up IMAP on the tab that should now appear
    4. Change language back to where it was before (UK in my case)
    5. Bask in the IMAPy goodness.

    *assumes your account wasn't already set to US English.

    That's what I did with my account, and I can now access the account via IMAP. YMMV, IANAL, etc.
     
  16. Lgreer macrumors newbie

    Joined:
    Aug 10, 2006
    #16
    Too much spam

    The whole label vs. folder thing really throws a kink in the Gmail IMAP system.

    Also, I have a folder filled to the brim with Spam. We're talking around 3000-6000 spam messages at any given time.

    I don't want Mail to download all those spam messages every time it syncs. Is there any way I can exclude certain "folders"?
     
  17. itsallinurhead macrumors 6502

    itsallinurhead

    Joined:
    Apr 23, 2007
    Location:
    Southern California
    #17
    That's what is perplexing me! I see none! It will eventually successfully download all the messages, but it refuses to download new ones.
     
  18. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #18
    Are you sure you're looking in the right place? My wife thought she had this problem with her GMail (with only emails sent from her own account - eg. bcc'ing herself with mail sent to work), but it turned out she had a GMail filter to label and archive any email with her address. When she looked in the folder corresponding to the GMail label, all her emails were there.
     
  19. itsallinurhead macrumors 6502

    itsallinurhead

    Joined:
    Apr 23, 2007
    Location:
    Southern California
    #19
    I am going to check, but I don't believe my girlfriend would even know how to do that. What is weird is that it works fine on my computer [sometimes]

    My gmail account works perfectly across mail.app and my iphone.
     

Share This Page