Gmail IMAP Push? Not working...

jdstoddard

macrumors member
Original poster
May 27, 2003
50
0
USA
Is anyone having an issue with their Gmail not pushing messages to the Mail app? It worked fine yesterday on SL, but today I have to manually check for mail.

I currently have it setup to Check Manually, but have the IDLE command checked. Has anyone come up with a resolution to this?

:confused:
 

Tearabite

macrumors regular
Sep 10, 2009
102
0
So.California
Well that was easy..
Previously, based on what i had read for Snow, to get gMail IMAP push notifications to work you had to enable the IDLE command and UNcheck the "include this account when automatically checking for email" option.. this is how my mail has always been set..

On a whim i decided to CHECK the "include this account" box, and that seems to have fixed it for me. :D
 
Comment

LastZion

macrumors 6502a
Apr 13, 2006
566
2
wasn't working for me either...
I unchecked idle and kept include checked
that fixed it
 
Comment

jdstoddard

macrumors member
Original poster
May 27, 2003
50
0
USA
I've tried both unchecking IDLE and include and every combined option, both checked, 1, etc and still broken.

Does anyone have a solution? Still no push for me, best I've been able to do is change it from manually check to check every minute.

Just an annoying little thing that my iPhone gets messages before my computer does!
 
Comment

Reliant

macrumors newbie
Aug 1, 2010
15
0
I've tried both unchecking IDLE and include and every combined option, both checked, 1, etc and still broken.

Does anyone have a solution? Still no push for me, best I've been able to do is change it from manually check to check every minute.

Just an annoying little thing that my iPhone gets messages before my computer does!
Pretty much where I'm at...I've noticed using the tick box "automatically include this account when checking for new mail" is also weird. When my mail is set for push, if I check or uncheck that, mail will push for a few emails, regardless of that setting, but then it will go back to not syncing. Simply changing that setting again forces it to fetch the new mails. I can't find a way to get it to be reliable 100% of the time.

I'm back to 1 minute polling, which I don't really like.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.