Gmail IMAP Push? Not working...

Discussion in 'Mac OS X Lion (10.7)' started by jdstoddard, Jul 21, 2011.

  1. jdstoddard macrumors member

    Joined:
    May 27, 2003
    Location:
    USA
    #1
    Is anyone having an issue with their Gmail not pushing messages to the Mail app? It worked fine yesterday on SL, but today I have to manually check for mail.

    I currently have it setup to Check Manually, but have the IDLE command checked. Has anyone come up with a resolution to this?

    :confused:
     
  2. Tearabite macrumors regular

    Tearabite

    Joined:
    Sep 10, 2009
    Location:
    So.California
  3. Tearabite macrumors regular

    Tearabite

    Joined:
    Sep 10, 2009
    Location:
    So.California
    #3
    Well that was easy..
    Previously, based on what i had read for Snow, to get gMail IMAP push notifications to work you had to enable the IDLE command and UNcheck the "include this account when automatically checking for email" option.. this is how my mail has always been set..

    On a whim i decided to CHECK the "include this account" box, and that seems to have fixed it for me. :D
     
  4. advan031 macrumors 6502

    Joined:
    Aug 16, 2008
  5. Tearabite macrumors regular

    Tearabite

    Joined:
    Sep 10, 2009
    Location:
    So.California
    #5
    what is your "include this account" setting? checked or UN checked?
     
  6. LastZion macrumors 6502a

    Joined:
    Apr 13, 2006
    #6
    wasn't working for me either...
    I unchecked idle and kept include checked
    that fixed it
     
  7. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #7
    It wasn't working for me yesterday morning, but it started working again. So its not the OS.
     
  8. jdstoddard thread starter macrumors member

    Joined:
    May 27, 2003
    Location:
    USA
    #8
    I've tried both unchecking IDLE and include and every combined option, both checked, 1, etc and still broken.

    Does anyone have a solution? Still no push for me, best I've been able to do is change it from manually check to check every minute.

    Just an annoying little thing that my iPhone gets messages before my computer does!
     
  9. Reliant macrumors newbie

    Joined:
    Aug 1, 2010
    #9
    Pretty much where I'm at...I've noticed using the tick box "automatically include this account when checking for new mail" is also weird. When my mail is set for push, if I check or uncheck that, mail will push for a few emails, regardless of that setting, but then it will go back to not syncing. Simply changing that setting again forces it to fetch the new mails. I can't find a way to get it to be reliable 100% of the time.

    I'm back to 1 minute polling, which I don't really like.
     

Share This Page