Gmail IMAP with mail.app

Discussion in 'Mac Apps and Mac App Store' started by hehe299792458, Dec 15, 2009.

  1. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #1
    I have setup Gmail in Mail.app with via IMAP. I have successfully downloaded all the messages, but I have trouble sending email. There seems to be some sort of problem connecting to the SMTP server. Here's the diagnosis:

    Code:
    CONNECTED Dec 15 01:01:22.527 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    
    READ Dec 15 01:01:22.557 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    220 mx.google.com ESMTP 22sm5722712pzk.6
    
    WROTE Dec 15 01:01:22.563 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    EHLO [192.168.0.195]
    
    READ Dec 15 01:01:22.604 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    250-mx.google.com at your service, [24.83.204.152]
    250-SIZE 35651584
    250-8BITMIME
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250 PIPELINING
    
    WROTE Dec 15 01:01:22.607 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    STARTTLS
    
    READ Dec 15 01:01:22.940 [kCFStreamSocketSecurityLevelNone]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    220 2.0.0 Ready to start TLS
    
    WROTE Dec 15 01:01:23.051 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    EHLO [192.168.0.195]
    
    READ Dec 15 01:01:23.071 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    250-mx.google.com at your service, [24.83.204.152]
    250-SIZE 35651584
    250-8BITMIME
    250-AUTH LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250 PIPELINING
    
    WROTE Dec 15 01:01:23.075 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    ***********************************
    
    READ Dec 15 01:01:23.657 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    235 2.7.0 Accepted
    
    WROTE Dec 15 01:01:23.662 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    MAIL FROM:<username@gamil.com>
    
    READ Dec 15 01:01:23.681 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    250 2.1.0 OK 22sm5722712pzk.6
    
    WROTE Dec 15 01:01:23.693 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    RCPT TO:<username.com>
    
    READ Dec 15 01:01:23.714 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    553-5.1.2 We weren't able to find the recipient domain. Please check for any
    553-5.1.2 spelling errors, and make sure you didn't enter any spaces, periods,
    553 5.1.2 or other punctuation after the recipient's email address. 22sm5722712pzk.6
    
    WROTE Dec 15 01:01:23.727 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:smtp.gmail.com -- port:587 -- socket:0x1148d6a50 -- thread:0x115e55ad0
    QUIT
     
  2. scottness macrumors 65816

    scottness

    Joined:
    Mar 18, 2009
    Location:
    Room 101
  3. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #3
    Yes. And the Authentication is Password
     
  4. psj macrumors newbie

    Joined:
    Jul 24, 2008
    Location:
    Bangkok
  5. Sweetfeld28 macrumors 65816

    Sweetfeld28

    Joined:
    Feb 10, 2003
    Location:
    Buckeye Country, O-H
    #5
    Gmail IMAP settings.


    You must first, if you haven't done so already, configure your gmail to use IMAP, in the Settings for your account.
     
  6. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #6
    I tried. The same result...
    I enabled IMAP in my gmail account and followed those instructions on google to the letter.
     
  7. Sweetfeld28 macrumors 65816

    Sweetfeld28

    Joined:
    Feb 10, 2003
    Location:
    Buckeye Country, O-H
    #7
    I guess, I'm stumped then. I have those same settings and it works fine. The only other suggestion i have, would be to delete your Mail Prefs, and start over. But i can't guarantee it will work.
     
  8. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #8
    Can you post some screenshots of your setup with the appropriate things blacked out? (email address I guess). Since it is only the SMTP (sending) we should probably focus there...
     
  9. elitesouth macrumors member

    elitesouth

    Joined:
    Nov 24, 2009
    Location:
    Savannah GA
    #9
    Looking at the report, I see that Google accepted your request to connect to smtp.gmail.com - however, I'm seeing this:

    "553-5.1.2 We weren't able to find the recipient domain."

    I hate to ask, but are you sending mail to an address that exists? :D
     
  10. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #10
    I'm pretty sure I'm sending mail to a valid address
     

Share This Page