Gmail no longer works in Apple Mail

Discussion in 'OS X El Capitan (10.11)' started by blackjackmark, Dec 6, 2015.

  1. blackjackmark macrumors 6502

    Joined:
    Apr 19, 2010
    #1
    I posted on a Gmail forum and no one has responded. But based on the fact that I can access these gmail accounts through both web browser and Microsoft Office, I'm thinking it's got to be an issue with the Mac configuration. I'd love some suggestions to remedy my issue!

    Recently I reinstalled the OS El Capitan on my 2013 Retina MacBook Pro. Prior to the reinstall, I was able to access all my Gmail accounts through the native Apple Mail app. Since then, I have been unable to access any of my Gmail accounts through Apple Mail.

    I have tried turning off two-step verification, but that doesn't solve it.
    I have repeatedly deleted all account, and followed the steps below, but still cannot get them added (don't they say that one of the definitions of being insane is doing the same thing twice and expecting a different outcome?

    Here are my steps that I take each time:

    When I log in in, I use my Gmail Password.
    Internet Accounts/New Account
    Select Google
    Enter my Username and click Next
    Enter my password (not the app-specific password, but the Google password. I've tried both and it always tells me that I should use the Google password.)
    Click Next
    The dialog box then states "Select the apps you want to use with this Account (and the Google logos is at the top of that box.​

    My options are:
    Mail
    Contacts
    Calendars
    Messages
    Notes (all the Mac logos for those apps)​
    All are checked, but I deselect all but Mail
    Click Done.

    The "Done" button grays out

    Finally after probably 60-90 seconds I get a message through Mac OS that states "Google Account Added" "XXX@gmail.com has been added"
    Within that box I'm given the options of "Not Now" or "Turn on".

    If I select "Turn on", I then get the message through Mac OS that states "Google Password required”.I enter my password, and the cycle repeats over and over.

    If I select "Not Now" then the account shows as "Inactive" in my list of internet accounts. Once I select it, I am immediately prompted for the password...and the whole process starts over.​

    Facts:
    The account is IMAP enabled.

    The account has two-factor authentication turned off. If I have it turned on, all the same things happen, with the only exception of being prompted and receiving the security code through my deliver y method, but once I input it, it still cannot access my mail.

    I have four different Gmail account, and this happens the same way with them all.

    They are all fine through the browser-based email

    They are all accessible through my iPad and iPhone.

    I cannot access any of them through the native Apple mail app.

    They are all accessible through Microsoft Outlook mail client (2016)


    I’ve even tried turning off the option to allow “Less secure apps”. I've tried it both on and off, and nothing works.

    I’m ready to ditch all my Gmail accounts at this point.

    Any ideas (other than getting rid of Gmail!)
     

    Attached Files:

  2. Max(IT) Suspended

    Max(IT)

    Joined:
    Dec 8, 2009
    Location:
    Italy
    #2
    my only Gmail account is working fine within Mail.
     
  3. Josh125 macrumors 6502

    Josh125

    Joined:
    Apr 28, 2008
    Location:
    Katy, TX
    #3
    It is working fine here as well using El Cap. Mine was asking odd at first when I installed El Cap. I had to delete it from settings, internet accounts and it worked fine.
     
  4. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #4
    I just happen to be at work today.

    In checking twelve of us are up and running via Gmail / Mail without any issues.
     
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    Check your Keychain Access app for erroneous entries regarding your Gmail accounts.

    Your situation sounds so messed up that I'd probably go a bit further and clean out Mail and start over.

    If they're all IMAP accounts and you don't have any email stored "On My Mac" then you could try the following:

    In this order I'd delete all SMTP servers, remove all Gmail accounts, delete all Keychain entries pertaining to those accounts, delete the actual mail files that are in ~/Library/Mail and then start over with one account to see if it now works.
     
  6. blackjackmark thread starter macrumors 6502

    Joined:
    Apr 19, 2010
    #6
    Thanks everyone! Clearing out the Keychain and doing a repair solved it. Love the forums for helping each other!
     

Share This Page