Gmail no longer works in Mail

Discussion in 'iPod touch' started by JavaWizKid, Jun 1, 2009.

  1. JavaWizKid macrumors 6502a

    Joined:
    Sep 18, 2008
    #1
    Hi I have no idea but all of a sudden my Gmail account keeps saying "The connection to the server "imap.gmail.com" failed. I haven't changed any of the settings and it worked before. Strange thing is the Mail app works on my Mac with Gmail.
     
  2. tremlock macrumors 6502a

    tremlock

    Joined:
    Jun 16, 2008
    Location:
    The Land of Cleves
    #2
    Login to gmail and make sure pop3 is checked in settings
     
  3. uberamd macrumors 68030

    uberamd

    Joined:
    May 26, 2009
    Location:
    Minnesota
    #3
    pop3? Shouldn't it be IMAP?

    This happens to me at times because I may have Gmail running on my Desktop mail client, and Gmail lets you have only a few simultaneous connections. Thus, Gmail will deny more connections until you close the desktop client.
     
  4. JavaWizKid thread starter macrumors 6502a

    Joined:
    Sep 18, 2008
    #4
    Nope still doesn't work. As I said before it receives in my Mail on my mac but not on my iPod Touch and it is synced with the mail application on my mac. I just don't understand what's wrong.
     
  5. tremlock macrumors 6502a

    tremlock

    Joined:
    Jun 16, 2008
    Location:
    The Land of Cleves
    #5
    Yeah i think you're right IMAP not pop3. Pop3 is yahoo:eek:
     
  6. JavaWizKid thread starter macrumors 6502a

    Joined:
    Sep 18, 2008
  7. 1rottenapple macrumors 65816

    Joined:
    Apr 21, 2004
    #7
    This happens to me every now and then. Don't know why really. It comes back after a few minutes to less than an hour.
     
  8. JavaWizKid thread starter macrumors 6502a

    Joined:
    Sep 18, 2008
    #8
    Mine hasn't been working for a more than a week!
     
  9. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #9
    Go into Settings->Mail, Contacts, Calendars, tap on the email account, and then go to the advanced button. Make sure that SSL is on for the incoming settings, authentication is password, no IMAP path prefix, and using server port 993. If all else fails, because Mail is so easy to set up on an iPod touch, you can just delete and re-add the account.
     
  10. JavaWizKid thread starter macrumors 6502a

    Joined:
    Sep 18, 2008
    #10
    Thanks, it works now. I tried re-syncing the information from my Mac and wiping the data over on the iPod Touch however Gmail still refused to work. Ah well all is good now :) thanks!
     
  11. Darkroom Guest

    Darkroom

    Joined:
    Dec 15, 2006
    Location:
    Montréal, Canada
    #11
    i had those settings already, and it's still extremely tempremental. sometimes it works, sometimes it doesn't. i'm convinced it's the iPhone OS 3.0 software, since it has royally f****d the wifi on my 2nd Gen iPod Touch, and the only confirmed fix is to do a hackish downgrade to OS 2.2.1.

    if you're also having wifi issues since 3.0, check out this thread.
     
  12. cmichaelb macrumors 68020

    cmichaelb

    Joined:
    Aug 6, 2008
    Location:
    Kansas
    #12
    I almost never have a problem but a couple of times I've had gmail stop wrking.

    All you do is log in to gmail via a browser, reset your settings, and it works again.
     
  13. Gyrferret macrumors regular

    Gyrferret

    Joined:
    Jan 19, 2009
    #13
    Alright. I have this problem too. My mail app doesn't work at my school. It works at home though.
    Why?
    Because the school's internet has certain ports blocked off that are vital to a couple of programs (such as mail.app and Steam). So, essentially, it might be the router or the admin blocking certain ports. I would check that too. It's not always that iPod that's not working.

    Gmail uses port 465 (needs to be encrypted). Make sure that's open. Other blocked ports might be interfering too.
     

Share This Page