Gmail not working on iOS (I've tried all the things)

Discussion in 'iPhone' started by kriista1234, Oct 6, 2015.

  1. kriista1234 macrumors regular

    Joined:
    Jan 12, 2008
    #1
    My gmail hasn't been working on my phone (consistently) in weeks.

    I've removed/added the account several times (this works fine for a couple days after), I've logged into the authorization google page several times, and tried other tricks I've seen on the forum.

    It's really getting to the point of being useless.

    What's especially unusual is that my wife's gmail (which also comes to my phone) has no problems at all. Works perfectly, all the time. So the hardware/system is ok. It's just my account for some reason.

    I'm using the stock mail app, and have absolutely no interest or desire to use the official gmail/google app. I've been moving away from google stuff as much as possible, and gmail is next. It's just a matter of steps

    Is anyone in a similar boat? What if anything did you do that helped (ideally in a long-term manner)?
     
  2. CKtoph macrumors 6502

    Joined:
    Nov 22, 2007
    #2
    I've seen similar issues. I have a junk gmail account for...well, junk...and it has been giving me server errors on and off for the past few weeks.

    My main gmail account I feed through iCloud so I can have emails pushed to me, and I have had no issues with that one.
     
  3. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #3
    As in you have it forwarded through? I've seen some guides for that kind of stuff online but never thought to try it.
     
  4. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair
    #4
    Yeah, the forwarding route is one workaround.

    Do you have 2 step verification on your account? I doubt it at this point, but it's the only other thing of which I can think.
     
  5. CKtoph macrumors 6502

    Joined:
    Nov 22, 2007
    #5
    Yep. I have incoming emails (Gmail) forwarded to my iCloud account, and all of my outgoing emails is sent by using Gmail's outgoing SMTP server. Works great.
     
  6. Carmenia83 macrumors 6502

    Joined:
    Feb 25, 2012
    #6
    This was going on with my iPhone 6 for months, across several gmail accounts. Not all at once, usually one account one day, another the next. The only "fix" was restarting the phone almost every morning when I couldn't get my mail, then it would work. I finally did a DFU restore and it worked fine for the next few weeks. Then I upgraded to a 6s and a new iPad mini 4 on 9/25 and it just started again on both devices yesterday.

    I have a theory that I will test when I am home from a business trip I'm on right now. Wireless OTA updates may be the culprit. When I restored via iTunes on the iPhone 6, the problem stopped. When I got the new devices I restored from iTunes backups on my Mac. No problems. I've updated both devices to 9.0.2 OTA and here I am. I'll post an update when I have a chance to do some restoring.
     
  7. bluedukies8 macrumors 6502

    bluedukies8

    Joined:
    Jun 30, 2009
    Location:
    Iowa
    #7
    May I ask if there is anything special I would need to setup in order to do this as well? The forwarding part is simple and straightforward enough, but unsure about the outgoing emails.

    Are only the Gmail responses sent via Gmail or are ALL emails sent through gmail?

    I have my iCloud acct set up and don't want those to go through Gmail if possible.
     
  8. CKtoph macrumors 6502

    Joined:
    Nov 22, 2007
    #8
    No, there's nothing special. If you'd like to still be able to send out iCloud or Gmail emails according to your choosing, you'd just have to keep the iCloud SMTP server on while adding an additional Gmail SMTP. Then, when you send emails, you can choose which server you want the email to be sent from.

    Pretty straightforward.
     
  9. bluedukies8 macrumors 6502

    bluedukies8

    Joined:
    Jun 30, 2009
    Location:
    Iowa
    #9

    Ah ok. Thank you very much!
     
  10. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #10
    Did you have to setup a secondary iCloud account?

    Looking at this guide here:
    http://jonwestfall.com/2014/07/get-true-push-gmail-iphone-ios-device/

    And it suggests starting with a secondary iCloud account (which seems weird). Also, do you use gmail webmail at all? I primarily use mail.app on mac/iOS but occasionally use the webmail while at work. Wondering if it's filled with iCloud mails (as suggested by that guide).

    If you used a different guide, could you post it?
     
  11. CKtoph macrumors 6502

    Joined:
    Nov 22, 2007
    #11
    No problem, and good luck :)

    I did not set up a secondary iCloud account. I still use my gmail webmail from time to time with no issues. You can just adjust your gmail settings to make sure your Gmail account saves a copy on its own servers, and to make sure you don't get double emails, anywhere that you have both your iCloud and Gmail, just turn off the Email portion. This allows me to still use Google for my calendar, notes, etc.

    Oh, and I didn't use any guide. I just kind of wanted to keep getting my Gmail via push, and figured this would work lol.

    Hope that helps!
     
  12. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #12
    Ugh, in trying to setup the outgoing SMTP in iCloud I get a 'password not correct' error.
    It's definitely correct as I changed it yesterday.

    Really growing to hate gmail....
     
  13. swerve147 macrumors 6502a

    swerve147

    Joined:
    Jan 12, 2013
    #13
    If you have 2-step verification on your Google account you might want to try using an app-specific password:

    https://support.google.com/accounts/answer/185833?hl=en
     
  14. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #14
    I was about to set that up but backed out at the idea of giving google my phone number.
     

Share This Page