Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Apple_Robert

Contributor
Original poster
Sep 21, 2012
31,324
42,519
In the middle of several books.
I am using Office for Mac 2011. I have gmail set up. And for some reason, the password for the gmail account doesn't appear to be saving in the keychain. The gmail account password box pops up on a regular basis asking me to input my password, because it can't connect.

I looked in keychain and the password wasn't there. I put it in and clicked on save. Not long after, the same password problem for gmail popped up again, wanting me to input my password. Once I provide my password, everything is fine for a while, and then the process repeats itself. It is very annoying.

I have also made sure to check the prevent sleep option for Outlook.

Anyone have a solution for the gmail problem?
 

saberahul

macrumors 68040
Nov 6, 2008
3,644
111
USA
I am using Office for Mac 2011. I have gmail set up. And for some reason, the password for the gmail account doesn't appear to be saving in the keychain. The gmail account password box pops up on a regular basis asking me to input my password, because it can't connect.

I looked in keychain and the password wasn't there. I put it in and clicked on save. Not long after, the same password problem for gmail popped up again, wanting me to input my password. Once I provide my password, everything is fine for a while, and then the process repeats itself. It is very annoying.

I have also made sure to check the prevent sleep option for Outlook.

Anyone have a solution for the gmail problem?

Paste the exact error. I tend to get a lot of "too many simultaneous connections" error which prompts a password re-entry in Outlook.
 

Apple_Robert

Contributor
Original poster
Sep 21, 2012
31,324
42,519
In the middle of several books.
Paste the exact error. I tend to get a lot of "too many simultaneous connections" error which prompts a password re-entry in Outlook.
I will post it as soon as it happens again. I had to set the account back up today, and haven't had the problem, yet. Although, I had this error numerous times just trying to set the account up.

The server for account "Gmail" returned the error "[ALERT] Too many simultaneous connections. (Failure)." Your username/password or security settings may be incorrect. Would you like to try re-entering your password?
 

saberahul

macrumors 68040
Nov 6, 2008
3,644
111
USA
I will post it as soon as it happens again. I had to set the account back up today, and haven't had the problem, yet. Although, I had this error numerous times just trying to set the account up.

The server for account "Gmail" returned the error "[ALERT] Too many simultaneous connections. (Failure)." Your username/password or security settings may be incorrect. Would you like to try re-entering your password?
This one - I just hit escape and my email comes in normally. After 5 times or so after hitting escape, it doesn't come for a while. Yep, annoying.
The server for account "Gmail" returned the error "[ALERT] Web login required: http://mail.google.com/support/bin/answer.py?answer=78754 (Failure)." Your username/password or security settings may be incorrect. Would you like to try re-entering your password?

That is the other error message I am getting.

Do you have 2-step on? If you're using an app password, it may be the cause. Alternatively, is it set up via pop or imap? imap works better imo. Hopefully these suggestions will help.
 

Apple_Robert

Contributor
Original poster
Sep 21, 2012
31,324
42,519
In the middle of several books.
This one - I just hit escape and my email comes in normally. After 5 times or so after hitting escape, it doesn't come for a while. Yep, annoying.


Do you have 2-step on? If you're using an app password, it may be the cause. Alternatively, is it set up via pop or imap? imap works better imo. Hopefully these suggestions will help.

I use IMAP and 2 step is turned off.

----------

If it's a Keychain issue you might get it fixed by deleting the Keychain entries pertaining to the account. Let Keychain create new ones.

I tried that, Brian.

I created my own password via OneSafe, and then cut and pasted the password into the account.
 

CoMoMacUser

macrumors 6502a
Jun 28, 2012
880
159

Apple_Robert

Contributor
Original poster
Sep 21, 2012
31,324
42,519
In the middle of several books.
I just changed the 'sync all IMAP folders' option from default 2 minutes to 15 minutes. Will see if that has any affect on either of the problems.

Two days now without any gmail errors.

If you have been getting the too many connections error, try changing the default IMAP folders sync from 2 minutes to 15 minutes in Outlook, and see if that resolves the issue.

I have my MBP, iPhone, and iPad Air all set up and running Gmail iMAP as well, and none of them are giving me any errors either.
 
Last edited:

Lloydc

macrumors newbie
Feb 13, 2015
2
0
Just a thought, but I do not believe this issue is directly as a result of your username and password being wrong. It is the way that Mac Outlook deals with the Gmail "Too many simultaneous connections" error. I was also getting these username/password errors and would just keep pressing NO and after a couple of times it would connect proving my username and password were correct all along. Gmail has set their system up to fail as it only allows 15 simultaneous connections and refuse to do anything about it. If you have several devices setup to use your Gmail account, then this number is easily reached. Along with slow synching issues by Mac Outlook, which is another well known issue, I stopped using it. I am currently using Mac Mail, which does report the error correctly, so now in search of a proper fix and not a work-around. Some have gotten around it by setting up their Gmail to forward to a mail server account that does not restrict connections.

Lloydc
 

bgstock

macrumors newbie
Nov 23, 2014
3
1
Thanks

Thank you Lloyd. It seems to work fine, but I am still afraid if the computer is less protected. Hopefully not.
 

Lloydc

macrumors newbie
Feb 13, 2015
2
0
No problem, agree it is always a concern when you have to turn some things off to get others to work.
 

Bronxzu

macrumors newbie
Dec 19, 2015
1
0
I am using Office for Mac 2011. I have gmail set up. And for some reason, the password for the gmail account doesn't appear to be saving in the keychain. The gmail account password box pops up on a regular basis asking me to input my password, because it can't connect.

I looked in keychain and the password wasn't there. I put it in and clicked on save. Not long after, the same password problem for gmail popped up again, wanting me to input my password. Once I provide my password, everything is fine for a while, and then the process repeats itself. It is very annoying.

I have also made sure to check the prevent sleep option for Outlook.

Anyone have a solution for the gmail problem?
I was having the same problem with my Mac Book Pro running Mac OS X 10.11. I noticed that when I turned on two-step verification in Gmail, I kept getting the authentication issues. The Gmail account would not take my password (even though the 2-step verification worked in the Mail App).

Once I turned off the 2 Step Verification in Gmail's online web server, I was able to enter my pass phrase in Outlook and Gmail went online. Perhaps MS Office fixed this bug in the 2016 version.
 

nplatinum

macrumors newbie
Feb 12, 2016
1
0
I see that this is an old post, but after fighting with Outlook for over a year to get my mail, I FINALLY got it working again.



The first thing I had to do was log into my my Gmail account and turn off the button labeled "Less secure apps" as Outlook is in that category.

  1. Go to the "Less secure apps" section in My Account.
  2. Next to "Access for less secure apps," selectTurn on. (Note to Google Apps users: This setting is hidden if your administrator has locked less secure app account access.)
And if you have 2-step verification on (as I did), it will still make Outlook fail. So the next thing you have to do is create an app password which will generate a password for you, and you use that in Outlook for it to sync correctly.



  1. Visit your App password page. You may be asked to sign in to your Google Account.
  2. At the bottom, click Select app and choose the app you’re using.
  3. Click Select device and choose the device you’re using.
  4. Since Outlook will not be listed, select Other and type in Outlook for future reference.
  5. Select Generate.
  6. Follow the instructions to enter the App password (the 16 character code in the yellow bar) on your device.
  7. Select Done.
  8. Copy the password that was generated.
  9. Open Outlook and paste the password in the Password section. DO NOT use your regular password.
  10. Your mail will sync without anymore issues. (Hopefully)
Once you are finished, you won’t see that App password code again. However, you will see a list of apps and devices you’ve created App passwords for.

I hope this helps everyone who is having an issue. And I hope these directions are easy to follow! Good luck everyone! :)
 

McAddress

macrumors newbie
Jun 7, 2016
1
0
I see that this is an old post, but after fighting with Outlook for over a year to get my mail, I FINALLY got it working again.



The first thing I had to do was log into my my Gmail account and turn off the button labeled "Less secure apps" as Outlook is in that category.

  1. Go to the "Less secure apps" section in My Account.
  2. Next to "Access for less secure apps," selectTurn on. (Note to Google Apps users: This setting is hidden if your administrator has locked less secure app account access.)
And if you have 2-step verification on (as I did), it will still make Outlook fail. So the next thing you have to do is create an app password which will generate a password for you, and you use that in Outlook for it to sync correctly.



  1. Visit your App password page. You may be asked to sign in to your Google Account.
  2. At the bottom, click Select app and choose the app you’re using.
  3. Click Select device and choose the device you’re using.
  4. Since Outlook will not be listed, select Other and type in Outlook for future reference.
  5. Select Generate.
  6. Follow the instructions to enter the App password (the 16 character code in the yellow bar) on your device.
  7. Select Done.
  8. Copy the password that was generated.
  9. Open Outlook and paste the password in the Password section. DO NOT use your regular password.
  10. Your mail will sync without anymore issues. (Hopefully)
Once you are finished, you won’t see that App password code again. However, you will see a list of apps and devices you’ve created App passwords for.

I hope this helps everyone who is having an issue. And I hope these directions are easy to follow! Good luck everyone! :)

I had to select the following for it to work (I had Allow users to manage their access previously but didn't work):
upload_2016-6-7_12-3-54.png

I am not using 2-step verification.

This solved the issue for me.

Thanks!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.