Gmail w/ "MAIL" Not Deleting Trash But Actually Saving It..

Discussion in 'iPhone' started by HappyDude20, Sep 4, 2009.

  1. HappyDude20 macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #1
    I've just set up Gmail on my iPod Touch under the native Mail app. When 1st configuring i checked "other" rather than "Gmail" to set up IMAP.

    Everything works great and syncs instantly with my Gmail on a browser desktop....except for the deleting/trash.

    When I click the trash icon for any email under the Mail app on my iTouch the email in question ends up in "All Mail" on my Touch and also at "Trash."

    When I go to Gmail.com on my Macbook and the message I thought I was trying to delete shows up under "All Mail" on Gmail.com and not under Trash.

    What's going on here?

    What i'm simply trying accomplish: I want to be able to delete an email while on MAIL on my iPod Touch and have it be deleted since i'll never need it again on Gmail.com and also the iPod touch. If I want an email deleted there is no reason for it to reside next to "All (my other) Mail" whether that's on my iTouch or Gmail.com
     
  2. HappyDude20 thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #3
    I'm so glad you linked me to this (again).

    See, I used that very same link yesterday when I originally set up my Gmail account on my touch and i'm glad you provided this link so I can easily relate the situation.

    I've clicked "Advanced" and have the setting exactly as is on the link you provided.

    [​IMG]

    1. Drafts Mailbox: Draft = Works Great, syncs and looks perfectly with Gmail on my Macbook
    2. Send Mail: The same, work flawlessly.
    3. Deleted Mailbox: All Mail = Problem

    When I delete anything it ends up in "All Mail" on my Touch, which houses all of my "archive" emails, same in Gmail "All Mail."

    But since the deleted mailbox is set with "all mail", anything I "delete" ends up in "All Mail" on both my MAIL native app on the iPod Touch and also ends up in "All Mail" on Gmail.com on any computer, rather than going to the trash...

    This is where i'm stuck and confused.

    Obviously the answer may seem to lie in just changing the Deleted Mailbox to something other than "all mail" but my other options only are:

    On my iPhone: Trash
    On the server: Inbox, Drafts, Sent Mail, All Mail & Starred...but oddly enough all these options are grayed out except "All Mail" & "Starred"

    .........I dont know what to do.
     
  3. G-Force macrumors 6502a

    Joined:
    Nov 25, 2006
    #4
    EDIT: Sorry didn't read the last bit of your post. Strange that Trash is not shown. Try to enable the Advanced IMAP Lab in Settings > Labs and make sure the Trash label is shown in IMAP (settings > labels).
     
  4. Eso macrumors 68000

    Eso

    Joined:
    Aug 14, 2008
    #5
    If you are using Gmail than you should understand that their whole system is designed around never having to delete an email, ever.

    If you want to send the message to the trash folder, just configure the account using the standard "Gmail" option - the whole point of manually configuring it is to avoid the behavior that you actually want.

    -Gmail "How do actions sync in IMAP?"
     
  5. HappyDude20 thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #6
    OMG, I'm not by iPod Touch just yet but think you're right. I'm not sure but believe under Settings in Gmail I made sure not to include Trash, which would explain it all. We'll see, i'll test it out right now.

    The problem with this Gmail option is that it's POP, which I hate. It doesn't keep my Macbook, iPod Touch and Random Computer Browser in sync.
    I've set up my Gcal to always be in sync with iCal on my Mac and Calendar on my Touch, which all work amazingly well...

    I'll report momentarily with results.


    :eek:
     
  6. HappyDude20 thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #7
    It works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    SOLVED!

    "Show in IMAP" under Gmail's settings was not checked but now is and everything works!

    I love it!

    Thank you so much.

    :D:D:D:D:D:D:D
     
  7. Rat-Boy macrumors 65816

    Rat-Boy

    Joined:
    Jul 28, 2008
    Location:
    Georgia
    #8
    I dont get the setup of GMail.

    Instead of doing "Other", I just did GMail.

    And everything works as it should.

    So why press "Other?"
     
  8. HappyDude20 thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #9
    Because when you click Gmail its set up as "POP" rather than "IMAP."

    POP is good but doesn't sync up if you tend to use Gmail say on a random PC computer on Campus + iPod Touch or iPhone (Whether its the native MAIL app or Safari Browser) + Firefox on Macbook + any other computer in the world.

    With POP, an email you read on your Touch will still show as unread on a computer...while IMAP will make all computers remember what was the last action you did on whichever device.

    Google's Gmail blog even suggests you use IMAP, unless for some unique reason you need POP.
     

Share This Page