Goes to home screen for no reason?

c.greene914

macrumors regular
Original poster
Jun 3, 2007
104
0
Has anyone else noticed this bug? For me it has occurred primarily in Google Maps. I will be navigating the map, and the screen goes blank for a second and the home screen appears. I am 100% positive I didn't hit the home button and it has happened on more than one occasion.

Side note: I have noticed also, that if I receive a SMS, when I slide to unlock, sometimes it is rather slow to display the message.

Neither one of these are detrimental to usage, but a minor annoyance and if there is an existing fix, I would like to know. Otherwise I suppose I will have to wait for an update.

Thanks
 

epochblue

macrumors 68000
Aug 12, 2005
1,671
0
Nashville, TN
The heading back to the home screen like that is what the iPhone does when an app crashes; I've had it happen randomly to me with Safari if I'm on a JS-heavy page. :)
 

rcarricato

macrumors newbie
Jul 11, 2007
12
0
Harrisburg, PA
same thing here

I got the same thing a couple of times in Gmaps, I dont think its just you.... you got nothing to worry about your iPhone isnt defective:eek:
 

c.greene914

macrumors regular
Original poster
Jun 3, 2007
104
0
Is there something I can do to try and prevent this? Free up some space? Anything? Has anyone found the cause for these crashes?
 

sunnywala

macrumors newbie
Jun 25, 2007
24
0
I have experienced this in virtually every application except ipod, usually when safari is loading a lot of photos or java heavy page as mentioned above. Seems that a restart of the phone helps a little
 

Trekkie

macrumors 6502a
Nov 13, 2002
906
16
Wake Forest, NC
I've had it happen in the iPod application a few times, did a power off/power on by holding the home/standby button until it shut down and it quit doing it. Something musta gotten gorped up a bit.

Has been ok since then for me.
 

belli1kl

macrumors newbie
Jul 17, 2007
1
0
It's kind of freakin me out.

Last night my battery died while I was talking on the phone and that's when all the glitching started. Every app I opened would only work for a little while then automatically go back to the Menu page. It was doing it the worst in iPod. For a while I couldn't even listen to a whole song before it would stop and go back to the menu. I just powered it off, then on for the third time and (cross my fingers) it seems to be working now. Do you think this is something that will be fixed in the first update? I hope so, because the glitching's got me worried.:eek: