iPhone Good For Enterprise, Xcon and Jailbreak Oh My!

Discussion in 'Jailbreaks and iOS Hacks' started by Paratel, Aug 30, 2012.

  1. Paratel macrumors 6502

    Paratel

    Joined:
    Jan 26, 2005
    Location:
    Somewhere in the US
    #1
    Okay so I have a jailbroken 4S running Good for Enterprise and Xcon. Made the stupid mistake of updating Good for Enterprise (ver.2.0.0) Now the app won't run because it will not let you run it on jailbroken devices.

    Anyone know of a work around or when Xcon is going to get updated to fix it?
     
  2. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #2
    I upgraded to the new version of Good yesterday. I'm jailbroken on my AT&T 4S and have no problems with it. I think this may have something to do with your IT departments security. Best to check with someone there if you can. Good luck
     
  3. Paratel thread starter macrumors 6502

    Paratel

    Joined:
    Jan 26, 2005
    Location:
    Somewhere in the US
    #3
    I agree that the IT Natzis have there hand on this. However, it work before the upgrade. I work for the federal government and I am sure they have some security measures i place to prevent Good working on a Jailbroken phone. Perhaps it has something to do with Good using my UDID.
     
  4. Snazzz macrumors newbie

    Joined:
    Aug 30, 2012
    #4
    Xcon failed for me as well Good for Enterprise 2

    I made the same silly mistake of upgrading without checking if Xcon works with the new version. You know the rest, it has ended in tears. GFE 2 does not play nice with the Jailbroken IPad. Get the same error as you. Hope there is a work around or I am screwed, reverting to being non Jailbroken is not an option.:mad: pretty sure my iT dept are not clued up on the GFE UDID and it's workiings nor IOS in general. pretty sure it's the App that is preventing its functionality

    S
     
  5. Dmaster79ios macrumors newbie

    Joined:
    Aug 30, 2012
    #5
    Works on my 4S

    What is the error message that you see? I am an IT admin for a good server and I just loaded my device tonight with the new version 2.0 and it's working fine. I would rather just use webmail then to remove my JB!

    Some companies choose to use the the added iOS security profile for increased security and this does several checks on the device so you have to be careful what applications especially jailbroken applications you have installed. I do indeed have this configured on a good server however we are a few versions behind so I won't know for a few weeks whether when we upgrade it will break anything at this point

    Any password jailbreaks or other utilities that are used for password security should be disabled or uninstalled as this will cause issues. You must hit allow on the UDID or you will have to have your IT department reprovision a device as this is a requirement for the new version.

    Also any browser chooser must be disabled or uninstalled as this will cause an issue prompting for the install of the IOS security profile. I do have Xcon running as well which may be a requirement for it to work properly.

    Just to rule out a carrier issue im on Verizon and confirm it does work.hopes this info helps a little. Good luck!
     
  6. Snazzz macrumors newbie

    Joined:
    Aug 30, 2012
    #6
    "....Also any browser chooser must be disabled or uninstalled as this will cause an issue prompting for the install of the IOS security profile. I do have Xcon running as well which may be a requirement for it to work properly.

    Just to rule out a carrier issue im on Verizon and confirm it does work.hopes this info helps a little. Good luck![/QUOTE]


    I did require to install the security Profile
    I am running Xcon Resprung and rebooted the device after a new install
    I am using a local 3G provider here in Australia, however I also tried on Wifi
    and it fails

    The error message is :
    "compliance check failed. Contact your IT administrator"

    Running Ios 5.0.1
    Latest Xcon
    Jailbroken with Absinth

    GFE2.0



    Worked perfectly on 1.9.7


    :confused:
     

Share This Page