GoodReader/iCloud sync

Discussion in 'iPad Apps' started by David Menzel, Apr 2, 2012.

  1. David Menzel macrumors member

    Apr 1, 2012
    Dear members,

    I hope that you can help me to fix this problem.
    Yesterday, I completely restored my iPad as a new device. After installing all apps and several types of content I opened the GoodReader App to sync all of my iCloud files. I really don't know what happened but I'm not able to sync GoodReader with iCloud anymore. I have no iCloud folder and no buttons in general settings to turn it on. I deleted and installed the app again but nothing changed. Any suggestions? Thank you so much.
  2. thewitt macrumors 68020


    Sep 13, 2011
    In Goodreader, Settings, General Settings, iCloud on
  3. David Menzel thread starter macrumors member

    Apr 1, 2012
    That is precisely the problem, I have the current app version but no buttons to turn it on. It's very strange.
  4. thewitt macrumors 68020


    Sep 13, 2011
    Is iCloud enabled in the Mail account?

    In iCloud settings, is Documents and Data on?
  5. David Menzel thread starter macrumors member

    Apr 1, 2012
    Yes of course ;). iCloud is on, Documents & data is on. It works perfectly with my iPhone 4S but I have no idea what happened to my iPad. I restored it as a new device, turned everything on but it shows no iCloud options in the GoodReader iPad app.
  6. David Menzel thread starter macrumors member

    Apr 1, 2012
    It's absolutely weird! I installed the GoodReader App for iPhone on my iPad and everything worked fine (I have access to my folders/documents). I deleted the iPad version and istalled it again but nothing ... I have still no option in my GoodReader App for iPad (hat means no iCloud on/off button) to activate/deactivate iCloud? Is here someone with the same issue or any useful hint? Please, I just want to use my papers...
  7. David Menzel, Apr 3, 2012
    Last edited: Apr 3, 2012

    David Menzel thread starter macrumors member

    Apr 1, 2012
    Great! I fixed the problem by my self but I like to share it with you so that some other members know how to avoid this issue.

    I had this problem because I restored my iPad as a new device and started directly with the current app version (3.14.2). The app didn't show me any iCloud settings and prevented the access to my iCloud folders/files.

    I also tested it with the GoodReader for iPhone app from my iPad and was suprised that I was able to open the folders/files.

    Fortunately, I had the old Pad app version in my MacBook Air's trash (3.14.0) and installed it --> IT WORKS! --> all settings are back, ...

    Next, I updated from 3.14.0 to 3.14.2 and it still works.

    Finally, I would certainly advise anyone to keep the older app versions just for a little bit longer ;)
  8. mnc042 macrumors newbie

    Nov 16, 2008
    New England, USA
    GoodReader support answer

    Timely thread. I just got an iPad 3 and went through installing GoodReader from scratch and it, too, lost the iCloud folder. (Yet my iPad 2, running the same version, still had it!)

    So I contacted Good.iWare and the gist of the reply was that there's some legal thing going on and they pulled iCloud support from the latest version, but only for new users. Customers who previously had iCloud support get to keep it, those who install fresh will lose it.

    I guess I'm out of luck for the moment, and I certainly hope Good.iWare gets through whatever legal mess they are in and can keep the feature (and thus reintroduce it into GoodReader).

    So that's the info, straight from the developer. Bummer, but GoodReader+DropBox does everything I need anyway..

    Hope this helps solve the mystery!

  9. pythagorean macrumors newbie

    Feb 23, 2009
    You're right but there is an easy fix:

    1) Kill/Terminate GoodReader on iPad
    2) Download iExplorer for Mac (
    3) In iExplorer navigate to YouriPadName/Apps/GoodReader/Library/Preferences/
    4) Download the file com.goodiware.GoodReaderIPad.plist
    5) Open com.goodiware.GoodReaderIPad.plist and Change the boolean value fICloudIsBanned to NO (this step assumes you have Xcode installed, if not don't worry, just open in a text editor like text wrangler instead and search for iCloud, instead of NO you'll change true to false)
    6) Save com.goodiware.GoodReaderIPad.plist and copy it back in iExplorer
    7) iCloud is working now in GoodReader
  10. mnc042 macrumors newbie

    Nov 16, 2008
    New England, USA
    Yes, but two things about that fix:

    - Good.iWare provided this to me as well, but asked that I not post this workaround to any forums. They seem more than happy to provide it on demand to those who ask for it, but I suspect they fear that they will be forced to remove the feature permanently if this common workaround is made common knowledge (I'm guessing here).

    - Good.iWare also warned me as part of the first point that, more than likely, they'll just be removing the feature entirely from future builds.

    Short summary: Just assume iCloud integration is gone from GoodReader. I don't know what battle they're fighting, but it seems they don't expect this feature to live much longer.

  11. JMJDave macrumors newbie

    Jan 17, 2008
    I think you are right. I just did what pythagorean said and I didn't have any reference to iCloud in my .plist. Weirdly, I'm having the opposite problem as this thread. I lost iCloud support on my iPhone 4s running iOS 5.0, but I still have it on my iPad. The bad thing is, I have to manually update the apps on my iPad now one by one so I don't upgrade to the newest version lest I lost my iCloud documents from GoodReader… :mad:
  12. georgesandre macrumors newbie

    Jan 14, 2014
    GoodReader (v.3.20.0, iPad)


    I have downloaded the new version of goodreader And there isn't any more the fonctionnality of pdfportfolio. Could you tell me if I haven't seen this option in the application ? Or if you know if there is a fixe for a new version ?

    Thank you for you help.


Share This Page