Google and yahoo "unable to connect"

Discussion in 'Mac Basics and Help' started by wyspace, Aug 3, 2009.

  1. wyspace macrumors newbie

    Joined:
    Aug 3, 2009
    #1
    Hello. I got my Macbook pro two weeks ago. So far i have had nothing but trouble. I had it for about a week before my printer came from apple. When i installed the divers everything ran really slow and firefox and safari would crash when i opened them. I called apple and eventually brought it to the apple store. In the end I had to do a complete reformat of the Macbook.

    I have had it for a week since then and this morning when I tried to look at gmail it said "unable to connect". I then tried to google the problem and that also was "unable to connect". I then tried yahoo and had the same results. i restarted the computer twice and still had the problem.

    I first assumed that it was an internet or router problem. I unplugged my linksys WRT54G router and let it restart and tried my macbook. Still unable to connect. I then plugged the cable into the macbook and still could not access the sites.

    I tried to go to google and yahoo on my parents iMac (plugged into the wall) and my old vaio (wireless) and they work fine on those.

    What should I do?

    I should note that iChat can not connect to AIM.

    Also, the mac book can connect to some sites (I am using it now) it just can't connect to google or yahoo as far as i can tell.
     
  2. D'Illusion macrumors regular

    Joined:
    Jul 28, 2010
    #2
    Well this is weird. I now have the exact same problem with my 2011 Macbook Pro. Can't connect to any site related to Google. Tried with Firefox and Safari and nothing. Windows and iPhone on the same network are fine.

    Miffed to say the least. How did you get round it ?
     
  3. D'Illusion macrumors regular

    Joined:
    Jul 28, 2010
    #3
    All down to Peer Guardian 1.6

    Deleted then restarted, now it's fine.
     
  4. chordate68 macrumors regular

    chordate68

    Joined:
    Oct 16, 2007
    Location:
    Los Angeles
    #4
    THANK YOU!!!

    This has been driving me crazy the past two days. Resetting my connection several times, resetting my router, changing my DNS. I always overlook Peer Guardian. Uninstalled and now working like a charm.
     

Share This Page