Google: application specific password

Discussion in 'OS X Mavericks (10.9)' started by badman89, Oct 24, 2013.

  1. badman89 macrumors regular

    Joined:
    Dec 24, 2011
    #1
    I've set up my Google account on Mavericks (System Preferences > Internet Accounts > Google) using an application specific password obtained from Google (because I use two factor authentication). Although I'm able to set it up successfully (for example I can open my emails in Apple Mail), it loses access after about ten or fifteen minutes, and it asks me for the password once again.

    How do I permanently configure the Google account on Mavericks using an application specific password?

    Thanks very much in advance to anybody who can answer this question for me. Cheers!
     
  2. badman89 thread starter macrumors regular

    Joined:
    Dec 24, 2011
    #2
    Bump... Anybody using Google's two factor authentication?
     
  3. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #3
    I am, no issues here. In fact, I had my account configured in Mail, added it to my Accounts dialog in System Preferences and it recognized it was the same account and left it as it was in Mail. This was yesterday, mail still flows.
     
  4. badman89 thread starter macrumors regular

    Joined:
    Dec 24, 2011
    #4
    So you first set up Mail using an application specific password, and then you set up the same account in your Internet Accounts? Which password did you use the second time?
     
  5. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #5
    Another application-specific password. I was trying to get Google Hangouts working in Messages.
     
  6. castas macrumors newbie

    Joined:
    Apr 22, 2014
    #6
    It's in your account settings

    You have to go to your account settings from any google app. Here's how I did it:

    1. Go to this url: https://www.google.com/settings/security
    2. Click Settings next to App Passwords
    3. From here you will create an app specific password

    Use this password with any one application
     
  7. JamesLJ macrumors newbie

    JamesLJ

    Joined:
    Apr 9, 2009
    Location:
    Champlin, MN
    #7
    One other thing to note: You're going to get a pop-up in Messages asking for your password. Don't do that; it won't work.

    Instead, go to Internet Accounts in Preferences and add you App Specific Password there.
     
  8. aferris macrumors newbie

    Joined:
    Oct 29, 2014
    #8
    Delete and start over

    I have had HEAPS of trouble when setting up Google's 2-factor authentication on Yosemite. Mail was sporadic, and I couldn't get the system preferences thing to work. I found a method which actually works, though I'm not sure if all the steps are necessary. Hopefully this might be useful if someone else has troubles.

    1) Close all apps that are connected to google (Mail, etc).
    2) Create an app-specific password from google (I only needed one for my MacBook Pro, so you can revoke any other you made for this computer). Keep the page open for a while, or write it down (destroy it later).
    3) In system preferences, I deleted my google account. I had to navigate a bunch of "enter password" prompts (that always fail), but eventually it was removed.
    4) Create a new google account, and enter the app-specific password. It should, after a few seconds, connect to all the services you selected.
    5) Open Mail. It should have copied the app-specific password and your Gmail inbox should work. Make sure to send an email via the gmail account and re-enter the SAME password (with email, the inbox and outbox use completely different protocols and need to be authenticated separately).
    6) Finally, open Calendar (if you sync to it) and it will prompt for a password. Use the same app-specific password.

    It think it is necessary to reuse the same "app-specific" password, because system preferences wants to use the one password for the various google preferences. Other apps like notes don't seem to ask me for the password again (I've checked note syncing with iPhone via Google; works well, but I haven't tried Messages).
     
  9. rlocker55 macrumors newbie

    Joined:
    Nov 21, 2014
    #9
    Thanks aferris!

    Thanks aferris! I have been struggling with this for a while, but your solution worked. I quit all apps that are connected to google, deleted the account and re-entered it using my google app password. That did the trick. Thank you!!
     
  10. tomharrisonjr macrumors newbie

    Joined:
    Sep 24, 2010
    #10
    Still and issue in Yosemite, and this still works, Jan 2015

    Thanks aferris,

    Having recently had success at getting Internet Accounts and app-specific Google passwords working together correctly, I was writing a blog post on how to do it.

    But then, "something happened" and it stopped working.

    Deleting the Google account after stopping all apps connected to it, then re-adding using a new app-specific password was the only solution I could find.

    Sigh. I would have thought Apple had finally come around to understanding that security is pretty important, and multi-factor authentication is a necessary evil (at least until more people and devices have Touch ID!).

    I'll update my blog post with a link here. Thank you!
     

Share This Page