Google Apps email filters not working

Discussion in 'Mac Apps and Mac App Store' started by Nostromo, Oct 31, 2011.

  1. Nostromo, Oct 31, 2011
    Last edited: Oct 31, 2011

    Nostromo macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #1
    Maybe this is an issue about Google Apps email not working well with Apple Mail.

    I have a professional photography website, and there's a contact form.

    When it sends an email, it is coming from one of my own email addresses.

    It always lands in spam.

    So I created a filter for that address, and told it to mark email from it as important, and not to put it in spam.

    It's like this filter didn't exist. The email (which is very important, as it's from customers to be) still lands in spam.

    Google Apps email filters also don't work the other way round: when I enter the email address of a spammer, and tell the filter to delete it, it still goes through.

    Any comments on why Google Apps email filters do not work? Thanks!
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    Where are you setting up your mail filter rules? It sounds like you are trying to set up rules using Google Apps' online webmail interface and expecting them to work when you're using Apple Mail as your client.

    Am I misunderstanding? If you tell Apple Mail that a message is "Not Junk" it should remember that. You can also make sure that your form's sender address is in your contacts on your Mac. That should avoid messages getting moved to Junk mail.

    If I'm misunderstanding, I apologize.
     
  3. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #3
    I'm setting up the filter in the Google Apps filter email menu.

    So, they shouldn't even make it to Apple Mail, but get filtered out before.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    I've got several filters set up at Gmail and they're all working fine.

    At mail.google.com did you select the messages and click the "Not spam" button? I don't know if that would work. Google is probably marking the messages because it looks like someone at another domain is "spoofing" your email address, which they are hosting(?).

    When you set up filters the "Test Search" button does not find messages in the Spam folder. This is probably why the filter isn't working.

    A good solution would be to set up your website contact form via another method...so that messages appear to be "from" the email address entered by the person filling out the form. That's the way it works at my website, which is on the Joomla content management system.
     

Share This Page