Google calendar events not syncing with Calendar

Discussion in 'Mac Apps and Mac App Store' started by 262Runnr, Feb 13, 2018.

  1. 262Runnr macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #1
    I've been syncing my Google calendar forever and all of a sudden all my events are gone on my Mac Calendar. I tried deleting accounts and re-adding them to Calendar but it's not working.
    Now I have to keep a Google Calendar window open in Safari to see my events. I have stopped using the Mac Calendar because of this.
    Any idea why this is not working anymore?
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    These are events that are in calendars under the heading "My calendars" at the Google Calendar website? Are you seeing ANY events from ANY calendar?
     
  3. 262Runnr thread starter macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #3
    Hi Brian, Yes I see all the events in my Google Calendar.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Let me rephrase:

    1. These are events that are in calendar(s) under the heading "My calendars" at the Google Calendar website?

    2. On your Mac int he Calendar app, are you seeing ANY events from ANY Google calendar?
     
  5. 262Runnr thread starter macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #5
    Brian, I'm seeing only 1 event on my MAC Calendar and it it the last appointment that I entered today at 2 o'clock on my Google calendar...so it sync'd that one event. There is nothing else on my MAC Calendar.
     
  6. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    Which macOS version are you on?

    Are you deleting/adding the account in System Preferences>Internet Accounts?

    Is this the only account with a synced calendar? Do you store any events that are only on your Mac?

    Are you running any third-party firewall or malware/virus protection?

    Basic stuff but will help. This may be a case of purging the calendar files.
     
  7. 262Runnr thread starter macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #7
    I just entered a test event to my Google Calendar and it sync'd to my Mac Calendar. However there are still no other events showing up on MAC Calendar.
    I deleted all accounts in System Preferences>Internet Accounts and now only have 3 internet accounts that I use for my MAC Mail App. I only use one of those accounts to sync to MAC Calendar. I am not running any firewall or malware software that I'm aware of and I used to add events right on my MAC Calendar and it would sync to Google...
     
  8. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #8
    Before we nuke any files check to see if it is indeed something in your User Account causing the issue by creating a new User Account and adding the Google Account to that one. If the results are the same you'll have to keep prying. If everything works great then some file surgery will have to be done on your original account.
     
  9. 262Runnr thread starter macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #9
    Well I quickly added some events to my Yahoo calendar then added the Yahoo Calendar to my MAC and everything syn'd to the MAC calendar. It's just that my Google Calendar is simply not syncing to MAC calendar....very odd.
     
  10. spedanden macrumors newbie

    Joined:
    Apr 14, 2012
    #10
    calendar.google.com/calendar/syncselect

    Try going there.
     
  11. 262Runnr thread starter macrumors regular

    262Runnr

    Joined:
    Jul 21, 2008
    Location:
    NC
    #11
    It didn't solve my problem but it did help me eliminate syncing with an item that I had been trying to delete from my Calendar for a long time......"Holidays in Brazil"....haha
    Finally got rid of that item by unchecking it....:)

    Yup, My Google calendar is checked off in the box there but it just won't sync...
     
  12. floridonet macrumors regular

    Joined:
    Apr 5, 2011
    Location:
    Irvine, CA

Share This Page