Google Calendar on iPad can't see shared calendars?

Discussion in 'iPad' started by KevKaos, May 6, 2010.

  1. KevKaos macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #1
    I have been using Google Calendar for awhile now (since before getting my iMac) and I have been very happy with it. I was able to get iCal on the iMac to display, edit, add and delete entries. I was also able to view my wife's and daughter's Google calendars as well. Able to do the same on my Droid phone as well. Just got my iPad last week, and got its calendar app to work with "MY" calendar by using these directions;

    http://www.googletutor.com/2007/01/24/syncing-google-calendar-with-ical/

    The problem is that I can't see my wife or daughter's calendar on my iPad. This baffles me. Any thoughts as to way this is happening? Wondering if deleteing the sharing of their calendars and then setting them up again would make a diffference?
     
  2. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #2
    Let me make sure I understand what you are asking. From what I gather, you're trying to view your wife and daughter's google calendar using the iPad's built in calendar. Is that correct?

    These directions already assume that you've set up the Google Exchange account on your iPad already. If so, you'll have to log into each of their calendars from your Mac and set up the sharing feature. This will allow your google account permissions to view or edit, depending on how you set up the sharing, each calendar.

    Once you do that, using your iPad, navigate to m.google.com/sync on your iPad. Then click "Sign in with your Google account", enter your credentials and you'll be presented with a list of devices. Choose your iPad and then you'll be given the option choose which calendars sync with the iPads calendar application.

    Once you do that, open the iPads calendar application, give it a minute or so and it will download their calendars. You'll see a button appear in the top left of the calendar that says "Calendars". Click on that and you'll see a drop down list of all the calendars synced to the IPad. That is where you can choose which calendars to display at any particular time.
     
  3. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #3
    Thank you for the detailed answer. I will probably print it out at home and follow your steps. I have somethings set up already, but probably won't understand your answer completely till I follow the steps.

    Yes, that is correct. the three of us have all shared our calendars with each other and will probably be doing the same with the other 2 kids as their calendar of events expands.

    That is done already. We just have "view" set up, except for each person's own personal account. For example, I can do everything on my own calendar but I can see the wife and daughters calendar entries on my calendar. My daughters entries are in green and my wifes entries are in orange. I cannot modify or delete their entries, just view them. This all works on my iMac and the Droid at this point but not the iPad.

    I think this is the step I have been missing. I did go to that link, but to be honest, I didn't exactly know what the heck I was doing. I think I see where we are going now and where my problem point is.

    I know I never did anything like this, so your last paragraph is where I took a wrong turn. Thank you for your detailed answer. I'll make sure I post back when I follow your steps, probably to say that it's working well. Hopefully someone else will also benefit from your answers. Based on my searches last night on the internet, other people seem to have similar issues and not getting answers. Thanks again.
     
  4. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #4
    This might help a little. The first two pictures show where you need to set up the sharing with your wife and daughter's calendar. The last picture is what you get after signing in with your gmail account on the iPad at m.google.com/sync

    [​IMG]

    [​IMG]

    [​IMG]
     
  5. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #5
    No problem. I was a little slow with the last reply, because of uploading the pictures. I didn't see yours until I posted the last one.

    Anyway, if you already have the calendars shared and yours is working properly on the iPad, it's just a matter of navigating to that website, choosing your device and checking the box next to your other shared calendars.

    Let me know how you make out.

    Oh, and it's a wonderful thing once you get it working. No more wasting time asking everyone what they are doing next week, tomorrow, etc. Do you currently sync your contacts with your gmail account? I love that feature as well, because everything is backed up essentially on Google's cloud. Dead iPad, no problem. Get a new one, enter your account information and viola' everything gets reloaded.
     
  6. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #6
    Thanks for the snapshots. Now I see right where I need to go today after work.

    You know, I have NOT sync'd my contacts. I never really thought about it. I think I will jump on that boat as well. Only thing I don't like in contacts is that it lists every person I have ever sent an email to. Maybe I just need to do a better job of cleaning up. :D I probably need to dig around in Google contacts to see how I can have contacts but not certain ones. Like the ex-wife. I need to have her contact info but don't need to see it all the time. hahaha
     
  7. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #7
    Be careful with the contact sync when you first set it up. It is very easy to accidentally erase all the contacts on the phone. Do a full sync with iTunes first just to be sure. That way if anything happens, you can reload from iTunes, or just import the .csv file to Google.

    Give this a read before you start with the contacts.

    If I remember correctly, when I did mine, I synced my iPhone with Outlook, then exported all my contacts to a .csv file. I was able to upload that to my Google account and then sync from there. I had been reading reports of people having to deal with duplicates when trying to merge the two together even if their Google contact list was empty.

    The only downfall to Google's contact sync, is that it doesn't support Groups yet so all your contacts get lumped into one group. :( Other than that, it's perfect.
     
  8. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #8
    Unfortunately there isn't any way to turn off this feature, which I think is stupid. The easiest way to clean things up is to log into your Google account from your Mac or PC. Find you contact list and locate the search box at the top of the list. Put your cursor in the box, press the space bar one time and then press enter.

    You'll see your contact list divided into two section, one will be "My Contacts" and the other will be "Other Contacts". Scroll down to the "Other Contacts" section and you'll find all the people that were auto-added. Just check off the entries you don't want and delete them.

    That's the easiest and fastest way to clean them up. It beats scrolling through all of them if you ask me.
     
  9. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #9
    More great information. Of course I am going slow and steady, since I am still a noob. Once I get the calendar sorted out I'll tackle the contacts with your directions. I have some other things I want to do and/or set up, but I have to get all this little stuff sorted out first. I'm a couple steps closer now.
     
  10. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
  11. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #11
    It's fixed

    Boy do I feel stupid. I finally got the calendar working the way it should. The answer was right there in you instructions, but since the email and my calendar was working, I just didn't pick up on it. When I would get to the section where you showed the iPad screenshot, I was getting something completely different. There was no way to select the device. I found another article online that talked of setting up an iPhone to use Google mail, contacts and calendar, but said that the same instructions work for iPad. Then I saw it. You have to set up your account as a Microsoft Exchange Server account and answer certain prompts are certain way. I had not done that when I set up my mail. I had picked Google. Since mail and my calendar were working, I thought it was correct. Sure enough, your instructions clearly said to set up as Microsoft Exchange. So anyway, I delete my accounts on the iPad and set it up the correct way. EVERYTHING is working correctly now and you are correct that it is a wondrous thing. In case I forgot to say it before, THANK YOU!!!
     
  12. Spyderturbo007 macrumors member

    Joined:
    Aug 7, 2009
    #12
    No problem. Glad I could help. I think I did make mention of assuming you had set it up as Exchange in my first post. :p It's a common mistake and honestly, one I made when I first when through the process.

    Let me know if you have any other questions.
     
  13. dlazo80 macrumors newbie

    Joined:
    Feb 16, 2012
    #13
    I could not get to the site m.google.com/sync on my ipad 2. I think they have made a change since this tutorial. From the ipad 2 I had to go to www.google.com/calendar/iphoneselect , then log in with gmail credentials. Choose the calendars to sync. from settings disable calendar sync within the exchange and add a gmail account and only sync the calendar. This is what worked for me.
     
  14. Ilandy macrumors newbie

    Joined:
    Feb 17, 2012
    #14
    That's the trick for iPhone. If you have a google acct running through the exchange server, the shared calendars don't show up in the calendar app. As soon as I set it up as a gmail acct and turned the calendar on it worked perfect. Just make sure you go to google.com/calendar/iphoneselect to pick your settings.
     
  15. Mikey94025 macrumors newbie

    Joined:
    Jun 2, 2013
    #15
    I was able to get my shared calendars to show up in my iPhone Calendar list only after visiting https://m.google.com/sync/settings/iconfig/ in the iPhone Safari browser. That page lets me manage the Google Sync devices (e.g. iPhone, iPad), each has its own Settings page where I must click the checkbox to sync each shared calendar. Once I saved those device-specific settings, I was able to see the extra calendars on the iPhone.
     
  16. johnq22 macrumors newbie

    Joined:
    Feb 13, 2008
    #16
    It may have changed... I followed this instructions on this page under Sync multiple calendars - https://support.google.com/calendar/answer/151674

    Visit the following page from your device's mobile browser: https://www.google.com/calendar/syncselect
    (Google Apps users can go to https://www.google.com/calendar/hosted/your_domain/syncselect, replacing 'your_domain' with your actual domain name)

    and that worked.
     

Share This Page