Google Chrome doesn't work on Windows 7 PC

Discussion in 'Windows, Linux & Others on the Mac' started by cat21, Aug 1, 2013.

  1. cat21 macrumors newbie

    Joined:
    Aug 1, 2013
    #1
    I installed Google Chrome on my Windows 7 machine. However, pages don't load and I get a message: "This webpage is not available". I tried to reinstall but it doesn't work. What should I do?
     
  2. AppleDeviceUser macrumors 6502

    AppleDeviceUser

    Joined:
    Jan 7, 2012
    Location:
    Canada
    #2
    I would suggest use Safari however, it's discontinued for windows, so I will now suggest you use Firefox
     
  3. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #3
    I hate to say it, but you should find a Windows forum and ask there. I have no problem with Chrome on Windows 7, and no special Windows knowledge that could help you.
     
  4. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #4
    Just for clarification when you say "my" is this your personnel computer and not a work computer correct?

    Did you install using the correct admin rights?
    Latest version?
    Do you have any webproxy issues that would prohibit you from access the internet?
    Can you ping a web site?
    Do other browsers work? i.e. IE or Firefox?
     
  5. cat21 thread starter macrumors newbie

    Joined:
    Aug 1, 2013
    #5
    Yes, it's my home computer. All other browsers work except this one. I'm planning on getting a Mac soon, but I still wish to try Chrome since I will be using Windows in the next couple of months.
     
  6. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #6
    Were you going to answer his questions rhett7660 asked you while trying to assist you when you asked for help, or ignore them? He went out of his way to help I think that would be the least you could do.
     

Share This Page