Google Images Won't Load In Safari

Discussion in 'Mac Apps and Mac App Store' started by flec321, Oct 13, 2009.

  1. flec321 macrumors newbie

    May 17, 2009
    My Safari won't load google images. Google itself works, and I can search all day long without fail, all the links are fine. But if I'm using google images, nothing loads up. I have deleted my history, emptied my cache, and finally reset safari, still nothing. Google works, its just google images I can't access.

    However, I took my macbook into my local Apple store and as you guess, it worked a treat (making me look silly!). So this led me to believe it must be something with my internet connection, something in my modem settings. My parents have a HP Windows vista laptop, and google images works fine for them. And they use the same wifi network.

    So now I'm stumped!

    I have had my 13inch Macbook since February, and up until a month ago, I could load anything in google images. However a month ago I had to have my hard drive replaced when I upgraded to Snow Leopard. I apparently had a corrupt drive, so under warranty I got a new one - so the computer I am with now only has a hard drive that is 5 weeks old - I have no parental controls, no anti virus software, nothing that I could think of that might affect it?

    Any ideas would be welcome, thanks all :) Below is a screenshot of my last search.

    Attached Files:

  2. GGJstudios macrumors Westmere


    May 16, 2008
    Since you can't see images, go to Safari > Preferences > Appearance
    and make sure "Display images when the page opens" is checked.

    Attached Files:

  3. flec321 thread starter macrumors newbie

    May 17, 2009
    Yep - afraid to say this is checked already. If it wasn't, would this mean no images would load at all? I only find problems with google images. When I search google for a website, I click the link in the search results, and it loads fine, everything as it should be. However when I go to google, and click images, I just get nothing. I have no idea what is going on?
  4. GGJstudios macrumors Westmere


    May 16, 2008
    Have you tried another browser to see if they load? If they don't load with Firefox or another browser, it's most likely your firewall settings.
  5. angelwatt Moderator emeritus


    Aug 16, 2005
    Something of interest that I see in that screen shot is the status bar, "21 errors occurred in opening the page. For more information, choose Window > Activity." (21 errors, 21 missing images) So, do as it says and maybe it'll give some clues. You can post back if the messages don't make much sense to you.
  6. flec321 thread starter macrumors newbie

    May 17, 2009
    Yep, clicked Window > Activity after I did this search for "Daughtry No Suprise." Regardless of what I search for, I get the same message every time.

    Attached Files:

  7. angelwatt Moderator emeritus


    Aug 16, 2005
    Does this occur with a different browser like Firefox? This would tell us if it's a networking issue, or a browser issue. If switching browsers doesn't show images try restarting your router.
  8. sidodekker macrumors newbie

    Nov 3, 2009

    I have exactly that same problem. And I have Opera and Firefox downloaded, tried it and still the images are not displayed! If somebody knows whats wrong please tell! It's irritating those who don't know what's going on (me).

  9. cokeacola macrumors member

    Nov 10, 2006
    Dundee Scotland
    i had the same problem and solved it by uninstalling glims ...but if you need glims then to solve that i had to turn off the firewall on my router ...:confused:

    weird i know but try it :eek:
  10. GGJstudios macrumors Westmere


    May 16, 2008
    Did you read my earlier post?
  11. Michaelmate macrumors newbie

    Nov 14, 2009
    Perth, Australia
    Evening all.

    The same thing is happening to me, and much to my annoyance, the 4.0.4 Safari update and the 10.6.2 update didn't do anything to help.

    'Display images when page opens' checked, firewall is turned off. Also doesn't work in the latest Firefox (3.5.5). Gee thanks Snow Leopard.
  12. RustyIron macrumors newbie


    Nov 17, 2009
    problem solved

    It's not a Snow Leopard or a Safari issue. When viewing the Google results page, change your Search Settings. I'm not sure which setting fixes the problem. After changing several settings, the problem disappeared. Then I went and changed all the settings back to what they were, but the problem didn't reappear. Good luck.
  13. gps macrumors newbie

    Sep 12, 2008
    is a terrible bug I believe...

    No! The problem is there, and is happening with ALL the major image search engines (I can't see the first page of results of Google, Bing, Yahoo, Cult...) and this is really depressing!

    Also with Firefox, Opera, Camino... WTF!!! Same problem...

    I have the very same issue with Google Maps, the only difference there is that it waits for 45 to 90 seconds and after the 50% of the tiles, appears...

    I saw in Console two recurrent messages:
    23/11/09 01.51.37 Safari[502] -[WebIconMenuItem accessibilityAttributeNames]: unrecognized selector sent to instance 0x1987a460

    and: DebuggerPluginKit was called...

    Please, don't tell me to do the BASIC operations we normally do when there is a problem on our macs... I did all of that, up to reset SMC.

    I took one spare macbook here at home, just flashed... and installed Leopard... it works fantastic!

    Ah, another little piece of info I saw in the element inspector of safari. When it doesnt load the images, it gaves this message..( which sounds wierd to me...) for all the images it was not able to load...

    generate_204Resource interpreted as image but transferred with MIME type text/html.

    Ah, last but not least.. this is happening on ALL the macbooks (one MBP ub and MB ub), at the point that we believed there was a serious incompatibility with our ISP's DNS and the mDNSResponder of SL (it happens with big CDN-related sites, like, or Akamai, or edgesuite... very wierd..)

    Any help, really appreciated.
  14. macMate macrumors newbie

    Dec 6, 2009

    i have the problem since 1 year now i found the solution and Safari displays all the images in google or yahoo search...
    It's about your vpn ip adress (about your location) to change it

    1. download the Hotspot Shield from any download sites (it's a free application)
    2. run the program it automatically changes your vpn adress (you can also use this program if u have trouble to enter the locked websites)
    3.after the running the program you can easily search what ever you want in google images or other search sites..
  15. webster1023 macrumors newbie

    Dec 9, 2009
    Hi, have been reading all you posts and playing around to fix this problem. Ended up turning off a firewall setting on my modem. So far everything is now working perfect. Heres the details.

    Modem: Belkin F5D5730au
    ISP: Bigpond AUS
    OSX 10.6.2

    enter into browser.
    Select firewall > Intrusion detection > UN tick SPI and Anti-DoS firewall protection.

    Hope this works a well for you has it has for me.
  16. flec321 thread starter macrumors newbie

    May 17, 2009
    still no luck. My parents were using a HP Laptop on the same modem, and have just bought a Sony problems on either machine when using Google Images.

    I only have this problem at home, the problem did not exist when I took my Macbook into the Apple Store, or when I take my Macbook to my friends house.

    Any ideas what settings I can change on my modem that might affect it? I can't see any options for "SPI and Anti-DoS firewall protection" like the previous poster said.
  17. funkypepper macrumors member

    Feb 6, 2007
    Everyone having this problem:

    Change ''Maximum incomplete TCP/UDP sessions number from same host'' from its default value to 20 (The default value is generally 10) in your routers firewall settings.

    This should solve the problem.
  18. TVR200 macrumors newbie

    Apr 19, 2010
    I have this problem too.
    PC laptops using the same software (Firefox) and the same router etc work perfectly.
    Brand new Macbook won't load more than one page of images from Google.

    I have looked at my router setting and I can't find any settings like the ones described.

    Any other ideas?:(
  19. davidperugini macrumors newbie

    May 29, 2010
    Kauai, HI
    A software conflict may be the cause ...

    The problem MAY be caused by a conflict caused by Russel Gray's 'AdBlocker' v. When I updated to version to AdBlocker version the Google Image Search thumbnails immediately returned. I 'Quit' and then 'Restarted' Safari , although I don't know if that step was really necessary - I just automatically did it as a matter of standard procedure.

    MacOS X 10.6.3
    Safari 4.0.5 (6531.22.7)
    AdBlocker (
  20. Levitron macrumors newbie

    Jun 9, 2010
    Got this problem as well...

    We use a few Macs at work, 10.4.11 (I know, but they don't want the "hassle" of updating...). Anyway, I can't load up most images from most image search sites (eg. google images, bing) no matter what browser I'm using. I can sometimes get google maps, but rarely google images. The work around I use is, if I search for what I need in the standard google, then select "images," I can get my results.

    Is the router "fix" working? Our tech guys get rather uppity when someone else suggests a technical solution...
  21. armadiljo macrumors newbie

    Jun 16, 2010
    In my case, I had several problems.
    MacBook Pro // Macbook
    Mac OS X 10.6.4
    Safari 5.0
    Glims 1.0b24
    with the same problems in Firefox. less problems in Opera (but I don't want to use that)

    safari crashes on several websites.
    -> solution: complete cleanup cookies/cache and reset

    no thumbnail images in google image search (in my old house + in my new house with different ADSL provider)
    -> no solution: complete fresh/clean install Macbook
    -> no solution: uninstall glims/adblocker
    -> solution: disable firewall in router

    It works, I'm glad.
  22. motodroid macrumors newbie

    Jun 17, 2010
  23. Meegot macrumors newbie

    Oct 4, 2010
    This solved it for me!

    I had this exact problem ever since I got my new belkin modem about six months ago. Pictures on Google image search as well as certian websites such as wouldn't load. I followed this suggestion and it is now fixed! Thanks Matt! PS - If you go to and need a password the default Belkin password is admin.
    Cheers, Megan. :)
  24. yanaivanov macrumors newbie

    Oct 8, 2010
    Mac OS X can't view images in browsers

    I have read all of the posts and tried to do all of the suggestions but I am still having no luck. I am not able to view any preview images in google or stock photo web sites. I have checked my firewall settings and it has always been set to OFF, I have checked the Safari preferences/appearance and it is checked as well. I have downloaded the suggested free application and that didn't fix anything either. I'm a graphic designer and I need access to images, can anyone help me please?:confused::eek:
  25. mozeydozey macrumors newbie

    Dec 8, 2005
    Cannot Load Images on Safari...

    Open Safari.
    Pull down on 'Develop" located between bookmarks and window up top.
    See where it says, "Disable Images".
    Make sure it is unchecked.
    That should do it.

    I stumbled upon this after searching for a solution for days!

Share This Page