Google keeps asking permission for location. Please help

Discussion in 'iOS 6' started by jwillpresents, Jan 25, 2013.

  1. jwillpresents macrumors member

    Jun 7, 2010
    Recently pretty much every time I search on google for my iPhone and iPad, it has started asking permission for my current location. It hasn't done this before and it's really getting on my nerves. Could someone please help with a fix?

    Attached Files:

  2. BHP41 macrumors 6502a


    Jul 21, 2010
    United States of America
    Not sure how to help on the pop up. I switched to Yahoo for search. Hasn't disappointed me yet. Googles business model is advertising and knowing your location is valuable to them for selling ads in that market. Yahoo asked but hasn't popped up since the time. I don't know of a way to permenatly restrict location from search.
  3. OriolesMagic macrumors member

    Jun 10, 2009
    I think it's because you have private browsing turned on. It doesn't ask me at all when I have it off. Just turned it on to experiment though, and I do indeed get the same pop up every search.
  4. Fischkind macrumors newbie

    Jan 13, 2013
    Your correct op has to turn off private browsing by general settings safari and turning off private browsing. Then google won't ask it Anymore. It does cause private browsing is not storing anything like cache or history so every time he goes there it is like his first visit.
  5. Futhark macrumors 65816


    Jun 12, 2011
    Northern Ireland
    I've private browsing off and it asks me every time.
  6. Daveoc64 macrumors 601

    Jan 16, 2008
    Bristol, UK
    That's because of how Safari remembers (or rather, doesn't) requests from websites for your location.

    It's up to the browser how you are asked for permission (if at all) and most browsers on desktop Operating Systems have an option to always allow (or deny) location requests for a specific site.
  7. Jab00 macrumors regular

    Jun 12, 2012
    I had this problem too and can confirm that switching off private browsing does fix it. But my question is why did this start all of a sudden? I have had my devices on private browsing for months and until like 2 weeks ago never ran into this problem...:confused:
  8. jwillpresents thread starter macrumors member

    Jun 7, 2010
    Exactly. It started happening just recently and I've had it on private browsing pretty much forever. Perhaps a bug from iOS 6.0.2?
  9. lemonbottle macrumors newbie

    Jan 29, 2013
    Definitely not. iOS 5.1 here and google asks me to use my location every time with private browsing on. I'd really like a solution that allows private browsing AND the nag screen being disabled.
  10. RichSinton macrumors newbie

    Feb 14, 2013
    Seem to have fixed mine

    Don't know if anyone has tried this but it worked for me.
    Went into Safari settings and Private Browsing is ON, and is staying that way!!
    Switching it off to test, made no difference. Still kept getting asked.

    So then i cleared the Cookies and Data and since doing that it hasnt asked me again!!??

    Corrupt Cookie somewhere I suspect
  11. jDW194 macrumors member

    Jan 12, 2013
    Canberra, Australia
    Excellent ... That's fixed it for me, thanks.
  12. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    I have never had private browsing set to on and it still has been asking me recently.
    There has to be some other issue going on also on this.
  13. SanjeevRana macrumors 6502a


    Aug 2, 2011
    I think Google made changes on the search page to ask for location and its not caching it due to privacy concerns
  14. brettO5 macrumors member

    Mar 11, 2012
    This worked for me. I've always had the problem of being asked for my location everytime I use the White Pages app. Clearing cookies and data has solved this thanks.

    Cheers, Brett
  15. RustyIron macrumors newbie


    Nov 17, 2009
    Just fixed it on my iPhone:

    Location Services
    Turn it ON for SAFARI

    Of course this is all assuming you have Location Services already turned on for GOOGLE.

Share This Page