Google Keeps Redirecting Me...Help!

Discussion in 'macOS' started by Big Tav, Dec 19, 2010.

  1. Big Tav macrumors newbie

    Joined:
    Jan 2, 2009
    Location:
    Sydney, Australia
    #1
    Hi guys, for some reason every time I go on Google and do a search it redirects me. Even if it takes me where I want to go when I close the window there is usually another page or two open that I never launched.

    Can anyone help? I am using Safari.

    Cheers.
     
  2. Big Tav thread starter macrumors newbie

    Joined:
    Jan 2, 2009
    Location:
    Sydney, Australia
    #3
    I looked there and I only have two codes in grey in the DNS setting.

    I am using a wireless router with a good password. My brother say he is not having the same problem on his PC laptop.

    I looked at the other threads (I did search first before I posted) and there seem to be just a lot of arguing about viruses and no answers for the average user like me :(

    I will look again. This only happens from Google.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Yes, but what are they? That's how we can determine if they're the problem or not.
    Unfortunately, many who are uninformed about malware tend to cloud the real issue (DNS settings) with bogus statements about viruses. Hopefully, this thread will remain on topic.
     
  4. Btrthnezr3 macrumors 6502a

    Btrthnezr3

    Joined:
    Aug 5, 2010
    Location:
    Texas
    #5
    I had the same issue on a windows machine and it was some sort of malware. I only got rid of it by doing a reinstall of the os. I don't know how or why it would happen on a Mac
     
  5. Big Tav thread starter macrumors newbie

    Joined:
    Jan 2, 2009
    Location:
    Sydney, Australia
    #6
    They are:
    85.255.115.43
    85.255.112.170

    I also did the dnschanger scan. Nothing was found.
     
  6. GGJstudios, Dec 19, 2010
    Last edited: Dec 19, 2010

    GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    Change those to OpenDNS:
    208.67.222.222
    208.67.220.220

    To make changes to your DNS settings:
    1. Go to System Preferences > Network
    2. Click the padlock icon in the lower left corner where it says "Click the lock to make changes."
    3. Enter your administrator password when prompted
    4. Select your network in the left column and click the "Advanced" button
    5. Click the DNS tab
    6. To remove an item, click on the IP address under "DNS Servers", then click the "-" button below to remove it.
    7. To add an item, click the "+" button and type the new DNS Server IP address
    8. When finished, click "OK" to close the advanced settings window
    9. Click "Apply" to make the changes to your network settings.

    Have you recently installed any software, such as codecs needed to watch certain videos?
     

Share This Page