Google maps cant find location after JB

Discussion in 'iPod touch' started by nigameash, Oct 22, 2010.

  1. nigameash macrumors 6502

    Dec 6, 2008
    Space: The Final Frontier
    I am using an itouch 4. After I jailbroke my device, I have issues with google maps every now and then at random. I didnt notice any problems for a while and suddenly one day i got an error "Your location could not be determined". Then I killed all my apps, turned off locations and rebooted my itouch and voila, google maps started working again. Now I got the same problem and nothing i did helped the situation. google maps still cant find my location.

    I've read about similar problems on some spanish forums but nothing in english and i didnt find any solutions.

    Are there any cydia apps that are known to interfere with google maps? Or are there any known solutions to this problem? I jailbroke my device with limera1n. I couldnt even find this problem in the list of known bugs with limera1n.


    I tried the solution here thats provided for the ipad and it works
  2. Skyhigh223 macrumors regular

    Jul 21, 2009
    It's just an intermittent problem, your iPod finds your location based on any WiFi hotspots around you.

    It can only get your location if Apple's database has the WiFi hotspots in, or if you provide enough hotspots to get a good fix.

    My iPod finds my location 80% of the time at my home, and if it misses it once, I certainly don't restore my iPod over it :p

    Just relax, and try once or twice to find your location, try moving to an area where you know there are more WiFi hotspots or where you will get better reception from them.

    I'm 99% sure that jailbreaking has nothing to do with this. You may just be covering the WiFi aerial in some instances and cutting that key hotspot off, therefore leaving your iPod unable to find a fix.
  3. nigameash thread starter macrumors 6502

    Dec 6, 2008
    Space: The Final Frontier
    well i am in the same area as i was before i jailbroke my device and the wifi networks around me havent changed.

    also the solution i tried worked but now it stopped working again.

    i need a permanent fix


    when google maps cant find your location, try this.

    1) Open SBSettings and make sure SSH toggle is activated (green) and note the Wi-Fi IP address of the iPad.

    2) Open Terminal , and type in:

    ssh (Replace with your iPad WiFi address) and it should be like ssh root@

    3) You will be prompted to enter your password. If you have not changed the default password is alpine.

    4) Now execute following commands

    launchctl unload /System/Library/LaunchDaemons/

    Press enter

    launchctl load /System/Library/LaunchDaemons/

    Google maps will start working again.

    I tried it now again and locations are working again.

    is this an apple bug or a jailbreak bug?

Share This Page