Google Maps don't work on my MB

Discussion in 'MacBook' started by parajba, May 10, 2008.

  1. parajba macrumors 6502

    Joined:
    Apr 19, 2008
    #1
    Hi everybody,


    I have recently switched to apple, have been a PC user since 8088 machines (!)...I'm literally loving it, should have done earlier!

    So, a couple of weeks ago I bought a white 2.4 MB. The computer is fast and efficient, absolutely happy about it. I'm having 1 problem only, I can't use google maps. The page doesn't load completely and the map stays gray.

    Is it just my MB???

    Thanks for your help!
     
  2. Chappers macrumors 68020

    Chappers

    Joined:
    Aug 12, 2003
    Location:
    At home
    #2
    Well its working OK on my MacBook.

    Your MB is the same as mine - my internet connection isn't great but it I don't have problems.

    Which Web browser are you using.

    Have you repaired permissions, run cron scripts recently.

    When ever my macs mis-behave I always repair stuff. I use "iceclean" these days - it take several minutes to do "All maintenance tasks and reboot" from the "Maintenance" menu. But its often worth it.

    http://www.versiontracker.com/dyn/moreinfo/macosx/31818

    Although I'm not that keen on the new version - however it does the job.
     
  3. parajba thread starter macrumors 6502

    Joined:
    Apr 19, 2008
    #3

    Hi thanks for the prompt reply!
    The thing is that Google Maps never worked, since day one...
    I've got Safari 3.1.1...
    I just updated the sw and downloaded Java 6, all good now!
     
  4. parajba thread starter macrumors 6502

    Joined:
    Apr 19, 2008
    #4
    Sorry, I was wrong, I still have the same issue...
     
  5. Chappers macrumors 68020

    Chappers

    Joined:
    Aug 12, 2003
    Location:
    At home
    #5
    Very strange - have you tried Firefox?

    And did you try the whole repair thingy?
     
  6. parajba thread starter macrumors 6502

    Joined:
    Apr 19, 2008
    #6
    I tried the repari thingy with IceClean but nothing, Googles Maps is still not working properly. Actually, I can't use it at all, it's not loading the pages and it freezes.

    Taking into account that my MB is brand new and I haven't done anything wrong so far (I've been on 'good' websites, listened to mp3 and watched my pics), what can it possibly be? Isn't a brand new MB supposed to work perfectly with the most common applications/interfaces? I think Google Maps is a very common app! Am I the only one having this problem? I do not want to try Firefox and start fiddling arond with sw because the MB comes with Safari, I like Safari, and I don't want to change it...It's extremely quick and efficient.

    I don't want to do the sort of things I was doing on Windows...I mean fiddling around...

    Very bizarre because the MB (for the other things) is very fast and work perfectly well!

    Help...?

    :confused:
     
  7. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #7
    I haven't had Google Maps work with Safari 3 in OS X or Windows. I use FireFox or Google Earth.
     
  8. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #8
    Mine is just fine, been using Google Maps via Safari for quite awhile now, without a problem. :confused:
     
  9. mavherzog macrumors 6502

    Joined:
    Jun 11, 2005
    Location:
    Columbus, WI
    #9
    how are you connecting to the internet? (cable, DSL, etc)

    What do you have at your perimeter? (linksys, airport, nothing, etc)
     
  10. parajba thread starter macrumors 6502

    Joined:
    Apr 19, 2008
    #10
    I've got DSL (8MB)...I've got nothing at my perimeter...I've been living here for a couple of years, and I've been surfing using the same wifi router with my other laptop Sony...which is still just fine with Google maps btw.. I'm going to install google earth and see what happens...
     

Share This Page