Google Maps Zoom - Safari Lag

Discussion in 'macOS Sierra (10.12)' started by doogie89, Apr 8, 2017.

  1. doogie89 macrumors newbie

    Joined:
    Jul 27, 2009
    #1
    I've been having this issue where zooming in and out in google maps using the safari browser is really laggy. If I use Chrome then the zooming in and out is buttery smooth. I have an iMac Retina 5k 27-inch Late 2014 computer running the latest macOS Sierra version 10.12.4.

    I tried to reset the NVRAM and I have 24GB of RAM with about 18GB free when this happens. I performed a complete wipe of the OS and reinstalled it, and only restored my user profile and no applications or settings. I still am having this issue.

    Does anyone have any tips or solutions?
     
  2. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #2
    Honestly, stop using Safari for GMaps. Really.

    I've used other browsers with GMaps - Chrome, FF, Vivaldi, Opera Beta/Next - and they're all smooth as you've described.

    What confounds me, to a degree, with Safari and some web sites like GMaps, is that they don't switch to the dGPU when in Safari. It's not a "WebKit" thing, as I also use Fluid (the paid version), and have a Fluid app specifically for Google Maps - the dedicated GMaps Fluid app does use hardware acceleration (noted in Activity Viewer, the Energy Tab, "Requires High Perf GPU") and is much smoother than Safari. I've even turn off Automatic Graphics Switching and still Safari won't use the dGPU regardless of whether I'm using an internal or external display.

    I'm surmising at this point that Apple has "wired" Safari to be a low-energy-impact browser. I've done two bits with Safari - first, tried toggling about every built-in and Developer setting and, second, pretty much given up on using Safari for a lot of graphics-intensive sites. Sigh.
     
  3. alex.houston macrumors member

    Joined:
    Oct 14, 2016
    Location:
    Indiana
    #3
    Yeah, mac generally seems to be avoiding using discrete graphics for Apple apps. Try turning off "Automatic graphics switching" in System Preferences > Energy Saver.

    See "macOS Sierra: If graphics-intensive tasks slow down your Mac": https://support.apple.com/kb/PH25402?locale=en_US
     

Share This Page