google not working on my mac

Discussion in 'Mac Basics and Help' started by showtime, Jun 15, 2007.

  1. showtime macrumors 6502

    Joined:
    May 10, 2007
    #1
    I have a macbook on connected through wireless and it won't load sites like google.com. Anything related to google like gmail or the google search bar doesn't work.

    I'm pretty sure that this is a wireless problem because I have been able to use it before on my school network. I have 2 windows machines on the network (one connected directly and one wirelessly) and they both work fine.

    Any ideas? Thanks.
     
  2. Steviewest macrumors newbie

    Joined:
    Nov 6, 2003
    Location:
    Edinburgh, Scotland
    #2
    So it loads other sites but nothing related to Google?

    Are you sure that it's connected to your own wireless network? Maybe you picked up a neighbouring network which blocks Google? (Our company network blocks certain sites).
     
  3. M@lew macrumors 68000

    M@lew

    Joined:
    Nov 18, 2006
    Location:
    Melbourne, Australia
    #3
    Tried another browser? Does it work there? Also, have you ever been able to connect to Google through this wireless point before?
     
  4. showtime thread starter macrumors 6502

    Joined:
    May 10, 2007
    #4
    I'm connected to my wireless. It's password protected and everything. I wouldn't say every website works. I'm thinking it's certain types. For example, when I click a user's name here on macrumors, the little popup box doesn't come up.

    I've tried it with firefox too. No go. This isn't the first time this is happened. When I first got my mac and set up my wireless it had the same problem. I never fixed it, went back to school, came back and then it worked. Now I'm back and it's not working again.
     
  5. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #5
    Were you required to set a proxy server or anything like that to use the school network? If yes, is that proxy setting still lurking in your network settings?
     
  6. showtime thread starter macrumors 6502

    Joined:
    May 10, 2007
    #6
    I'm not sure if I was. I was able to connect to google after the one time I couldn't and before today so it might not be that. But if it was how would I go about changing this?
     
  7. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #7
    To check this out, go into System Preferences, Network icon. Pick your active network connection from the Show: menu there, and look under the Proxies tab. You'll just want to make sure that nothing (especially HTTP) is checked.
     
  8. showtime thread starter macrumors 6502

    Joined:
    May 10, 2007
    #8
    Thanks for all the suggestions guys but it's still not working for me. None of the boxes are checked.
     
  9. showtime thread starter macrumors 6502

    Joined:
    May 10, 2007
    #10
    thanks for the suggestion flopticalcube. I just figured out what the problem is but still can't fix it.

    Apparently I can't connect because of my wireless security. When I have it set to none on my router I can connect to google just fine. When I have it on wpa or wpa2 google stops working. When I change it back to open it works perfectly. Any suggestions?
     
  10. showtime thread starter macrumors 6502

    Joined:
    May 10, 2007
    #11
    anybody ever have any problems connecting to their secured router? I have a netgear wgt624 btw.
     
  11. modconfig.t macrumors newbie

    Joined:
    Jun 18, 2007
    #12
    router/computer issue

    first i would recommend rebooting the machine to see if it's a cache issue with the network settings. if it doesn't resolve the issue, i would factory restore the router, and redo the security implementations again. be sure that the firmware for the router is up-to-date also.

    other than that, i would be completely lost, besides running the daily, weekly, and finally the monthly scripts.
     
  12. drlev macrumors newbie

    Joined:
    Jun 28, 2007
    #13
    have the same google.com problem

    Hi there, I have the exact same problem on my macbook! I was researching google(on my pc computer) and found this article. It seems to be a DNS problem in my network settings. I tried typing google's IP address and it appeared! I have included the link to the web page at the bottom and pasted his response.

    hope this helps.


    When you're in a situation where you can connect to a network, but there's the appearance that you can't connect to the internet, the very first thing to check is that you REALLY can't connect to the internet, or if you just have a DNS problem.

    DNS is the service that converts domain names (for example forums.macosxhints.com) to the IP addresses that are actually used on the internet (for example 129.250.134.26).

    A common situation is that you actually DO have a connection to the internet, but because there's some problem with DNS, all of the domain names that people regularly use are not being translated to IP addresses.

    It is quite easy to check this: just try using an IP address instead of a domain name. So, for example, you can enter http://64.233.167.99 into the URL address field of your browser of choice (like Safari or Firefox). If that IP address brings up Google, even though entering http://google.com does NOT bring up Google, that means that the actual problem is with DNS, not with the internet connection.

    If that is the real problem, then enter a DNS server explicitly into System Preferences > Network > Show: your network interface, such as Airport > TCP/IP tab > DNS Servers. You can get the IP address of DNS servers from your internet service provider, or there are lists online of public DNS servers.


    http://forums.macosxhints.com/archive/index.php/t-60382.html
     
  13. kjbrazil macrumors newbie

    Joined:
    Jul 8, 2007
    #14
    10.4.10 update

    This just started happening to me with the 10.4.10 Intel update on my 2.16 Ghz Macbook Pro. I've been using WPA-preshared authentication since October without issue on my Juniper (Netscreen) 5GT wireless firewall/router until last week when I got the OS X update.

    When I turn off security on my wireless or use WEP I can get to google.com and other google-related websites fine. When I use any form of WPA I can't get to google.com or doubleclick or most other google sites.

    This is very strange - it doesn't affect my girlfriend's iBook G4. Also the problem does not occur with my Macbook Pro when connected to my neighbor's Linksys router which is also WPA protected. My brother has a newer Core 2 Duo Macbook Pro and he hasn't noticed any issues either (same firewall/router as me).

    I also tried everything - DNS, MTU, looked at packet captures, etc. but could find nothing obvious. Packets from my firewall were simply not being picked up by the Airport card. Must be a lower-level driver issue.

    I would obviously like to use WPA instead of WEP. I guess I'll be opening a ticket with Apple Care tomorrow.

    Cheers,

    Kelly
     

Share This Page