Google search problems

Discussion in 'iOS 10' started by EzDoesItSC, Mar 29, 2017.

  1. EzDoesItSC macrumors member

    Joined:
    Nov 20, 2012
    #1
    On my iPhone 7 plus in safari when I go to google I can't get it to stop saving searches. I have read all the articles and watched videos. My activity settings are all set to pause and it still shows the last 3 things I search for every time. Has anyone got any idea how to fix this? Thanks.
     
  2. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
    #2
    Private Browsing mode.
     
  3. willmtaylor, Mar 29, 2017
    Last edited: Mar 29, 2017

    willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #3
    Use DuckDuckGo instead.
    --- Post Merged, Mar 29, 2017 ---
    I don't know what that means, but have you gone into Safari's settings and disabled "Search Engine Suggestions" as well as "Safari Suggestions"?
     
  4. EzDoesItSC thread starter macrumors member

    Joined:
    Nov 20, 2012
    #4
    Everything is disabled in safari and I turned on private browsing in google. Is there somewhere in the phones settings to do that as well?
     
  5. EzDoesItSC thread starter macrumors member

    Joined:
    Nov 20, 2012
    #5
    I found private mode in safari and that works but there has to be a way to get it back to not saving them without that. It wasn't saving them until I had to delete cookies and website data last night and now it saves everyone of them.
     
  6. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #6
    The Safari settings are the phone settings.

    IMG_8576.PNG
     
  7. EzDoesItSC thread starter macrumors member

    Joined:
    Nov 20, 2012
    #7
    Got those. Didn't change anything. Frustrating.
     
  8. EzDoesItSC thread starter macrumors member

    Joined:
    Nov 20, 2012
    #8
    [​IMG]
    When I click search history and manage it takes me to the the 2nd picture I posted. [​IMG]
     
  9. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #9
    Out of curiosity, why are you going to Google.com instead of just searching from your safari address bar? It's a search field as well.

    By the way, if privacy is a concern, don't use Google at all. I know this isn't a solution to your problem, but it's worth noting.
     
  10. EzDoesItSC thread starter macrumors member

    Joined:
    Nov 20, 2012
    #10
    I've just always had the google website under my favorites and just used it that way. I've never tried searching from the address bar. Still doesn't solve this issue but I will try that out.
     

Share This Page