Google Voice not forwarding call iPhone7 Plus

Discussion in 'iPhone' started by brianric, Aug 5, 2017.

  1. brianric, Aug 5, 2017
    Last edited: Aug 5, 2017

    brianric macrumors regular

    Joined:
    Jul 30, 2011
    #1
    I'm having problems at times receiving calls from Google Voice on my iPhone 7 Plus. Service is with Verizon. Cell tower 1.5 miles away, getting 3 out of 5 bars for a signal. The problem is sporadic. My T-Mobile Android phone will ring even when the iPhone doesn't. Before I activated my T-Mobile To Go phone, the only way I knew that a call didn't ring on the iPhone was a text message and email saying I had a missed call or voice mail. Is this a known problem with either the iPhone, Google Voice, or Verizon?
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    I haven't had any such issues on my iPhones through the last several years...first on AT&T and now on StraightTalk.

    I suppose the issue could be with Verizon but how is one supposed to know? It could also be an issue related to your specific GV account. Creating and testing a new GV number might eliminate that possibility.

    Have you re-checked every setting at the Google Voice "Legacy" site?
     
  3. brianric thread starter macrumors regular

    Joined:
    Jul 30, 2011
    #3
    I'm not about ready to change GV number. I've had that number since 1989 as a Bell Atlantic land line that I initially ported to AT&T wireless, then I ported over to GV. I just installed Hangouts to see if this may resolve my problem. I really don't want to switch over an Android phone because I have a series 2 Apple Watch, and use it to remind me when to take my Parkinson's medicine, which is three times a day. It gets expensive to switch to Android, and that will be my last resort. Re-validated my settings.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    No mention of "change". I wrote of "testing". If a new number works flawlessly there might be a difference in settings or even an issue with the specific account at Google.

    So...your iPhone would often not ring even when it was the only device to which you were forwarding your GV number? Did you have any specific "Groups & Circles" settings (Legacy) that might be causing a premature voicemail switch?

    Have you searched to see if any other Verizon users had similar issues?

    This could be a particular combination of forwarding GV to Verizon and the number of rings before sending to voicemail. If this is the case it might be cured by increasing the number of rings with Verizon.
     
  5. brianric thread starter macrumors regular

    Joined:
    Jul 30, 2011
    #5
    Unless I'm not understanding how Google Voice works, there are only two ways of getting a new GV number, either give up my present GV number, or open up a new email account and put in for a GV number on that account, neither of which I'm going to do.

    The most recent case where my iPhone did not ring came from a Benefits Express person who wasn't on my contact list. The only way I knew he called was the being notified by GV that I had new voicemail. I then went to GV and "turned on" forwarding to my T-Mobile To Go Android back up phone. Later that night I received another call from the same person. iPhone was silent, Android phone was ringing. I almost didn't get to the Android phone in time before the call went to voice mail. I already have my iPhone with Verizon set to maximum number of rings before going to VM.

    The problem doesn't happen all the time. Most calls do ring the iPhone, but the few that don't ring the phone it is annoying. On Groups and Circles some of them also included Google Talk for forwarding. I just went in and disabled that option.

    I did install Hangouts and see if that may solve the problem for now. It's really not and ideal solution as the calls are treated as data, not cellar. As far as checking with Verizon users, I thought I would check here first. Looks like I'm going to have to go to Howards Forum and post my question there. Thank you for your help. I hate to resort to the last option and get rid of the iPhone for and Android. In the mean time I'll carry my backup Android phone with me until I either give up on the iPhone or I solve the problem.

    Again thank you for offering solution to my problems. Keeping fingers crossed disabling Google Talk might solve the problem.
     
  6. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #6
    Verizon. I have Google Voice. I have 1-2 bars of Verizon at my house (max at my work, college, etc...). Even normal calls straight to my iPhone I can get 1 ring or no ring.

    WiFi calling has been the savior of my situation at home. It fixes everything. It allows me to get calls - Google Voice or not.

    Without WiFi calling - I'll never get notified of calls save for the Google Voice email/app notification that I had a missed call.

    Doesn't happen too often and I use my phone as a telephone less than 5% of the time, lol - so it doesn't bother me too much but it is annoying. Now with WiFi calling, I'm good for now.

    Having used an Android phone at my house - I've had the same problem so I think it's more than Verizon --- my house is in a dead zone (1-2 bars at best). But I could be wrong as I haven't scientifically tested anything. :p
     
  7. brianric thread starter macrumors regular

    Joined:
    Jul 30, 2011
    #7
    Wi-Fi calling may indeed solve my problem. Problem I see with Wi-Fi is when I'm not at home but on xfinitywifi if available. it has been my experience with Wi-Fi for data in week areas that trying to surf the web is almost impossible, especially if I'm in a strong cellular area. I don't know how Verizon handles Wi-Fi calls. Does it default to the strongest signal or stays on Wi-Fi come hell or high water. Usually when I'm in a weak area with Wi-Fi and want to surf the Web I just forget the network or turn off Wi-Fi and use cellular. Just got off the phone with Verizon, they don't feel it's a problem on their end. Verizon also told me with Wi-Fi calling the call defaults to the strongest signal, either Wi-Fi or cellular. My next option if Wi-Fi or Google Hangouts doesn't work is to temporarily activate my Samsung 7 Edge and see what happens. This can be a long involved process as I don't make or receive many phone calls.
     

Share This Page