Got 8GB Memory but only shows 4GB

drfunk1986

macrumors newbie
Original poster
Aug 6, 2012
15
1
Hey guys, sorry to be posting already but i need some quick answers and solutions. I recently was given a Mac Mini that is only a year old at this point, it had like 2GB RAM but I upgraded to 8GB ram buy purchasing 2 (4GB) RAM cards. Now, I recently switched them out and it turns on perfectly however when i visit the "about this mac" page, it states I only have 4GB RAM in there. Is this something Mac's tend to do where they don't report all 8GB being used? Or is it possibly that my slots aren't in all the way on one card?
 

Ifti

macrumors 68020
Dec 14, 2010
2,330
465
UK
It should show the full 8GB.
Check the RAM is properly seated into the bank.
 

fig

macrumors 6502a
Jun 13, 2012
916
70
Austin, TX
It should show the full 8GB.
Check the RAM is properly seated into the bank.
Exactly what I was going to say.

If you've never installed RAM before you need to push it in harder than you expect to, it'll solidly snap in when you do it right.
 

paulrbeers

macrumors 68040
Dec 17, 2009
3,960
120
Check in your system profile to see what OSX states is in each RAM slot. I bet you will see that one slot isn't filled. Re-seat the RAM and if that doesn't work, try swapping the sockets of the RAM to see if you somehow damaged a RAM socket or if it is just a bad stick (most likely the latter).
 

QuantumLo0p

macrumors 6502a
Apr 28, 2006
987
27
U.S.A.
Ditto.

When I upgraded the ram in my 2010 Mini I had the same issue and had to re-seat the ram. I recall how hard the ram seated in the slots; I mean HARD. I remember thinking, wow, this can't be right and thought I may have broken it but it turned out just fine.
 

4PPl3

macrumors newbie
Oct 24, 2011
8
0
To check to make sure your RAM is all in, just hold down the ⌥ option key while going into the  Apple menu, and select 'System Information'. From there select 'Memory' under the Hardware tower and it should will tell you which of your modules are working correctly and which isn't.