Got MMS & EDGE working on iPhone 4 with T-mobile USA

Discussion in 'Jailbreaks and iOS Hacks' started by Eric Noa, Aug 7, 2010.

  1. Eric Noa macrumors 6502

    Eric Noa

    Joined:
    Nov 4, 2008
    #1
    Hello guys I finally got my MMS & EDGE to work with the iPhone 4 on T-mobile USA. (I have the Unlimited Even More Plus Family Talk and Text with the $10 Unlimited Web For Phones)

    I will post everything I did to get it to work and tomorrow I will do a demonstration of it working so you guys can believe me! ;) Unfortunately still not Facetime, but nor really important to me!

    1.Jailbreak and Unlock your phone using Jailbreakme and Unltrasn0w
    2. Settings -> General -> Reset -> Reset Network Settings (Only do this if you have already tried changing your settings)
    3. Cydia -> Manage -> Sources -> Edit -> Add -> http://beta.leimobile.com/repo -> Return To Cydia
    4. Click on LEIMobile Repo -> Install T-Mobile 4.0 MMS Fix -> Reboot
    5. The previous steps were done with the T-mobile SIM in your iPhone 4, after you complete those 4 steps take out the T-mobile SIM and insert the AT&T SIM.....wait 10 sec and take out the AT&T SIM and insert the T-mobile SIM.
    6. Settings -> General -> Network -> Cellular Dada Network -> Type in the following settings!

    Cellular Data
    APN: internet2.voicestream.com
    Username: Leave Blank
    Password: Leave Blank

    MMS
    APN: wap.voicestream.com
    Username: Leave Blank
    Password: Leave Blank
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.050:8080
    MMS: Max Message Size: 1048576
    MMS UA Prof URL: www.apple.com/mms/uaprof.rdf

    When I send an MMS to myself it sends and a couple of seconds after it sends I receive it, The only issue Im having is when someone send me an MMS I can't receive it, this is what I get:

    "The media content was not included due to a picture resolution or message size restriction."

    As soon as I get this fix I will post it here! If anyone needs help just let me know!
     
  2. Eric Noa thread starter macrumors 6502

    Eric Noa

    Joined:
    Nov 4, 2008
    #2
    I also got Internet Tethering to work! Just use the same APN as the one for Cellular Data and leave Username and Password Blank
     
  3. mrzeve macrumors 6502a

    Joined:
    Jan 25, 2005
    #3
    Can anyone confirm? Also, do you lose settings once you restart the phone?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    So you didnt get MMS working on iphone 4 with Tmobile then.
    The same problem everyone is having.
     
  5. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #5
    install sinful iphone repo, there is a cydia installable fix titled 't-mobile mms fix' or something similar. this is far easier than the multiple steps fix everybody is posting. i am on a 3gs on ios4, however, so i cannot confirm anything on the iphone4.
     
  6. mrzeve macrumors 6502a

    Joined:
    Jan 25, 2005
    #6
    The following worked for me to get MMS & Internet working on T-Mobile USA (even after restarting the iPhone 4):

    MMS
    Add http://beta.leimobile.com/repo/ to your cydia sources and Install the T-Mobile 4.0 MMS fix, then reboot

    Add this to your Settings>General>Network>Cellular Data Network
    MMS
    APN: epc.tmobile.com
    Username:
    Password:
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf

    Internet
    APN: internet2.voicestream.com

    FYI: I'm on the $20 a month unlimited Blackberry Internet plan from T-Mobile
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    I tried that before, MMS wouldnt send either.
     
  8. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #8
    make sure cellular data is turned on and you have "epc.tmobile.com" under APN for both cellular data and MMS. i just tried sending a few pictures now that worked and i am on the purely prepaid plan where i just pay $100 for 1000 minutes whenever i get low.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Would that also work on postpaid monthly accounts?
     
  10. mrzeve macrumors 6502a

    Joined:
    Jan 25, 2005
    #10
    Follow "my" instructions. They worked flawlessly for me.
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    Ok, I will try them both and hope one works:D
    Thank you.
     
  12. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #12
    i believe so. there were people with many diff kinds of plans on another forum where i was checking up on info. it looked as if everybody could get it to work, perhaps with diff settings though. if what i said doesnt work, there are 2 different APNs you can try.
     
  13. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #13
    by the way, can you add edge to a purely prepaid account like the one i have? if so, how?
     
  14. miki66 macrumors 6502

    miki66

    Joined:
    Nov 19, 2008
    Location:
    IL
    #14
    congrats :) i'm also using t-mobile so it's a very good news for all of us
     
  15. mrzeve macrumors 6502a

    Joined:
    Jan 25, 2005
    #15
    So howd it go?
     
  16. jdlorinser macrumors member

    Joined:
    Jun 20, 2010
    #16
    It worked for me at first. Then after a power off and on, I couldnt send an MMS anymore (didnt try to receive one). Also: data stopped working.

    Edit:
    Strange, I noticed that if you remove the sim card and then put it right back in, everything works again.
     
  17. Eric Noa thread starter macrumors 6502

    Eric Noa

    Joined:
    Nov 4, 2008
    #17
    Yes I did! The only problem is that I can't received MMS.... but if I send it to myself I receive it or If I send it to someone else they receive it too
     
  18. Eric Noa thread starter macrumors 6502

    Eric Noa

    Joined:
    Nov 4, 2008
    #18
    For some odd reason everything was working last night and this morning and now all of a sudden no MMS at all nor Internet!!!
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    I didnt get to try it yet.
    I unlock alot of iphones for friends and family and did a few to be used for tmobile latelly.
    Couldnt get any of those solutions to work on the MMS part.
    So I gave up and told them to use texts and email the pics instead :D
     
  20. DJohm macrumors member

    Joined:
    Jul 13, 2010
    #20
    AppleJ...we're counting on you bruh. I'm in the same boat with most of the posters here. Tmobile MMS issue is a bummer. I just like there plan, especially having unlimited data, enough to keep me with tmo. Hopefully this gets resolve soon...
     
  21. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #21
    I hope so too.
    I came across many tutorials but most of them fail or either send but not receive and many other issues. Or they stop working after you restart the phone etc...
    I wonder why they cant come with a fix for this?
     
  22. Showtime3 macrumors member

    Joined:
    Jul 19, 2010
    #22
    ive had the orginal iphone, 3g and 3gs unlocked over tmobiles edge network. i just switched everything over to att for the ip4, and trust me the 3g service is worth the extra money.

    i use to have to jump through all of these hoops to get mms and the internet working and its just plain annoying. you guys should consider switching to att. iphone plans can be pretty cheap on a family plan
     
  23. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #23
    I agree.
    The painfully slow edge and no visual voicemail and other things is not worth it IMO.
     
  24. powerbuddy macrumors 6502

    Joined:
    Jun 20, 2006
    #24
    Is this fix for all iPhones 3G/3GS/4 or only iPhone 4?

    I have an unlocked iphone 3gs and my Edge is working fine. I do not send mms so i could care less. But, wondering if I still need this to speed up EDGE or something...?
     

Share This Page