got netshare from torrent, onto iphone? (non-jailbroken)

Discussion in 'Jailbreaks and iOS Hacks' started by ashjamben, Aug 7, 2008.

  1. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #1
    basically i posted on the main netshare thread about downloading it from a torrent website (i said on that thread that i dont normally use torrents, as i buy all my own cd's, dvd's and software)

    but anyway, a user, who ive tried to contact via PM, said there is a way of getting apps that have been downloaded in this way onto an iphone that hasn't been jailbreaked. he specifically said it was done using a PC, not a mac.

    anyone got any insight into this?
     
  2. BMP1199 macrumors member

    Joined:
    Jun 14, 2008
    #2
    please share any info... i would like to know this as well
     
  3. americaskate macrumors member

    Joined:
    Apr 19, 2008
    #3
    You cannot do it unless the phone is jailbroken.
    How else are you supposed to add files into the phone?
     
  4. ashjamben thread starter macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #4
    i don't know, that's exactly why i asked the question. obviously someone knows (or is making up) a way of doing it.
     
  5. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #5
    jailbreak phone then ssh it into the apps folder
     
  6. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #6
    And, you know, don't mention the permissions changes you need to apply...
     
  7. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #7
    iTunes won't recognize it if its a legit app even if it isn't downloaded from the store?
     
  8. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #8
    You must have a jail-broken iPhone. I tested this on a first-gen iPhone running 2.0, but it should work on 3G iPhones as well.


    Using an SFTP application (I use Cyberduck), drag the NetShare.app/ folder from the desktop into the iPhone's /Applications folder.

    Open a terminal window, and open an SSH session with the iPhone:

    $ ssh root@192.168.0.5

    (replace the IP address above with your iPhone's IP Wi-Fi address.) The default root login password is "alpine".

    Next, go to the NetShare.app folder:

    # cd /Applications/NetShare.app

    and change the access file mask of the main application file:

    # chmod 755 NetShare

    Reboot (or re-spring if you know how) your iPhone.

    You're done!

    -----
    Shamelessly ripped from wherever I got it from.

    Disclaimer: Down with piracy, up with tethering.
     
  9. NiroshanMan macrumors 6502

    Joined:
    Jun 25, 2007
    #9
    Actually there is a way to do it without using permissions, you replace a MobileInstallation file and then you open cracked .ipa files in iTunes and the next time you sync up your iPhone your apps will be put on your iPhone just like any legit app. Currently im trying to figure out a way where you can view the internal iPhone folders, without jailbreaking, I found one app DiskAid, but you can't reach the right folders, but you can see hidden folders, like in a normal iPod, when its in diskmode.
     
  10. tehfrag macrumors newbie

    Joined:
    Jul 26, 2008
    #10
    If you've read the instructions for or done the "MobileInstallation" hack you'd know you still have to change permissions on multiple directories for it to work.
     
  11. yaniv1818 macrumors newbie

    Joined:
    Aug 9, 2008
  12. rtztgue macrumors regular

    Joined:
    Aug 9, 2008
    #12
    I was able to get the netshare file and itunes recognizes it but wont install, so same problem here. I did hear a rumor that there is a cracked version of netshare than can be dropped into itunes and installed but i have not seen it. I think apple must have someone 24/7 finding these files (if they exist) and then doing whatever they can to hide them. Anyone know if there is a cracked version of netshare?
     
  13. NiroshanMan macrumors 6502

    Joined:
    Jun 25, 2007
    #13
    Actually you don't need to change the permissions to work. I've replaced the file on three different iPhones/iPod Touches and they have worked fine.
     
  14. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #14
    I'm confused....

    1. Can we get the torrented app into iTunes to act like a paid app or not?
    2. Do we have to change permissions or not?
     
  15. quis5550 macrumors newbie

    Joined:
    Aug 9, 2008
    #15
    custom pwnage 2.0 2

    dont restore usin g custom pwnage use simple mode pwnage worked great for me
     
  16. NiroshanMan macrumors 6502

    Joined:
    Jun 25, 2007
    #16
    1) Not at the moment. If there was it would have to be cracked in a certain way, which no one has done yet

    2) I haven't had problems with changing permissions for files when i used Open SSH and then loading the cracked .ipas onto my iPhone it works fine.
     
  17. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #17
    Niro - Which instructions are you following? That's the other worry I have before beginning.... various instructions flying around. Not sure which one to go with.
     
  18. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #18
    1) you can load an .ipa from iTunes, but you must swap out the "mobileinstallation" file per directions first.

    2)You also need to change permissions on that new "mobileinstallation" file to 775.

    One set of instructions erroneously refers to the "mobileinstallation" file as "mobileframework" He made a simple mistake. Just think the first one if you read the second one.

    If you're trying to install a .app (instead of .ipa), use ssh to drag the file to the applications folder and follow what ever instructions came with the .app.
     
  19. The General macrumors 601

    Joined:
    Jul 7, 2006
  20. NiroshanMan macrumors 6502

    Joined:
    Jun 25, 2007
    #20
    I've never had to change permissions for it to work. Ive just had to replace the file, reboot and then sync the cracked apps onto my iPhone from iTunes.
     
  21. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #21
    The question is, where did you find the instructions to put it into iTunes, etc. or what method did you use? I'm having issues finding good instructions on how to get it into iTunes.
     
  22. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #22
    My Netshare folder says .ipa In that, there's a file? called iTunesArtwork and folder called Payload. In that, there's a folder called Netshare.app. Do I put just the netshare.app in the applications directory?

    And the command $ ssh root@***.*.*.*** doesn't work.
     
  23. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #23
    The .app goes in the applications directory and .ipa is for iTunes but not necessary. Did you install the SSH package via Cydia?

    Your missing something somewhere.
     
  24. hotshotharry macrumors 6502

    Joined:
    Sep 6, 2007
    #24
    For the anti pirating camp - maybe you haven't noticed that you absolutely cannot buy this functionality, that option has been removed unfortunately.
     
  25. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #25
    Lavrishevo - At some point I figured out to put just the .app in the phone. Yes, Ssh was running. Then I tried terminal using the no "$" and "#" in front of the commands and it worked.
    I "think" I have it now.

    I sure could kick myself for not grabbing it the two times it was in front of my face on the store. It's really for my husband for any occasion he'd need this in a pinch.

    I'd still like to get it into iTunes properly but couldn't get past making a backup of the mobileblablabla folder. Couldn't figure out how to do that in Fugu. Perhaps learning CyberDuck might be the better way to go. IDK.
    Thanks!!!

    -----------------------

    As for 'stealing' it, I'm all up for any easy way to buy this if it was on Installer, etc. Once I see this is working, I'll likely toss a donation to Nullriver. But I do hope to see this app for sale 'somewhere' soon.
     

Share This Page