GPS bug after Jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by usman.rz, Aug 2, 2010.

  1. usman.rz macrumors member

    Joined:
    May 15, 2010
    #1
    I'm not sure if this is an isolated issue or something more widespread, but I'm experiencing trouble with the location services. The location services icon blinks every few seconds when I'm in the Maps.app and it can't seem to get a GPS lock on my phone. This happens in other apps that require GPS (RBC finder, ZipCar, etc).

    Is anyone else having similar issues post jailbreak?
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Not on mine, working as good as always.

    try resettings network settings
     
  3. N23 macrumors regular

    Joined:
    Aug 3, 2009
    #3
    No issues here as well. Tried google maps and mapquest.
     
  4. mmike70 macrumors newbie

    Joined:
    Nov 8, 2008
    #4
    Just noticed this on my iP4 I just jailbroke. I was in a building where I don't get any GPS signal but before always got a very close location (within 400') either through cell tower triangulation or wifi location. After the jailbreak, in the building it said I was about 70 miles away from where I really was with the blue circle pulsing with a radius that changed from a 1/4 mile to 50 or so miles. I guess I'll try a restore back to apple specs and see what happens.
     
  5. HiFiGuy528 macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #5
    Same problem here.

    I have two iPhone 4. One JB other not. Non-JB iphone 4 locked GPS within seconds. JB unit will not lock. I tried Google Maps app & Navigon.
     
  6. mytakeontech macrumors 6502a

    Joined:
    Jun 14, 2010
    #6
    Try disabling and then enabling the location service in iphone settings.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    That did the trick.?
    I haven't used the gps since I jb my i4.
    Hope it doesn't cause any probs.
     
  8. mmike70 macrumors newbie

    Joined:
    Nov 8, 2008
    #8
    Just a quick addition...
    The satellite GPS part of mine still works great. Within 5 seconds of stepping outside I got a perfect location lock. I tried to go back inside again and bam, I was 70 miles away, in exactly the same place as before. I did a reboot, a double hard reboot, turned location services off and on. MotionX GPS showed it as a triangulation lock and it was still way off.
     

Share This Page