GPS does not work when I am using running apps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by princessromanov, Sep 29, 2012.

  1. princessromanov macrumors newbie

    Joined:
    Sep 29, 2012
    #1
    I will be so happy if someone could tell me what to do about my iPhone 4. When I try to use running trackers such as Runkeeper or Map my run the GPS is completly out. Runkeeper tells me I have gone 8 miles when I know the path I take is 3 miles. Same with all the other tracking apps I have tried. My maps and find my iPhone app still works okay. I have tried reloading the apps but still the same results
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Checked location services?
     
  3. princessromanov thread starter macrumors newbie

    Joined:
    Sep 29, 2012
    #3
    Yes. It is on but the arrow isn't always showing in purple just grey
     
  4. thepriesthood macrumors newbie

    Joined:
    Jan 29, 2013
    #4
    I've been having the exact same problem, but in a different country (South Korea) and with an older iphone (3G). I have tried everything from reinstalling the app to restoring the phone. My GPS works with maps, but no longer with Runkeeper. The GPS arrow is grey instead of purple.

    @princessromanov did you ever solve the problem? if so, how? Thanks.
     

Share This Page