GPS not working sometimes, or taking forever to pick up on 2.1?

Discussion in 'iPhone' started by OverSpun, Sep 20, 2008.

  1. OverSpun macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #1
    I just got back from an 800 mile round trip drive, and on the way back, I could not get GPS to locate me a single time on the phone. It would give me the crosshair thing that was normal on the 2.5G phone, but never did I get the blue pulsating dot on the way back, or get any of the GPS enabled apps to work. Now that I'm home... GPS works? What gives? I dont need it to work at home, but on a trip when it could be most useful, it doesnt work at all? anyone else have issues? It seemed to work perfect before 2.1, so I dont get it.
     
  2. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #2
    i know, gps is very inconsistent for me

    ill get the crosshairs all the time but only sometimes the pin point, doesnt matter if i wait forever either, sometimes it just wont pin point
     
  3. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #3
    Yea, pretty much exactly what I'm experiencing. pretty crappy.
     
  4. rxmxsh macrumors member

    Joined:
    Sep 15, 2007
    Location:
    Irvine, Ca
    #4
    I found that in 2.0.2 I had that problem more than I get it now. It seems like it's pretty good for me overall.
     
  5. iPhone envy macrumors member

    Joined:
    Mar 14, 2008
    Location:
    Berkeley, CA
    #5
    No dot only crosshairs

    iPhone Atlas posted on this issue, I guess its widespread. But thier workarounds aren't getting me a dot. Its not a huge problem as I rarely use the turn-by-turnless GPS, but it SHOULD work. Anyone found a workaround other than just resetting your settings?
     
  6. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #6
    What do you mean by resetting your settings? I couldnt get it to start working for anything the other day. I did a few 2 fingered resets and such, no dice.
     
  7. Cyroceon macrumors 6502a

    Cyroceon

    Joined:
    Feb 9, 2008
    #7
    I have had the exact opposite issues. My GPS was quirky in the first few updates then with 2.1 got amazingly better. I actually enjoy using it now.
     
  8. acvball92 macrumors regular

    acvball92

    Joined:
    Jun 8, 2008
    Location:
    Fairfield County, CT
    #8
    i can never get a signal, I want to be able to use the GPS, but I just don't even bother anymore.:(
     
  9. iPhone envy macrumors member

    Joined:
    Mar 14, 2008
    Location:
    Berkeley, CA
    #9
    iPhone Atlas fix

    http://www.iphoneatlas.com/2008/09/17/gps-not-working-under-iphone-os-21-fix/

    This didnt work for me, but works for some.

    "GPS Not Working Under iPhone OS 2.1, Fix
    Posted 17 September 2008 @ 9am in Troubleshooting

    Several users have reported an issue in which GPS functionality and location services in general do not work properly after the update to iPhone OS 2.1. In most cases of the problem, location service crosshairs appear, but the tracking blue dot (indicative of GPS) never appears.

    As described by Apple Discussions poster hitchsaid:

    “Both my brother and I have iphones and we both updated to 2.1 and the GPS on both our phones were working fine prior to 2.1 Now all we get are the crosshairs- the blue dot is nowhere to be seen. I have tried all the recommendations sitting outside for 20min, 3G off, airplane mode on/off, soft reset, location services on….wi-fi on, bluetooth off…. but nothing seems to make it work again….what is really bugging me is that it was working fine before the update.”

    The fix for this issue, for many users, is to navigate to Settings > General > Reset and choose Reset All Settings. "
     
  10. Cyclone Chris macrumors regular

    Joined:
    Jul 14, 2008
    #10
    What settings will be lost when you "Reset all Settings" ? Saved Games? Contacts? Calendar? Apps?

    Thanks
     
  11. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #11
    I'll tell you in a second... just did it.

    edit:

    k, it basically just resets... the settings, as it said. Your springboards go back to out of the box positions and apps just get placed wherever.... ringtones go to default, wifi is all forgotten, BT off... etc. You lose nothing important, as it says. Its not a big deal. GPS also SEEMS to be working better. We'll see though.
     
  12. iphonecode macrumors member

    Joined:
    Sep 22, 2008
  13. moonknife macrumors newbie

    Joined:
    Sep 26, 2008
    Location:
    SoCal
    #13
    Yeah, it's a bit flakey. I was driving down 405S around Santa Monica and my iPhone flat out told me "It could not find my current location". Never got this msg on older firmwares.
     
  14. ryanwarsaw macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #14
    I am also experiencing the same issue as others.
     
  15. DanielJvdBerg macrumors regular

    Joined:
    Jun 1, 2008
    Location:
    The Netherlands.
    #15
    I have never experienced this on a 3G 16GB, first batch from the Netherlands, Europe. It has always worked properly, and it works even better after updating to 2.1. Maybe I should note that with every update, meaning from 2.0 to 2.0.1, 2.0.1 and with 2.1 I did a fresh install of the iPhone. It just makes me feel better:Dand perhaps it does work.
    But better try the reset all settings first.
    And if a clean install doesn't work, drop by your retailer to get a working one!
     
  16. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #16
    make sure you are outside so that the satellite can pick up your signal, sometimes bad weather can affect gps performance too
     
  17. ryanwarsaw macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #17
    When i was inside and outside I could get location services before. This is a 2.1 problem maybe it depends on what cell network you have. I really don't know but the problem is present.
     
  18. mkitchen macrumors member

    Joined:
    Jul 7, 2008
    #18
    Glad to know i'm not the only one experiencing this problem. GPS was one of my number 1 uses for the phone, and it always worked great - it lagged a little behind but it always blue dotted and stayed with me and showed me where i was going. I guess i will try the reset all settings, but i'm not confident. This is really frustrating - maybe i need to downgrade until 2.2 comes out...
     
  19. Hardcoredan52 macrumors regular

    Joined:
    Mar 2, 2008
    #19
    I don't know about any one else, but I've been getting great GPS service. Locates me within seconds here in florida... If i'm in my car I might see the Blue circle for a second then it turns into the blue dot. If I'm in a building it all depends but it never use to pick me up in my apartment and now it does very quickly. Its getting alot better for me here in Central Florida
     

Share This Page