GPS only on Wifi?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Greggio, Aug 5, 2008.

  1. Greggio macrumors newbie

    Joined:
    Jul 28, 2008
    #1
    When I push the location button in Google Maps on the iphone when I'm at home and connected to the home Wifi, it zooms in on the location in no time at all.

    If I turn off Wifi, it can't do it at all. And not just at home - it won't work at all outside and I've tried several locations. It just keeps searching indefinitely.

    Updated to 2.01 to see if that'd fix it - it hasn't, but isn't the cause, because it wasn't working before that. Have both powered down and reset the iphone - no effect. Have tried it with 3G turned off - no better. And yes, Location Services are turned on in the settings menu.

    As far as I can tell, the only time this thing can tell me where I am is when I'm on the couch at home - not as useful as I'd hoped. My wife's phone seems to be the same. Any suggestions?

    I had one thought this morning - we bought our laptop in New Zealand, but live in London. Although I've changed all the settings I can find on the laptop (PC), the iphones thought we were in NZ when we first initiated them by connecting to Itunes. Could this be throwing things out (e.g., the phone starts looking in NZ and can't find us - or doesn't do it because it's not an available service in NZ)?
     
  2. macduke macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #2
    I heard about this happening to someone, ironically, from New Zealand. The iPhone uses assisted GPS. Basically, it will look for your location based on wifi first and that way it can lock onto the GPS satellites overhead faster. If you're on the other side of the world and it thinks you're not, it might be looking for satellites over that side of the world since I believe GPS satellites are geo-stationary. Weird situation though that it doesn't work at other locations. If it is finding you in your house, then that is only the wifi locator in action. GPS usually doesn't go through buildings. Also if it is a small circle and not a pinpoint blue dot then its not using GPS. So obviously it must know your current wifi location to use a-gps. Try doing a restore first and if that doesn't work then your GPS chip is dead and you need to return it. Good luck.
     

Share This Page