GPT edit tutorage needed

Discussion in 'iMac' started by seapup66, Oct 9, 2010.

  1. seapup66 macrumors newbie

    Joined:
    Oct 8, 2010
    #1
    Hello
    first post guys, be easy.

    Tried to install winblows 7 on my new 27" imac. Sorted through the known issues-Black screen of Death,never ending cursor, missing BootMgr, Ati drivers... got win 7 working and noticed that the os x side cannot mount the windows (BOOTCAMP) partition?

    seems the mac GPT thinks the win partition is fat 32 and it is actually a NTFS partition.

    any way to edit the GPT to agree with the MBR???????

    Thanx for the help
     
  2. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #2
    so what is the actual problem you are having?

    did you initially install win7 using Bootcamp Assistant?
     
  3. seapup66 thread starter macrumors newbie

    Joined:
    Oct 8, 2010
    #3
    Sorry it took so long to reply

    I am trying to edit the gpt table to match the MBR on the windows side

    Yes mI installed windows 7 via bootcamp.
    I had to format bootcamp partition to NTFS as win7 will not install on a FAT 32 partition. I think this is why the GPT and MBR do not match up...

    Any Ideas ANYONE????
     
  4. seapup66 thread starter macrumors newbie

    Joined:
    Oct 8, 2010
    #4
    more info

    here is the info from the GPT and MBR

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 1531330599 Mac OS X HFS+
    3 1531594752 1953523711 Basic Data

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 409639 ee EFI Protective
    2 409640 1531330599 af Mac OS X HFS+
    3 * 1531332608 1531537407 07 NTFS/HPFS
    4 1531537408 1953521663 07 NTFS/HPFS
    --------------------------------------------------
     
  5. Interna macrumors newbie

    Joined:
    Oct 26, 2010
    #5
    Having the same problems.

    1. Bootcamp partition (Windows 7) not showing up on desktop in OSX.
    2. Bootcamp partition (Windows 7) is unmountable through disk utility.
    3. Verify/Repair disk/permissions does not solve the problem of it being unmountable in OSX.
    4. chkdsk does not solve this problem of it being unmountable in OSX.
    5. Bootcamp works fine when selecting the OS while holding Option Key like normal.


    Like seapup66 mentioned earlier the OSx GPT thinks the Bootcamp (Windows 7) partition is FAT32 when it's actually a NTFS partition.

    Anyone know how to configure the GPT/MBR to coincide with each other?

    Here is the exact same problem that also got solved however I am lost as to how to go about doing this.

    http://forums.macrumors.com/showthread.php?t=979951
     

Share This Page