GPU clock throttling and fluctuating

Discussion in 'MacBook Pro' started by shinai299, Jun 5, 2015.

  1. shinai299 macrumors newbie

    Joined:
    Jun 5, 2015
    #1
    Hello guys, I have a problem I can't fix my self, been trying for about 3 days all day now.

    graph:
    [​IMG]

    My GPU clock is acting very strange. I can't really say when this problem started, but it was working perfectly fine at a time before.

    My specs:
    Macbook Pro Late 2013 15" with geforce gt 750m
    Playing on bootcamp (windows 7 home premium) with latest graphics driver.
    bought it Dec 2013

    I already tried:

    - Changing energy plan (changing processor state, high performance, etc.)
    - Changing settings in Nvidia system control (changing energy setting for gpu to highest performance and some other settings)
    - Forcing p-states (and forcing specific clock values) with Nvidia Inspector ---> helped at first, but after some time ingame it starts fluctuating again between 270 and 660 mhz
    - Over- and Underclocking in conjunction with forcing p-states
    - Force constant voltage with MSI afterburner
    - Using ThrottleStop to control CPU usage
    - clean uninstall of graphics driver and fresh install
    - completely reinstall windows (also tried with windows 8)
    - using older driver version (the version that bootcamp provides)
    - Doing SMC and PRAM reset

    Some of those of course weren't supposed to help in the first place but i was kind of desperate, so I tried anyways... also i'm not the extreme technician, I found all of those solutions via. google and really searched to death, but nothing helped.
    I really don't think it's a temperature problem, since it stays at about 70°C, max 80°C with forcing p-states (so that it works for some minutes / seconds).

    Also my Memory Clock stays perfect fine all the time, it's only the GPU-Clock, that is acting strange. Oh and I found out that somehow it goes down to performance level 1 when it starts fluctuating and switches between 0 and 1 (270mhz and 660mhz).
    I tried changing the clocks of those states, but that didn't help as well, which is very confusing.

    I did that test with Final Fantasy 14 ARR, but had same problems in guild wars 2, for example.

    I did the apple diagnostic test and it didn't detect any faults in my hardware, then i checked on Mac OS, if i got the same issues there, but everything is fine there, no fluctuation etc.,
    so this definitely is no hardware issue...

    Did another test after SMC and PRAM reset... first everything seems alright, but gpu temp rises to 90+ (with no CPU controlling) then it starts to throttle... but after some time it cools down again and then still fluctuates...

    [​IMG]

    After playing around some more with p-states I found out something interesting:

    [​IMG]

    I forced it again via command line and it stays fine for some time ingame, but then it starts fluctuating again. Whenever I alt tab out of the game though, it goes back to max. After I alt tab back into the game it slows down again (sometimes right away, sometimes after some minutes).
    I tried playing in windowed mode, but same problem... when I click on the Desktop to focus it, gpu clock goes up, but when I focus the game again it slows down.
    Temperature never rose above 80°, because I used ThrottleStop at the same time.

    Also did a complete log (using ThrottleStop as well here):

    [​IMG]

    The Framerate graph is invalid though.. it's much lower ingame.
    If you need more Info just ask, i hope someone can help :).
     
  2. Dead0k macrumors regular

    Joined:
    Apr 23, 2015
    Location:
    Poland
    #2
    hot season weather wise right now in many countries. When did you clean (from dust) your laptop last time?
     
  3. shinai299 thread starter macrumors newbie

    Joined:
    Jun 5, 2015
    #3
    Didn't do that yet, but it doesn't seem to be a temperature problem to me.
    Will try that later though :)
     
  4. jchen95295 macrumors newbie

    jchen95295

    Joined:
    Dec 8, 2015
    #4
    Hey, I'm having the same issues with my Macbook Pro 15 inch from 2015. I throttle on GW2 at 72 degrees celcius. I'm curious if you have resolved your issue by now and how?
     
  5. ha1o2surfer macrumors 6502

    Joined:
    Sep 24, 2013
    #5
    Power related throtting, set your CPU to 15% in the windows power manager and the throttling will go away. A 7xxM series card throttles, by default, at 96C temp wise. Apple may have set this lower but I doubt it. Setting CPU clocks lower allows more power to be drawn by the GPU.

    Apple gives power priority to CPU in the UEFI, hence why you are seeing this fluctuation
     
  6. jchen95295 macrumors newbie

    jchen95295

    Joined:
    Dec 8, 2015
    #6
    I set it to 70% because i think 15% may be a little too low, it helps a little bit, i see less throttling but it definitely still does so around 72 degrees celcius for my gpu. I know that both my cpu and gpu throttle at the same exact time though so what you said does make sense.
     
  7. ha1o2surfer macrumors 6502

    Joined:
    Sep 24, 2013
    #7
    I said 15 percent so you can start from there and go up if the game lags too bad from lack of CPU. Every game will be different and some games don't care if the CPU is at 800mhz but others (such as BF4) require the CPU to be running at a reasonable speed. I hope it helps you out at least a little bit :)
     

Share This Page