GPU Failing? (Screenshot Included)

Discussion in 'MacBook Pro' started by matty1551, Oct 11, 2014.

  1. matty1551 macrumors 6502

    Joined:
    Jul 7, 2009
    #1
    I've started noticing certain graphical glitches. These have happened exclusively in google chrome so far. Here's a screenshot. My applecare expires on monday so I may go in and push for a logic board replacement if this is the beginning of the end for my macbook.
     

    Attached Files:

  2. poiihy, Oct 11, 2014
    Last edited: Oct 11, 2014

    poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #2
    That's Radeongate. Get a logic board replacement.

    Google Chrome always uses the dGPU and the dGPUs in 2011 MBPs are faulty/defective, and yours is breaking. It will get worse and worse until you can't see anything. I suggest you use gfxcardstatus to force OS X to use only the iGPU (Theres a bug so you have to select Integrated twice for it to work), until you get it replaced. But the replacement boards are the same and are also defective faulty, they have not been updated or fixed, so you'd be in this endless loop of replacing, unless apple gives you a brand new macbook pro for free.
     
  3. Fimeg macrumors regular

    Joined:
    Jun 12, 2013
    #3
    There wasn't a 2011 rMBP. 2012 is the first rMBP and it uses Nvidia.

    Now though, I agree that this is Radeongate. Get it checked out.
     
  4. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    Oh then 2011 not-r MPB.
     

Share This Page