GPU fans constantly full speed - Mac Pro 2010 with Vega 56

MitchMunro

macrumors newbie
Original poster
Aug 29, 2016
13
1
Australia, Sydney
Hey mates,

I recently upgraded my Mac Pro 2010's GPU to an MSI Vega 56 Air Boost OC card to support Mojave and future OS upgrades. It runs well, but the fans seem to be stuck on near 100% (or so). I am a recording/music producer, so I can't afford to have a loud machine like this. I bootcamp windows, and on windows, when the computer is idling, the GPU fan is very quiet.

Apparently this is a known problem. There are also solutions out there, but after hours of trying to understand what the guys were saying, I'm stumped.


Here are pages with solutions that apparently work, but I can't understand:

https://www.insanelymac.com/forum/topic/325120-vega-frontier-edition-on-high-sierra/?page=6

- Also some useful stuff at the bottom of page 5.
- Someone on this forum here, halfway down the page (https://www.tonymacx86.com/threads/amd-vega-56-64-wx9100-fan-noise-semi-workaround.247213/) posts the above link, saying it is a better solution than the OP had. There guys all seem to be Hackintosh guys, so I'm not sure if that makes a difference!



Any help you guys can give me to interpret what these guys are saying, or to find another way to make the Vega 56 fans operate like normal, would be much appreciated!

Thanks for your time.
 

MitchMunro

macrumors newbie
Original poster
Aug 29, 2016
13
1
Australia, Sydney

crjackson2134

macrumors 601
Mar 6, 2013
4,585
1,690
Charlotte, NC
That seems to be saying that the only option is to flash the BIOS to another cards BIOS, and then goes on to say that it is risky to flash the BIOS of an MSI Air Boost. Is that the only option? It doesn't seem like a good one. That link doesn't address anything like what the other links I posted were talking about.
Not a criticism, just wondering....

Why didn’t you just buy a Supported/Officially endorsed GPU? Was that one cheaper than an RX580?
 

MitchMunro

macrumors newbie
Original poster
Aug 29, 2016
13
1
Australia, Sydney
I think crjackson meant that the ones that apple endorses - even vega 56

"These graphics cards are based on the AMD Vega 56 architecture. Recommended graphics cards include the Sapphire Vega 56 and XFX Vega 56."

https://support.apple.com/en-us/HT208544

I have a sapphire vega 64 with cMP09 and no fan issue.
I wasn't aware that so many Vega's had problems until I got this one sadly.

Oh great! That is good to know one works for you. do you use Pixla's Mod? I'm tempted to do what you have done, if so. Is it a blower cooler like this one? https://www.gumtree.com.au/s-view-details.html?adId=1208932158
I asked the guy selling this card and apparently he said it is Sapphire brand.
 

eml-cmp

macrumors newbie
Feb 23, 2019
8
3
I wasn't aware that so many Vega's had problems until I got this one sadly.

Oh great! That is good to know one works for you. do you use Pixla's Mod? I'm tempted to do what you have done, if so. Is it a blower cooler like this one? https://www.gumtree.com.au/s-view-details.html?adId=1208932158
I asked the guy selling this card and apparently he said it is Sapphire brand.


I sidegraded / downgraded from an always-crashing GTX 1080 to a XFX Vega 56 yesterday. No problems with fan speed at all. Also, I'm throwing all of the same After Effects files at it, and instead of rebooting all the time, it's rock solid.

I power my card with an external PSU. I can't do that Pixla Mod, I have all of the PCI slots full, and like 8 drives in there. Plus, from what I gather, it's safer to just use an external PSU and not risk drawing too much power from the internal one.
 

IndioX

macrumors regular
Oct 1, 2018
200
72
austria/europe
I power my card with an external PSU. I can't do that Pixla Mod, I have all of the PCI slots full, and like 8 drives in there. Plus, from what I gather, it's safer to just use an external PSU and not risk drawing too much power from the internal one.
see my signature for specs at the first cMP - the pixlas mod works well for me