GPU hang state

Discussion in 'Mac Pro' started by golf1410, May 9, 2014.

  1. golf1410, May 9, 2014
    Last edited: May 10, 2014

    golf1410 macrumors 6502a

    golf1410

    Joined:
    May 7, 2012
    Location:
    San Francisco, CA
    #1
    Hi there,
    It happened so quick. I was playing starcraft 2 on my nMP. My screen was frozen. However, I could move my cursor around. I had to do hard reset the machine. I could not force quit or anything. After a reboot, I took a look at logs. I found this.

    GPU Hang State = 0x00000000
    kernel[0]: ** GPU ASIC Log Start **
    kernel[0]: 0x00006740
    kernel[0]: 0x00000091
    kernel[0]: 0x00000001
    kernel[0]: 0x00000018
    kernel[0]: 0x0000b080
    .
    .
    .
    (Bunch of hex numbers)

    OSX 10.9.2
    New Mac Pro 2013

    Has anyone experience this? Was it a OS software or hardware problem?



    ********************* Update Full log version *************************


    5/8/14 9:46:36.000 PM kernel[0] [6:0:0] GPU Hang State = 0x00000000
    5/8/14 9:46:36.000 PM kernel[0] ** GPU ASIC Log Start **
    5/8/14 9:46:36.000 PM kernel[0] 0x00006798
    5/8/14 9:46:36.000 PM kernel[0] 0x000000e3
    5/8/14 9:46:36.000 PM kernel[0] 0x00000001
    5/8/14 9:46:36.000 PM kernel[0] 0x00000018
    5/8/14 9:46:36.000 PM kernel[0] 0x0000a060
    5/8/14 9:46:36.000 PM kernel[0] 0x00000001
    .......... Many of these numbers.......
    5/8/14 9:46:42.000 PM kernel[0] 0x00000000
    5/8/14 9:46:42.000 PM kernel[0] 0x00000000
    5/8/14 9:46:42.000 PM kernel[0] ** GPU ASIC Log End **
    5/8/14 9:46:42.000 PM kernel[0] 0
    5/8/14 9:46:42.000 PM kernel[0] [0x2d7
    5/8/14 9:46:42.000 PM kernel[0] Trying restart GPU ...
    5/8/14 9:46:43.693 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 9 seconds
    5/8/14 9:46:52.701 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:02.709 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:12.716 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:22.724 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:32.731 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:42.739 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:47:52.746 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:48:02.754 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:48:12.762 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:48:22.770 PM com.apple.launchd[1] (com.apple.DumpGPURestart) Throttling respawn: Will start in 10 seconds
    5/8/14 9:49:01.000 PM bootlog[0] BOOT_TIME 1399610941 When I did hard reset
     
  2. crjackson2134, May 9, 2014
    Last edited: May 9, 2014

    crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #2
    A google search finds this information. And this too...

    I would keep a close eye on things and make sure you are backing up regularly. From the looks of it, it's possible you have some defective hardware (GPU(s)) that may need to be replaced.

    I feel like you really need to call Apple.
     
  3. NOTNlCE macrumors 6502a

    NOTNlCE

    Joined:
    Oct 11, 2013
    Location:
    DMV Area
    #3
    Had a very very similar issue with my GTX 660 last week. Needed to be replaced. I would run a GPU test such as THESE and see if you get a crash. That sounds exactly like the issues I was experiencing. If it crashes, rush that baby to an Apple store.
     
  4. golf1410 thread starter macrumors 6502a

    golf1410

    Joined:
    May 7, 2012
    Location:
    San Francisco, CA
    #4
    I could not re produce the same issue with these tests. Some of them, I ran tests for some period of time.
    [​IMG]

    When you had this problem, did it happen often?
     
  5. NOTNlCE macrumors 6502a

    NOTNlCE

    Joined:
    Oct 11, 2013
    Location:
    DMV Area
    #5
    My issue was frequent crashes. Needless to say, the card was bad and has since been replaced. I could boot up the system and use it for max 30 minutes before the hang, even in non-intensive situations. I wouldn't worry too much if stress tests didn't crash anything, unless you're still experiencing the hang state. It very well could just be a driver thing.
     
  6. golf1410 thread starter macrumors 6502a

    golf1410

    Joined:
    May 7, 2012
    Location:
    San Francisco, CA
    #6
    Thank you for your reply. I was thinking it might be Maverick bug that causes this.
     
  7. hydr macrumors regular

    Joined:
    Feb 25, 2009
    #7
    I had this too. 6core/D700 - Apple replaced it with a new unit.
     
  8. golf1410 thread starter macrumors 6502a

    golf1410

    Joined:
    May 7, 2012
    Location:
    San Francisco, CA
    #8
    Did it happen to you often? Were you be able to reproduce the issue?
     
  9. chama98 macrumors regular

    Joined:
    Feb 13, 2014
    Location:
    London
    #9
    I spoke to Apple myself the other day and he was saying that it could be an issue with iMessage left open or minimised to the dock. This is a bug apparently and is being investigated by Apple. This is for Yosemite I must add.

    My mac pro is also experiencing GPU restarts but all my hardware is working well. i.e there are no reported hardware faults according to the Apple hardware test.

    So far I have reinstalled the OS. and reduced the amount of apps I don't use to see if there are any compatibility problems. I also removed my windows virtual machine and installed boot camp with windows 10 on it. I was playing a game in windows 10 in boot camp and the mac was getting quite warm, so I am wondering if it freaked out as it was too warm or using too much power? I don't know.
     
  10. chama98 macrumors regular

    Joined:
    Feb 13, 2014
    Location:
    London

Share This Page