GPU Kernel Panic in mid-2010; what's the best fix?

Discussion in 'MacBook Pro' started by groverb, Jun 6, 2015.

  1. fabioroberto, Sep 3, 2016
    Last edited: Sep 3, 2016

    fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #26

    Interesting fact.
    Thank you for help
     
  2. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #27


    Hi, I'm very interested in your solution because I also have problems with kernel panics and I've been using the gfxCardStatus app as a fix.

    My Macbook Pro model is the MacBook Pro 6,2 with the GT330M but in my system information, my device ID is listed as 0x0a29 instead of the 0x029 that you have listed. Does this make a difference?

    Also, is it ok to reenable SIP after I finish everything?
     
  3. fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #28


    0x0a29 ok!

    SIP disabled, if is enabled will not work.

    good luck
     
  4. AlainD. macrumors newbie

    AlainD.

    Joined:
    May 25, 2016
  5. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #30
    Sorry, just to make sure, even after I've finished everything, I can't turn back on SIP? I have to leave it disabled forever for the fix to work?
     
  6. alexishirst macrumors newbie

    Joined:
    Aug 15, 2010
    #31
    THANK YOU!!!!! This fixes the issue for me!!

    I also noticed the pattern that my machine would crash only in very certain circumstances.

    I found that many Open GL tests would not cause it to fail, but Cinebench would.

    This evening I've been able to reproduce the failure a number of times by using Cinebench.

    By making this change I was able to run Cinebench to completion with no kernel panics!

    I was very close to buying a new computer, but this should mean my machine has a few more years left!
     
  7. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #32

    I think you meant to reply to fabioroberto, he's the one you should be thanking!

    Since you already did the fix, did you leave SIP off after you went through all of the steps?
     
  8. fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #33

    .kext was changed, so, SIP should be turned off. SIP does not allow kext unsigned.

    SIP is important to safety, but, we are good guys, we'll know to keep the system safe!
    --- Post Merged, Sep 4, 2016 ---

    I am so happy for you!!
     
  9. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #34
    Cool, thank you, I'll hopefully try to do this in the near future. Thanks so much for doing this and sharing it!
     
  10. dontworry Suspended

    dontworry

    Joined:
    Mar 18, 2010
    #35
    I am going to try this fix soon too. Thank you for all of your effort, it is much appreciated.

    I will have to study up a little, as even your step by step is above my head right now.
     
  11. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #36

    If you need any help in understanding the steps, I can also probably help, I think I have a pretty good grasp on how to do all of the steps, I just need to actually get around to doing it.
     
  12. dontworry Suspended

    dontworry

    Joined:
    Mar 18, 2010
    #37
    thanks. i'm confused by the first part actually. lol. reading through the rest, i feel like i can follow the rest.

    1 - Verify that the file is the original and this loaded:

    • ACPI_SMC_PlatformPlugin.kext (IOPlatformPluginFamily.kext)
    • AppleGraphicsPowerManagement.kext
     
  13. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #38
    I was also unsure of that but I think it just means to check that those files are located in /System/Library/Extensions. You can get to that location my opening finder and pressing the keyboard shortcut shift+command+g or in the menu bar go to 'Go' and scroll down and click 'Go to folder...' and paste in the location /System/Library/Extensions

    If things go successfully, please do share your results!
     
  14. fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #39

    Yes. If .kext are present (there are mods that remove these files) and if they are the original (Apple signed).

    You can check this on: About System Information -> Extensions
    --- Post Merged, Sep 4, 2016 ---
     
  15. Fhiiz, Sep 6, 2016
    Last edited: Sep 6, 2016

    Fhiiz macrumors newbie

    Joined:
    Sep 6, 2016
    #40

    Hi and thanks for your help, i wanna try to fix this with your modified files, but well, i haven't the line with Macbookpro6,2 in my info.plist
    Do you add it after the macbookpro6,1 line ?
    I think i knew do everything else, but i don't know where i should change the value in the info.plist

    Well i found it sorry.. That the space between , and 2 which make me search for a while

    Edit : Not working there, ever GPU Panic

    Edit2 :
    Anonymous UUID: C4344705-C21F-D234-47B3-3DDE5929CF67

    Tue Sep 6 20:41:56 2016

    *** Panic Report ***
    panic(cpu 0 caller 0xffffff7f99124bd5): "GPU Panic: [<None>] 5 3 7f 0 0 0 0 3 : NVRM[0/1:0:0]: Read Error 0x0061002c: CFG 0x0a2910de 0x00100000 0x00000000, BAR0 0xd2000000 0xffffff90c1617000 0x0a5480a2, D0, P3/4\n"@/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.12.8/src/AppleMuxControl/kext/GPUPanic.cpp:127
    Backtrace (CPU 0), Frame : Return Address
    0xffffff80a9973ae0 : 0xffffff8016adab52
    0xffffff80a9973b60 : 0xffffff7f99124bd5
    0xffffff80a9973c40 : 0xffffff7f992663f8
    0xffffff80a9973d00 : 0xffffff7f99332076
    0xffffff80a9973d40 : 0xffffff7f994fb35e
    0xffffff80a9973d60 : 0xffffff7f99304714
    0xffffff80a9973d80 : 0xffffff7f993a7ecf
    0xffffff80a9973e00 : 0xffffff7f9924e4b9
    0xffffff80a9973ec0 : 0xffffff7f9921ae16
    0xffffff80a9973f00 : 0xffffff8016b0f2da
    0xffffff80a9973fb0 : 0xffffff8016bc9117
    Kernel Extensions in backtrace:
    com.apple.driver.AppleMuxControl(3.12.8)[3186B630-FFF4-32C9-BAB9-DCD0C9DB6BA2]@0xffffff7f99116000->0xffffff7f99129fff
    dependency: com.apple.driver.AppleGraphicsControl(3.12.8)[C57F5F56-2229-365F-9765-F24AA4687584]@0xffffff7f9910e000
    dependency: com.apple.iokit.IOACPIFamily(1.4)[5D7574C3-8E90-3873-BAEB-D979FC215A7D]@0xffffff7f975b3000
    dependency: com.apple.iokit.IOPCIFamily(2.9)[5447B943-A94D-3BD4-A60F-98B24D19CE93]@0xffffff7f9732c000
    dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[A360453D-2050-3C49-A549-AC0DD5E87917]@0xffffff7f976db000
    dependency: com.apple.driver.AppleBacklightExpert(1.1.0)[C49819CE-729A-36B2-9AC1-744A43DC236F]@0xffffff7f99111000
    com.nvidia.web.NVDAResmanTeslaWeb(10.1.1)[3778090E-F2D4-3E85-8070-3A69B765A929]@0xffffff7f99215000->0xffffff7f9947dfff
    dependency: com.apple.iokit.IOPCIFamily(2.9)[5447B943-A94D-3BD4-A60F-98B24D19CE93]@0xffffff7f9732c000
    dependency: com.apple.iokit.IONDRVSupport(2.4.1)[4EB2843C-C821-3AD0-B333-575FD6ED6FB1]@0xffffff7f97722000
    dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[A360453D-2050-3C49-A549-AC0DD5E87917]@0xffffff7f976db000
    com.nvidia.web.NVDANV50HalTeslaWeb(10.1.1)[16E2FDB9-C9CA-3223-82B3-96D730D29073]@0xffffff7f9947e000->0xffffff7f99726fff
    dependency: com.nvidia.web.NVDAResmanTeslaWeb(10.1.1)[3778090E-F2D4-3E85-8070-3A69B765A929]@0xffffff7f99215000
    dependency: com.apple.iokit.IOPCIFamily(2.9)[5447B943-A94D-3BD4-A60F-98B24D19CE93]@0xffffff7f9732c000

    BSD process name corresponding to current thread: kernel_task
    Boot args: nvda_drv=1

    Mac OS version:
    15G1004

    Kernel version:
    Darwin Kernel Version 15.6.0: Mon Aug 29 20:21:34 PDT 2016; root:xnu-3248.60.11~1/RELEASE_X86_64
    Kernel UUID: E349749B-3303-3DDF-959C-B5885A0E1F6E
    Kernel slide: 0x0000000016800000
    Kernel text base: 0xffffff8016a00000
    __HIB text base: 0xffffff8016900000
    System model name: MacBookPro6,2 (Mac-F22586C8)

    System uptime in nanoseconds: 2550713233204
    last loaded kext at 1038939219610: com.apple.filesystems.smbfs 3.0.1 (addr 0xffffff7f997ee000, size 409600)
    last unloaded kext at 307273868725: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7f997ee000, size 61440)
    loaded kexts:
    com.nvidia.web.GeForceTeslaWeb 10.1.1
    com.nvidia.web.NVDANV50HalTeslaWeb 10.1.1
    com.nvidia.web.NVDAResmanTeslaWeb 10.1.1
    com.apple.filesystems.smbfs 3.0.1
    com.apple.driver.AudioAUUC 1.70
    com.apple.driver.AppleHWSensor 1.9.5d0
    com.apple.filesystems.autofs 3.0
    com.apple.driver.AppleOSXWatchdog 1
    com.apple.driver.AppleMikeyHIDDriver 124
    com.apple.driver.AppleUpstreamUserClient 3.6.1
    com.apple.driver.AppleMikeyDriver 274.12
    com.apple.driver.AppleHDA 274.12
    com.apple.driver.pmtelemetry 1
    com.apple.iokit.IOUserEthernet 1.0.1
    com.apple.driver.AppleIntelHDGraphics 10.0.0
    com.apple.iokit.IOBluetoothSerialManager 4.4.6f1
    com.apple.driver.AppleSMCLMU 208
    com.apple.driver.AppleIntelHDGraphicsFB 10.0.0
    com.apple.driver.AppleMuxControl 3.12.8
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.AppleHV 1
    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
    com.apple.driver.SMCMotionSensor 3.0.4d1
    com.apple.driver.AppleMCCSControl 1.2.13
    com.apple.driver.AppleUSBTCButtons 245.4
    com.apple.driver.AppleUSBTCKeyboard 245.4
    com.apple.driver.AppleIRController 327.6
    com.apple.driver.AppleUSBCardReader 3.7.1
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
    com.apple.BootCache 38
    com.apple.iokit.SCSITaskUserClient 3.7.7
    com.apple.iokit.IOAHCIBlockStorage 2.8.5
    com.apple.driver.AppleFWOHCI 5.5.4
    com.apple.iokit.AppleBCM5701Ethernet 10.2.0
    com.apple.driver.usb.AppleUSBEHCIPCI 1.0.1
    com.apple.driver.AppleAHCIPort 3.1.8
    com.apple.driver.AppleSmartBatteryManager 161.0.0
    com.apple.driver.AppleHPET 1.8
    com.apple.driver.AppleACPIButtons 4.0
    com.apple.driver.AppleRTC 2.0
    com.apple.driver.AppleSMBIOS 2.1
    com.apple.driver.AppleACPIEC 4.0
    com.apple.driver.AppleAPIC 1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0
    com.apple.nke.applicationfirewall 163
    com.apple.security.quarantine 3
    com.apple.security.TMSafetyNet 8
    com.apple.driver.AppleIntelCPUPowerManagement 218.0.0
    com.apple.kext.triggers 1.0
    com.apple.driver.DspFuncLib 274.12
    com.apple.kext.OSvKernDSPLib 525
    com.apple.iokit.IOSurface 108.2.3
    com.apple.iokit.IOSerialFamily 11
    com.apple.iokit.IOBluetoothFamily 4.4.6f1
    com.apple.driver.usb.IOUSBHostHIDDevice 1.0.1
    com.apple.driver.AppleHDAController 274.12
    com.apple.iokit.IOHDAFamily 274.12
    com.apple.iokit.IOAudioFamily 204.4
    com.apple.vecLib.kext 1.2.0
    com.apple.driver.AppleSMBusPCI 1.0.14d1
    com.apple.iokit.IOFireWireIP 2.2.6
    com.apple.driver.AppleBacklightExpert 1.1.0
    com.apple.iokit.IONDRVSupport 2.4.1
    com.apple.driver.AppleGraphicsControl 3.12.8
    com.apple.driver.CoreCaptureResponder 1
    com.apple.driver.corecapture 1.0.4
    com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0
    com.apple.driver.AppleSMC 3.1.9
    com.apple.driver.AppleSMBusController 1.0.14d1
    com.apple.iokit.IOGraphicsFamily 2.4.1
    com.apple.driver.AppleUSBMultitouch 250.5
    com.apple.iokit.IOUSBHIDDriver 900.4.1
    com.apple.iokit.IOSCSIBlockCommandsDevice 3.7.7
    com.apple.iokit.IOUSBMassStorageDriver 1.0.0
    com.apple.driver.usb.cdc 5.0.0
    com.apple.driver.usb.networking 5.0.0
    com.apple.driver.usb.AppleUSBHostCompositeDevice 1.0.1
    com.apple.driver.usb.AppleUSBHub 1.0.1
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.7.7
    com.apple.iokit.IOBDStorageFamily 1.8
    com.apple.iokit.IODVDStorageFamily 1.8
    com.apple.iokit.IOCDStorageFamily 1.8
    com.apple.iokit.IOAHCISerialATAPI 2.6.2
    com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.7
    com.apple.iokit.IOFireWireFamily 4.6.1
    com.apple.iokit.IOEthernetAVBController 1.0.3b3
    com.apple.driver.mDNSOffloadUserClient 1.0.1b8
    com.apple.iokit.IONetworkingFamily 3.2
    com.apple.iokit.IOAHCIFamily 2.8.1
    com.apple.driver.usb.AppleUSBEHCI 1.0.1
    com.apple.iokit.IOUSBFamily 900.4.1
    com.apple.iokit.IOUSBHostFamily 1.0.1
    com.apple.driver.AppleUSBHostMergeProperties 1.0.1
    com.apple.driver.AppleEFINVRAM 2.0
    com.apple.driver.AppleEFIRuntime 2.0
    com.apple.iokit.IOHIDFamily 2.0.0
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.sandbox 300.0
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.driver.AppleKeyStore 2
    com.apple.driver.AppleMobileFileIntegrity 1.0.5
    com.apple.driver.AppleCredentialManager 1.0
    com.apple.driver.DiskImages 417.4
    com.apple.iokit.IOStorageFamily 2.1
    com.apple.iokit.IOReportFamily 31
    com.apple.driver.AppleFDEKeyStore 28.30
    com.apple.driver.AppleACPIPlatform 4.0
    com.apple.iokit.IOPCIFamily 2.9
    com.apple.iokit.IOACPIFamily 1.4
    com.apple.kec.Libm 1
    com.apple.kec.pthread 1
    com.apple.kec.corecrypto 1.0
    Model: MacBookPro6,2, BootROM MBP61.0057.B11, 2 processors, Intel Core i5, 2,53 GHz, 4 GB, SMC 1.58f17
    Graphics: Intel HD Graphics, Intel HD Graphics, Built-In
    Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x384A53463235363634485A2D314731443120
    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x384A53463235363634485A2D314731443120
    Network Service: Ethernet, Ethernet, en0
    Serial ATA Device: Samsung SSD 840 Series, 250,06 GB
    Serial ATA Device: MATSHITADVD-R UJ-898
    USB Device: USB 2.0 Bus
    USB Device: Hub
    USB Device: USB OPTICAL MOUSE
    USB Device: Card Reader
    USB Device: Apple Internal Keyboard / Trackpad
    USB Device: USB 2.0 Bus
    USB Device: Hub
    USB Device: IR Receiver
    USB Device: Built-in iSight
    Thunderbolt Bus:
     
  16. AlainD. macrumors newbie

    AlainD.

    Joined:
    May 25, 2016
    #41
    I tried his method on mine, and it worked perfectly. I did not used his file though, but I modified my file with the same values as his, except that I have an extra line in my own plist.info which was not listed in his (I don't remember which one).

    Probably you missed one step. So restore your files with the original ones, and follow exactly all the steps top to bottom.
     
  17. Fhiiz macrumors newbie

    Joined:
    Sep 6, 2016
    #42

    Well ok i'm gonna do this, telling you if something get fixed
     
  18. fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #43


    In your .log, the AppleGraphicsPowerManagement.kext is not present. So, it was not loaded. Something is wrong, check.
    --- Post Merged, Sep 6, 2016 ---

    Great!
     
  19. lapinus macrumors newbie

    Joined:
    Apr 30, 2012
    #44
    Hi fabioroberto,

    I have the same issue for years and my I was using my Mac for a paperweight from now on then. I'm not a tech savvy guy and I have to admit I've stuck on the first step. When you have time, would you consider to create a guide for non-techs like me?

    I'm always ok with this guides but can't do anything without them. I don't even know where to locate kext files:)

    Thanks!
     
  20. fabioroberto, Sep 7, 2016
    Last edited: Oct 3, 2016

    fabioroberto macrumors regular

    Joined:
    Mar 5, 2013
    #45

    Hi, lapinus

    i'll try explain just a little bit better


    I believe that you are using the latest combo 10.11.6, ok? If not, please install last combo (10.11.6). Why this? Because you said that you do not have good knowledge to edit system files. And.. so we are sure that the system is ok.


    After, please, boot into Recovery Mode. How? Simple:

    1 Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on your screen.

    2 Click Utilities > Terminal.

    3 In the Terminal window, type in: csrutil disable and press Enter.

    4 Restart your Mac.


    Ok, now you are into OSX again.

    Please, if possible, search and download a app called: Kext Drop. (this is not marketing, okay?) Only to facilitate the process.



    Download my AppleGraphicsPowerManagement.kext (already edited) here:
    https://dl.dropboxusercontent.com/u/35721057/AppleGraphicsPowerManagement.kext.zip


    Open Kext Drop and drag .kext inside. Press install.

    Attention, this .kext only works if the system is upgraded to 10.11.6.

    (But the “hack” manual in .plist can be done in other versions of OSX)



    Reboot.


    To check, open Console app (type in the spotlight), and search for: GFX0



    Like this:
    https://dl.dropboxusercontent.com/u/35721057/console.png




    Test if this ok and free GPU Panic.



    (Edited)
    AppleGraphicsPowerManagement.kext 10.12
    https://dl.dropboxusercontent.com/u/35721057/10.12.AppleGraphicsPowerManagement.kext.zip
     
  21. AlainD. macrumors newbie

    AlainD.

    Joined:
    May 25, 2016
    #46
    For info, Kext Drop seems to be not compatible with Yosemite (I didn't try though, but it is written so on their website). So I used Kext Utility.app instead to install the modified kext.
     
  22. Clete2 macrumors 65816

    Clete2

    Joined:
    Sep 20, 2008
    Location:
    USA
    #47
    Where did you find this / how do I verify my issue is the same / where do I buy one of these / are you 100% sure?
     
  23. gregwtmtno macrumors newbie

    Joined:
    Sep 8, 2016
    #48
    Hi fabioroberto,

    Thanks so much for this guide! I have been looking for a solution to this problem for a long time! I have modified my kext file and installed it. (I used a different method to install the kext.) I believe it has loaded correctly, because I am getting messages in the console log:


    gfx0.png

    It is too soon to know if my computer will still crash, but I will update everyone when I know more.

    Thanks again,

    Greg
     
  24. greyosx macrumors newbie

    Joined:
    Sep 3, 2016
    #49
    Can you please share what your method was for installing the kext?

    I'm waiting for the release of Sierra to do the fix just to avoid any possible issues.
     
  25. gregwtmtno macrumors newbie

    Joined:
    Sep 8, 2016
    #50
    Sure, greyosx. My method is more complex than fabioroberto's method but I used it because I'm familiar with the command line. This is all on El Capitan. I can't speak for Sierra, but I will likely do this on Sierra once that is released, so I'll try to update people on how that goes.

    1. Disable system integrity protection
    To do this, you need to enter recovery mode by holding down Command-R on boot up. Once in recovery mode, open the terminal and then type "csrutil disable". After that, reboot the machine.​

    2. Enter Console Mode.
    Hold down Command-S on boot up.
    3. Backup the old kext.
    First type "mount -uw /" to make the hard drive writable. Next, you need to make a temporary folder to store the backup. I used /_temp. Type "mkdir /_temp". Now we need to copy the kext to the backup folder. "mv /System/Library/Extensions/AppleGraphicsPowerManagement.kext /_temp/"
    4. Copy in new kext
    This is where my method differs from fabioroberto's. I will use the command line to install the new kext. Fabioroberto used an app called Kext Drop. The exact commands to run here will depend on where your new kext is. Your new kext will be the one you downloaded from fabioroberto's post or maybe you made one yourself as per fabioroberto's instructions. My new kext was on my desktop. "cp -r /Users/greg/Desktop/AppleGraphicsPowerManagement.kext /System/Library/Extensions/"
    5. Install new kext
    Run "kextcache -v 1 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions/". I don't know exactly how this command works, but I got it off a different post about a similar problem. That post is here: http://www.asyncro.com/2014/03/24/macbook-pro-discreate-graphics-card-issue-fix-updated/
    6. Reboot
    Type "reboot now". The computer will output some stuff to the command line and reboot after a minute or two. The first reboot WILL FAIL. That is expected. Don't panic. It should automatically reboot again, and on the second try it should boot normally.
    Good luck and let me know if anything is unclear.
     

Share This Page