Graphic Bug Yosemite (Files and Folders disappear)

Discussion in 'OS X Yosemite (10.10)' started by accode44, Oct 26, 2014.

  1. accode44 macrumors newbie

    Joined:
    Oct 26, 2014
    #1
    Hi, after a clean install of OS X Yosemite (on my both rMPR 15' mid-2012 and rMBP Late2013 ) I noticed that my files disappear when my wifi is on, they appear (a few seconds) when I disable the wifi.

    Do you have the same problem ?
     

    Attached Files:

  2. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #2
    Try switching to list view (from icon view) and they should return.

    I saw this bug in the betas, and immediately reported it, I kept reporting it in each new GM candidate, and it wasn't fixed through to release...

    It doesn't only depend on wifi, I think it requires the integrated intel GPU to be active too, I find it isn't always reproducible (which hopefully is why Apple didn't fix it). For me all icons disappear, and using the icon zoom slider causes corruption within the finder window.

    rMBP 10,1
     
  3. webberade macrumors member

    webberade

    Joined:
    May 6, 2013
    Location:
    New York, NY
    #3
    This is happening to me as well and it is super annoying. I find that relaunching the Finder gets everything back to normal though. I've tried to replicate the issue but can't seem to find out what triggers it.
     

    Attached Files:

  4. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #4
    You're also on a HiDPI display I assume. Does toggling wifi change anything? I wonder if the wifi toggling somehow affects the Finder sidebar...

    I also notice if I shrink the Finder window to its minimum width then icon mode will work sometimes.

    You're both running dropbox in your screenshots, but I can trigger the bug when dropbox is closed.
     
  5. MSQ macrumors newbie

    Joined:
    Jun 14, 2011
    Location:
    Tennessee
    #5
    I had the same issue with an upgrade over Mavericks and again with a clean install of Yosemite (Retina MacBook Pro Late 2013). I did not have this issue with Mavericks, so it seems it's Yosemite specific. Never could peg the cause as it was always happening at random times. Big enough issue that I downgraded back to Mavericks as a result and have not had a problem since.
     
  6. Beavix, Oct 27, 2014
    Last edited: Oct 27, 2014

    Beavix macrumors 6502a

    Beavix

    Joined:
    Dec 1, 2010
    Location:
    Romania
    #6
    Exactly the same issue here too.

    On my computer I can easily reproduce the bug:
    - Switch to icons view mode.
    - Drag the sidebar edge left and right a few times until I notice some black display artifacts.
    - Drag the bottom-right corner of the window a few times to resize it.
    - Boom.

    rMBP 15", Late 2013, Iris Pro Graphics.
     
  7. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #7
    Yes, I also realised this has to do with the sidebar.

    1. If you resize the sidebar width to be a slim as possible, the bug never triggers.
    2. Make sure your finder window is about 1/3rd of your screen width, then start to slide the sidebar wider, after about 100px or so you'll notice you get glitchy black display artifacts, that means the icon view has just broken.
    3. Resize larger still and at some point it may work again.
    4. This behaviour may be affected by custom sidebar items of different lengths. I notice the sidebar can sometimes "lock" to a position if some text is longer (I have "Automatically add to iTunes" folder in my sidebar which does this, removing this item doesn't fix the bug however).
    5. Turn the sidebar off and this bug never triggers.

    So this bug depends on both the width of the sidebar and the width of the finder window. I think these are related as as you make the finder window narrower it also starts to resize the sidebar.
     

Share This Page