Graphic glitches with 10.12.5 and GTX 1070

Discussion in 'Mac Pro' started by omvs, May 26, 2017.

  1. omvs, May 26, 2017
    Last edited: May 26, 2017

    omvs macrumors 6502

    Joined:
    May 15, 2011
    #1
    Seems like ever since I upgraded to 10.12.5 I've been getting tons of graphic glitches -- where a window would either be black, scrambled, or sometimes show content and sometimes go back to black. Might only happen on 1 tab out of a few on safari, but I might also see it in iChat or other windows. Not seeing it at all on the screensharing window (vnc to work), but I suspect that uses a greatly reduced set of graphics primitives and just pretty much blasting bits from the vnc

    Oddly enough my laptop doesn't seem to exhibit the same behavior, though its also on 10.12.5 and using a GTX 1060.

    Didn't see any other threads mentioning this - is nobody else having problems?
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #2
    No issues here with my MVC flashed Gigabyte GTX 1080.

    Lou
     
  3. omvs thread starter macrumors 6502

    Joined:
    May 15, 2011
    #3
    As a test I swapped the 1060 into my mac pro, and all the problems seemed to go away. The 1070 as a epgu for the laptop seemed fine too, though didn't use it as long.

    Just put the 1070 back in and getting glitches again. It looks like the glitches actually survive a screen shot - here's what Messages looks like when its glitching:

    Messages.png
     
  4. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #4
    That screen shot looks like a common effect for failing GPUs. I'd do a support call and I wouldn't be surprised if you end up with a warranty replacement.
     
  5. omvs thread starter macrumors 6502

    Joined:
    May 15, 2011
    #5
    It's not a failing gpu:

    Both the 1060 and 1070 do this in my Mac Pro under OS X. Both are fine under windows. both are fine under OS X when used as epgus on my laptop

    It might be related to having the gpu in the second slot from the bottom. I have to put my gtx 120 in the bottom slot or it won't give a boot screen. When I have the 1060/1070 by itself in bottom slot seems to be okay. But without the boot screen I can't use FileVault and it makes it a lot harder to switch to windows.

    Also appears to be fine if a monitor is hooked up to the gtx 120 and I mirror displays though I'm guessing it's just copying data from the gtx120 to the gtx 1060/1070. Since that kills 3D performance it's not exactly acceptable either.

    Even reverted to 10.12.4 as a test. That actually seems worse to back on 10.12.5

    Are others using with another card as bootscreen?
     
  6. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
    #6
    We have a person on this forum who will tell you these problems don't exist no matter how many times you raise it. You have to be careful who you take advice from on forums because sometimes someone is a salesman earning commissions for mentioning certain video cards. So we have this issue for two years that professional users were being coerced to use beta drivers on cards that aren't officially supported.
     
  7. bitnaut macrumors newbie

    bitnaut

    Joined:
    May 10, 2014
    #7
    I'm having the same problem ever since I upgraded to 10.12.5 using the latest NVidia web driver on my Titan X and regular Titan video cards.

    It seems to be something with WebKit since the corruption only occurs in Safari or Mail content windows. It does not occur using Chrome.

    Also, sometimes if I move the cursor too fast within Safari or Mail, the GPU will crash and my Mac 5,1 will do a soft reboot back to the login screen.
     
  8. Norbert Mikołajczyk macrumors member

    Norbert Mikołajczyk

    Joined:
    May 26, 2016
    #8
    I got this also on my rMBP with gtx750m when using dual screen couple of months ago, but not recently.
    I went to the apple, they inspected machine and run some test and they said that everything is fine...
     
  9. ActionableMango, Jun 8, 2017
    Last edited: Jun 8, 2017

    ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #9
    Well okay, I change my mind then. To be fair, earlier I feel like you said literally the opposite:
    --------

    I hope you are not referring to me. If so, then this is 100% false. Yesterday I just made a post linking/listing all of the Nvidia driver problems in another thread. I have no skin in this game at all. I don't even have a Mac Pro any more because I got tired of GPU limitations.
     

Share This Page